aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <cjk34@cam.ac.uk>2013-12-02 22:11:07 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-08 18:36:48 +0100
commit898ce1132382259cfc257a5dbc5d84c8d862e168 (patch)
treeff79b21e9504f51d1a00bf16be5ec1025e471f4e /sci-libs/xraylib/xraylib-2.16.0.ebuild
parentsci-libs/mkl: Fix linking problems with openmp support, #492802; thanks Andre... (diff)
downloadsci-898ce1132382259cfc257a5dbc5d84c8d862e168.tar.gz
sci-898ce1132382259cfc257a5dbc5d84c8d862e168.tar.bz2
sci-898ce1132382259cfc257a5dbc5d84c8d862e168.zip
New ebuild for xraylib
Diffstat (limited to 'sci-libs/xraylib/xraylib-2.16.0.ebuild')
-rw-r--r--sci-libs/xraylib/xraylib-2.16.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/xraylib/xraylib-2.16.0.ebuild b/sci-libs/xraylib/xraylib-2.16.0.ebuild
new file mode 100644
index 000000000..e699dffdb
--- /dev/null
+++ b/sci-libs/xraylib/xraylib-2.16.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 python3_1 python3_2 python3_3 )
+inherit eutils autotools-utils python-r1
+
+DESCRIPTION="A library for X-ray matter interaction cross sections for X-ray fluorescence applications"
+HOMEPAGE="https://github.com/tschoonj/xraylib"
+SRC_URI="https://github.com/tschoonj/xraylib/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cxx examples fortran java lua perl python"
+
+DEPEND="fortran? ( virtual/fortran )
+ java? ( virtual/jdk )
+ lua? ( dev-lang/lua )
+ perl? ( dev-lang/perl )
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}"