aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <cjk34@cam.ac.uk>2013-12-02 22:27:59 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-08 18:36:48 +0100
commite153914b3212d9bcf02500bbbab0746cbc4834d1 (patch)
treeea8d7c123495f4d9e799c3299b3daf6985197068 /sci-libs/xraylib
parentNew ebuild for xraylib (diff)
downloadsci-e153914b3212d9bcf02500bbbab0746cbc4834d1.tar.gz
sci-e153914b3212d9bcf02500bbbab0746cbc4834d1.tar.bz2
sci-e153914b3212d9bcf02500bbbab0746cbc4834d1.zip
Added myeconfargs so the USE flags actually affect the compilation
Diffstat (limited to 'sci-libs/xraylib')
-rw-r--r--sci-libs/xraylib/xraylib-2.16.0.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/sci-libs/xraylib/xraylib-2.16.0.ebuild b/sci-libs/xraylib/xraylib-2.16.0.ebuild
index e699dffdb..889f1bf19 100644
--- a/sci-libs/xraylib/xraylib-2.16.0.ebuild
+++ b/sci-libs/xraylib/xraylib-2.16.0.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/tschoonj/xraylib/archive/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="cxx examples fortran java lua perl python"
+IUSE="cxx examples fortran java lua perl php python ruby"
DEPEND="fortran? ( virtual/fortran )
java? ( virtual/jdk )
@@ -23,3 +23,21 @@ DEPEND="fortran? ( virtual/fortran )
${PYTHON_DEPS}"
RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-idl
+ $(use-enable fortran fortran2003)
+ $(use-enable java)
+ $(use-enable lua)
+ $(use-enable perl)
+ $(use-enable perl perl-integration)
+ $(use-enable php)
+ $(use-enable php php-integration)
+ $(use-enable python)
+ $(use-enable python python-integration)
+ $(use-enable ruby)
+ $(use-enable ruby ruby-integration)
+ )
+ autotools-utils_src_configure
+}