aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@saffron.(none)>2009-04-16 17:39:26 +0100
committerSebastien Fabbro <seb@saffron.(none)>2009-04-16 17:39:26 +0100
commitf1f1b12823f83b6b481cd95bf06f33d5a83c011f (patch)
treeb125f5c60195e8b5ef296be082eb707cdd343b44 /sci-libs/zarja
parentanother qa for pymol Thanks bicatali (diff)
downloadsci-f1f1b12823f83b6b481cd95bf06f33d5a83c011f.tar.gz
sci-f1f1b12823f83b6b481cd95bf06f33d5a83c011f.tar.bz2
sci-f1f1b12823f83b6b481cd95bf06f33d5a83c011f.zip
Added zarja
Diffstat (limited to 'sci-libs/zarja')
-rw-r--r--sci-libs/zarja/ChangeLog10
-rw-r--r--sci-libs/zarja/Manifest4
-rw-r--r--sci-libs/zarja/metadata.xml10
-rw-r--r--sci-libs/zarja/zarja-1.1.1.ebuild43
4 files changed, 67 insertions, 0 deletions
diff --git a/sci-libs/zarja/ChangeLog b/sci-libs/zarja/ChangeLog
new file mode 100644
index 000000000..7bd5f750c
--- /dev/null
+++ b/sci-libs/zarja/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/zarja
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*zarja-1.1.1 (16 Apr 2009)
+
+ 16 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +zarja-1.1.1.ebuild:
+ Initial import to science overlay - bug #254832 - Thanks Hynek Lavička
+
diff --git a/sci-libs/zarja/Manifest b/sci-libs/zarja/Manifest
new file mode 100644
index 000000000..8a0a38ffc
--- /dev/null
+++ b/sci-libs/zarja/Manifest
@@ -0,0 +1,4 @@
+DIST zarja-1.1.1.tar.gz 1368076 RMD160 16424eebecf3b9fbc6e97c003c24db8c3c0854af SHA1 46cb19175588022fbfb22cfb171588cd27517dec SHA256 279198e15dca274ba4cdef2cb2e997e74e32bf5a92cc9b6d0d08f264131b8f38
+EBUILD zarja-1.1.1.ebuild 831 RMD160 035842b47b30470fa84dd437f26722c5be600f29 SHA1 e799864e47677b61e8640d28e1c3729be81129c9 SHA256 a5c0efaae288577887522bd6914f6596d3a3c7f0da4d743d6af34499770eb7ed
+MISC ChangeLog 311 RMD160 4457e3466fd847379d09201521ca747eef1b851e SHA1 a75a90955025ced539c44042608160f0621065ce SHA256 0911d32ef2d92cbfa8eba2d4ae7c9493d3510077ff584f4453fd151124e1dd46
+MISC metadata.xml 365 RMD160 dbaffecd0070af06696a92a87048e43b6445bb97 SHA1 e6660756fa1244ef6eb1f8863da4755ffdb6e8f8 SHA256 0c12c7086797f11dc5c795deb03039a94ebc7df745c0799e68d6434dbc04f37a
diff --git a/sci-libs/zarja/metadata.xml b/sci-libs/zarja/metadata.xml
new file mode 100644
index 000000000..6a944909c
--- /dev/null
+++ b/sci-libs/zarja/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Zarja is open-source library that allows to make multi-agent
+ simulations on graphs. Its functionality was proved in Classical or
+ Quantum mechanical models.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/zarja/zarja-1.1.1.ebuild b/sci-libs/zarja/zarja-1.1.1.ebuild
new file mode 100644
index 000000000..9754cad79
--- /dev/null
+++ b/sci-libs/zarja/zarja-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="Scientific multi-agent simulation library"
+HOMEPAGE="http://sourceforge.net/projects/zarja/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="sci-libs/gsl
+ virtual/lapack
+ >=sci-libs/fftw-3
+ dev-libs/boost
+ dev-cpp/tclap"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf --includedir=/usr/include/zarja
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ doxygen Doxyfile || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc README AUTHORS FAQ
+ if use doc; then
+ dohtml html/* || die
+ fi
+}