aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-11-08 23:24:20 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-11-08 23:24:38 +0800
commit051efe62ff7b5696889b5fe99a6cccb60848ac44 (patch)
tree10e7bf930c38413ede619e401e1f1ebf9ad5b254 /sci-libs
parentsci-libs/ensmallen: version bump to 2.15.0 (diff)
downloadsci-051efe62ff7b5696889b5fe99a6cccb60848ac44.tar.gz
sci-051efe62ff7b5696889b5fe99a6cccb60848ac44.tar.bz2
sci-051efe62ff7b5696889b5fe99a6cccb60848ac44.zip
sci-libs/pytorch: give cmake a fake /dev/nvidiactl.
This disables the auto detection of CUDA compute capabilities. Reported-by: Hendrik Klug Suggested-by: Simon Detheridge Closes: https://bugs.gentoo.org/742617 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pytorch/pytorch-1.6.0-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sci-libs/pytorch/pytorch-1.6.0-r1.ebuild b/sci-libs/pytorch/pytorch-1.6.0-r1.ebuild
index b81be39e6..0708ef6d3 100644
--- a/sci-libs/pytorch/pytorch-1.6.0-r1.ebuild
+++ b/sci-libs/pytorch/pytorch-1.6.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1 cmake-utils cuda
+inherit distutils-r1 cmake cuda
MPV=${PV/_p/a}
@@ -153,6 +153,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-1.6.0-nccl-nvccflags.patch
ln -s . nccl || die
+ addpredict /dev/nvidiactl
cuda_src_prepare
export CUDAHOSTCXX=$(cuda_gccdir)/g++
fi