aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <cjk34@cam.ac.uk>2013-12-02 23:37:40 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-08 18:36:48 +0100
commit09afb7a67f56eddda5a35e26437ca378c2393d09 (patch)
tree78725b1ca0a7740f446bee3efb4bb2cc8e2f14a8 /sci-libs
parentAdded fortran-2 eclass, tweaked python stuff (diff)
downloadsci-09afb7a67f56eddda5a35e26437ca378c2393d09.tar.gz
sci-09afb7a67f56eddda5a35e26437ca378c2393d09.tar.bz2
sci-09afb7a67f56eddda5a35e26437ca378c2393d09.zip
Workaround for parallel compilation bug with fortran
Also Doh! on use_enable not use-enable!
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/xraylib/xraylib-2.16.0.ebuild31
1 files changed, 20 insertions, 11 deletions
diff --git a/sci-libs/xraylib/xraylib-2.16.0.ebuild b/sci-libs/xraylib/xraylib-2.16.0.ebuild
index 113a28389..c87f7c24e 100644
--- a/sci-libs/xraylib/xraylib-2.16.0.ebuild
+++ b/sci-libs/xraylib/xraylib-2.16.0.ebuild
@@ -39,17 +39,26 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--disable-idl
- $(use-enable fortran fortran2003)
- $(use-enable java)
- $(use-enable lua)
- $(use-enable perl)
- $(use-enable perl perl-integration)
- $(use-enable php)
- $(use-enable php php-integration)
- $(use-enable python)
- $(use-enable python python-integration)
- $(use-enable ruby)
- $(use-enable ruby ruby-integration)
+ $(use_enable fortran fortran2003)
+ $(use_enable java)
+ $(use_enable lua)
+ $(use_enable perl)
+ $(use_enable perl perl-integration)
+ $(use_enable php)
+ $(use_enable php php-integration)
+ $(use_enable python)
+ $(use_enable python python-integration)
+ $(use_enable ruby)
+ $(use_enable ruby ruby-integration)
)
autotools-utils_src_configure
}
+
+src_compile() {
+ if use fortran
+ then # see https://github.com/tschoonj/xraylib/issues/11
+ emake -j1
+ else
+ emake
+ fi
+} \ No newline at end of file