aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-20 10:40:39 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-20 10:40:39 +0100
commit2497d3d59d9e67dcc67eb8687964e57d18b6993c (patch)
tree3d51d86eccd674b9319a1d5b97a076b2f4a1eeef /sci-libs
parentsci-libs/nipy: drop old: failed REQUIRED_USE: py_targets_py3_7 (diff)
downloadsci-2497d3d59d9e67dcc67eb8687964e57d18b6993c.tar.gz
sci-2497d3d59d9e67dcc67eb8687964e57d18b6993c.tar.bz2
sci-2497d3d59d9e67dcc67eb8687964e57d18b6993c.zip
sci-libs/nipype: drop old failed REQUIRED_USE: py_targets_py3_7
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nipype/Manifest2
-rw-r--r--sci-libs/nipype/nipype-1.1.1-r2.ebuild70
-rw-r--r--sci-libs/nipype/nipype-1.4.2.ebuild67
3 files changed, 0 insertions, 139 deletions
diff --git a/sci-libs/nipype/Manifest b/sci-libs/nipype/Manifest
index cbf353bd7..a3c77d4ff 100644
--- a/sci-libs/nipype/Manifest
+++ b/sci-libs/nipype/Manifest
@@ -1,3 +1 @@
-DIST nipype-1.1.1.tar.gz 3353518 BLAKE2B 509b6c2b18aab8c8ddfad3ca4ac87401caf0608ee566edecaa20a4329a3bfd9d67dae730ac45342600b4026b66c5043d753d09e5230269d3fc4b946d049ad11e SHA512 dba749ff3b53dfe19992a27f9ad9aedcd360b51b3bf7233bf4b83387ae7181425b27ef43d23747553e9f8eb368b6769d6bec62650e1303ec353dde4de84f1769
-DIST nipype-1.4.2.tar.gz 2823870 BLAKE2B 3af3a5e45fada174908723afd8c747575cba4c8489cd894fdced68a5b10b0638f871c600df921b61a4e809c43ea3b827539410ed713f14829d60f207d5bd8cfd SHA512 f913d1a63105ccb8392adfdba5ec52b3e5ce0c9ad145b062f6e551a811602b77a52f1f6e89d9d5ff366e9b063f0ab965cfbd6ae5f68a79e25e8970e1a864901c
DIST nipype-1.5.0.tar.gz 2735317 BLAKE2B d618714b15defde52325bac32a80449846b448d1c141a21f9d950976c8c89624d714dbab10b4cd99fe20d4eb99ceb4095ebc6ddc567f57b3803e2c16ffda155a SHA512 eb11096a090855278c3e76ffe9643ab4de046a017511ba51f59448fd8cf9d67a4f6c552acbbbdd38065cfb456c24fd21299cf698fa05c5be507524622f28ac85
diff --git a/sci-libs/nipype/nipype-1.1.1-r2.ebuild b/sci-libs/nipype/nipype-1.1.1-r2.ebuild
deleted file mode 100644
index 734fae8fc..000000000
--- a/sci-libs/nipype/nipype-1.1.1-r2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
-HOMEPAGE="http://nipy.sourceforge.net/nipype/"
-SRC_URI="https://github.com/nipy/nipype/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/prov[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- sci-libs/nibabel[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ${RDEPEND}
- )
-"
-# Dependency disabled as upstream test configuration which requires it fails
-#dev-python/pytest-xdist[${PYTHON_USEDEP}]
-
-RDEPEND="
- >=dev-python/click-6.6[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pydot[${PYTHON_USEDEP}]
- dev-python/pydotplus[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/traits[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-"
-
-src_prepare() {
- sed -i\
- -e "/'pytest>=%s' % PYTEST_MIN_VERSION,/d"\
- -e "/'pytest-xdist',$/d"\
- -e "/'prov==%s' % PROV_VERSION,/d"\
- nipype/info.py || die
- sed -i\
- -e "s/prov==1\.5\.0/prov/g"\
- requirements.txt rtd_requirements.txt || die
- default
-}
-
-python_test() {
- pytest -vv\
- || die
- # Upstream test configuration fails
- #-c nipype/pytest.ini\
- #--doctest-modules nipype\
- #--cov nipype\
- #--cov-config .coveragerc\
- #--cov-report xml:cov.xml\
-}
diff --git a/sci-libs/nipype/nipype-1.4.2.ebuild b/sci-libs/nipype/nipype-1.4.2.ebuild
deleted file mode 100644
index 1f91463b6..000000000
--- a/sci-libs/nipype/nipype-1.4.2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
-HOMEPAGE="http://nipy.sourceforge.net/nipype/"
-SRC_URI="https://github.com/nipy/nipype/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/prov[${PYTHON_USEDEP}]
- sci-libs/nibabel[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ${RDEPEND}
- )
-"
-# Dependency disabled as upstream test configuration which requires it fails
-#dev-python/pytest-xdist[${PYTHON_USEDEP}]
-
-RDEPEND="
- >=dev-python/click-6.6[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pydot[${PYTHON_USEDEP}]
- dev-python/pydotplus[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/traits[${PYTHON_USEDEP}]
-"
-#etelemetry and neurdflib
-
-src_prepare() {
- sed -i \
- -e "/def test_no_et(tmp_path):/i@pytest.mark.skip('Known to fail by upstream: https://github.com/nipy/nipype/issues/3196#issuecomment-606003186')" \
- nipype/tests/test_nipype.py || die
- sed -i \
- -e "/def test_fslversion():/i@pytest.mark.skip('Known to fail by upstream: https://github.com/nipy/nipype/issues/3196#issuecomment-605997462')" \
- nipype/interfaces/fsl/tests/test_base.py || die
- default
-}
-
-python_test() {
- NIPYPE_NO_ET=1 pytest -vv\
- || die
- # Upstream test configuration fails
- #-c nipype/pytest.ini\
- #--doctest-modules nipype\
- #--cov nipype\
- #--cov-config .coveragerc\
- #--cov-report xml:cov.xml\
-}