aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-06-26 02:50:14 +0200
committerHorea Christian <horea.christ@yandex.com>2018-06-26 02:50:14 +0200
commit2afd2fbdee20a8b42f5fc9bdc7d696774e567650 (patch)
tree49926fb7eda6b48b1afcc0a110d25690319906a9 /sci-libs
parentsci-biology/ants: Version bump and improvements (diff)
downloadsci-2afd2fbdee20a8b42f5fc9bdc7d696774e567650.tar.gz
sci-2afd2fbdee20a8b42f5fc9bdc7d696774e567650.tar.bz2
sci-2afd2fbdee20a8b42f5fc9bdc7d696774e567650.zip
sci-libs/nipype: version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nipype/Manifest1
-rw-r--r--sci-libs/nipype/nipype-0.14.0_pre20170830.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/nipype/Manifest b/sci-libs/nipype/Manifest
index 9d73a7316..307d00372 100644
--- a/sci-libs/nipype/Manifest
+++ b/sci-libs/nipype/Manifest
@@ -1,3 +1,4 @@
DIST nipype-0.11.0.tar.gz 2837853 SHA256 b1a69fbda7ce044ec24c2536f5733dfc251d16b4a713cab65f893d7e3357b437 SHA512 2b54cb5e57081b49565644a02d319477ecddb41ce6a6689c7f72f5381850afee2ce18ea4d0097ef0cb150fdff4980e1fc6a9c04d9a37610b65179727e8d8a82f WHIRLPOOL a406e44b13df4a90557f745753c19ee949b3267cf68245fb4ab3d23300e39aa481a36c47b690cf40681a1f1c4ffe772b88f36c71827debc23526604333683539
DIST nipype-0.12.0.tar.gz 3088339 BLAKE2B 640ef5192c5502aa0eb12354547ac701de150fcd44a65a48d393263612ae69760186daed9400ad92823a52e303980eca0df3a481e93287160ded2f332c4f37a9 SHA512 cb882fb8d20ae8a12b1f333cb5812a1de608158cee0e75b367d97980c6b55e27e8217dbfbd57f5df7da980dd8ac86692c393553ac66ea0e77f7b9a232b6be728
DIST nipype-0.12.1.tar.gz 3092631 BLAKE2B 2081274ba8e5aaa993f29ffc46421e0910759861513f5445a3960298446e7f69d3d482fe5c4569dd2313a0c933b80ff2f66e2b2121325389fa13f3942bc96df0 SHA512 feab0f71c1274a19f6861d73e7c94cd2d35858404c8ef1bf62a35da030ad5fc96ad86370043f018e919c90574b70d56051c3894709c139cecae5117cb2681527
+DIST nipype-0.14.0_pre20170830.tar.gz 3290267 BLAKE2B ef5ca5000e4d0d6d0079dd39e9f798aae5bff9de4ac58c8418bd46e2425ac3ec0d8cc9038a6cff9987b9b7c3e702f29c16d00e4896c2218afac03376fa0978a5 SHA512 0280312e6c80b10ee5463991baeff12cef5ff46c05ea294cdb889594b74cf92bdd5d5d93a9c8facbf888d11d60cdd549df82f262356ae1c59b6eb1bfff813b5e
diff --git a/sci-libs/nipype/nipype-0.14.0_pre20170830.ebuild b/sci-libs/nipype/nipype-0.14.0_pre20170830.ebuild
new file mode 100644
index 000000000..0fc65a5ce
--- /dev/null
+++ b/sci-libs/nipype/nipype-0.14.0_pre20170830.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1
+
+COMMIT="7055313c91de52bf65518284b42df446466fe581"
+
+DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
+HOMEPAGE="http://nipy.sourceforge.net/nipype/"
+SRC_URI="https://github.com/nipy/nipype/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ =dev-python/prov-1.5.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-2.0.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7)
+ "
+RDEPEND="
+ >=dev-python/click-6.6[${PYTHON_USEDEP}]
+ dev-python/funcsigs[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pydotplus[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/traits-4.6.0[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ EXISTING_REQUIRE="setup_requires=\['future', 'configparser'\]"
+ CORRECTED_REQUIRE="setup_requires=\['future'\]"
+ sed \
+ -e "s/${EXISTING_REQUIRE}/${CORRECTED_REQUIRE}/g" \
+ -i setup.py \
+ || die "sed setup.py"
+}
+
+python_test() {
+ nosetests -v || die
+}