aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-20 20:57:23 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-20 20:57:23 +0000
commit2ba15ee1208acbbf6c97e8dc59b16be201dfb364 (patch)
tree7aa860cff22a5991ff028da3bfeb75bf77d4fdba /sci-libs
parentyorick-2.1.05 (diff)
downloadsci-2ba15ee1208acbbf6c97e8dc59b16be201dfb364.tar.gz
sci-2ba15ee1208acbbf6c97e8dc59b16be201dfb364.tar.bz2
sci-2ba15ee1208acbbf6c97e8dc59b16be201dfb364.zip
mkl: more polishing
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@982 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mkl/Manifest2
-rw-r--r--sci-libs/mkl/mkl-10.0.2.018.ebuild13
2 files changed, 8 insertions, 7 deletions
diff --git a/sci-libs/mkl/Manifest b/sci-libs/mkl/Manifest
index 3e2c49474..4ca7c6a49 100644
--- a/sci-libs/mkl/Manifest
+++ b/sci-libs/mkl/Manifest
@@ -1,4 +1,4 @@
AUX mkl-10.0.2.018-openmpi.patch 332 RMD160 255a2cb3fdba6fd1803d830e9cd791da954d958f SHA1 6a3a7b690873c9bc4c003f47739dfa9394ab9627 SHA256 758c3aef0124932426002aa502c0e7b721a026d6c54c37c679d3ee7eb607b58c
AUX mkl-10.0.2.018-tests.patch 528 RMD160 15f11a38567bd533626008fce62e6021372bfc53 SHA1 8c9358d798f597e87d8a62fff27b79123273ebe3 SHA256 f65a074c64a3969b08d41f88874f25fdc06693b5a5aee930bd7ef9763e94e71d
DIST l_mkl_p_10.0.2.018.tgz 227440983 RMD160 0c28416597ef917328193fa0c6403d7c0e7b971d SHA1 1aa8c47701b142ab52ebcda27fdda4c5d0903471 SHA256 311d2885a33d553a2d1b1370eed1e3e9bccc246f2dcd20e3558ed492443ba20f
-EBUILD mkl-10.0.2.018.ebuild 8933 RMD160 87503b074bd00f371a34f6f2f42451453ae3e107 SHA1 8d11e096325f3ea78cd7e1191864a13f4b42f447 SHA256 802e2c328778cda9216d76672bcdf00273ef137d4b7b9354f7e1de2dc784644b
+EBUILD mkl-10.0.2.018.ebuild 8967 RMD160 f6e8817e975b537b8576af68d06c9fa0076010b7 SHA1 cfcbdd1241f42fa677883e325c3e647406fa26d3 SHA256 3aaf6b12c5042b628134ab09f7caadfed44e48dbd4ada5423302a6a57dc0613a
diff --git a/sci-libs/mkl/mkl-10.0.2.018.ebuild b/sci-libs/mkl/mkl-10.0.2.018.ebuild
index e502100ea..79392c91a 100644
--- a/sci-libs/mkl/mkl-10.0.2.018.ebuild
+++ b/sci-libs/mkl/mkl-10.0.2.018.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="http://developer.intel.com/software/products/mkl/"
KEYWORDS="~amd64 ~ia64 ~x86"
SRC_URI="http://registrationcenter-download.intel.com/irc_nas/${PID}/l_${PN}_p_${PV}.tgz"
-#slotting not yet supported (would need a mkl-config)
+#slotting not yet supported (need eselect-mkl)
#MAJOR=$(get_major_version ${PV})
#MINOR=$(get_version_component_range 2 ${PV})
#SLOT="${MAJOR}.${MINOR}"
@@ -33,16 +33,17 @@ RDEPEND="${DEPEND}
mpi? ( virtual/mpi )"
MKL_DIR=/opt/intel/${PN}/${PV}
+INTEL_LIC_DIR=/opt/intel/licenses
pkg_setup() {
# Check the license
- [[ -z ${MKL_LICENSE} && -d /opt/intel/licenses ]] && \
- MKL_LICENSE=$(find /opt/intel/licenses -name *MKL*.lic)
+ [[ -z ${MKL_LICENSE} && -d ${INTEL_LIC_DIR} ]] && \
+ MKL_LICENSE=$(find ${ROOT}/${INTEL_LIC_DIR} -name "*MKL*.lic" | tail -n 1)
if [[ -z ${MKL_LICENSE} ]]; then
eerror "Did not find any valid mkl license."
eerror "Register at ${HOMEPAGE} to receive a license"
- eerror "and place it in /opt/intel/licenses or run:"
+ eerror "and place it in ${INTEL_LIC_DIR} or run:"
eerror "\t MKL_LICENSE=/my/license/dir emerge mkl"
die "license setup failed"
fi
@@ -274,8 +275,8 @@ src_install() {
dosym ${MKL_DIR} ${MKL_DIR/mkl/cmkl}
# install license
- if [[ ! -f /opt/intel/licenses/${MKL_LIC} ]]; then
- insinto /opt/intel/licenses
+ if [[ ! -f ${INTEL_LIC_DIR}/${MKL_LIC} ]]; then
+ insinto ${INTEL_LIC_DIR}
doins "${WORKDIR}"/${MKL_LIC} || die "install license failed"
fi