aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2010-01-19 21:02:37 +0100
committerThomas Kahle <tom111@gmx.de>2010-01-19 21:02:37 +0100
commit2ccadbf4792f6e72c452f63b90b933a95cc2cf6f (patch)
treef2ca14f7d585c32c8871abeffb346ea8903757ee /sci-libs
parentMove include files into a subdirectory (diff)
downloadsci-2ccadbf4792f6e72c452f63b90b933a95cc2cf6f.tar.gz
sci-2ccadbf4792f6e72c452f63b90b933a95cc2cf6f.tar.bz2
sci-2ccadbf4792f6e72c452f63b90b933a95cc2cf6f.zip
New Package sci-libs/cdd+
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cdd+/ChangeLog11
-rw-r--r--sci-libs/cdd+/Manifest6
-rw-r--r--sci-libs/cdd+/cdd+-077a.ebuild35
-rw-r--r--sci-libs/cdd+/files/cdd+-077a.patch69
-rw-r--r--sci-libs/cdd+/files/makefile.patch43
-rw-r--r--sci-libs/cdd+/metadata.xml10
6 files changed, 174 insertions, 0 deletions
diff --git a/sci-libs/cdd+/ChangeLog b/sci-libs/cdd+/ChangeLog
new file mode 100644
index 000000000..6bfb1457e
--- /dev/null
+++ b/sci-libs/cdd+/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/cdd+
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 19 Jan 2010; Thomas Kahle <tom@gentoo.org> +ChangeLog +Manifest
+ +cdd+-077a.ebuild +files/makefile.patch +files/cdd+-077a.patch
+ metadata.xml:
+
+ New ebuild: sci-libs/cdd+ Bug #301567
+
+
diff --git a/sci-libs/cdd+/Manifest b/sci-libs/cdd+/Manifest
new file mode 100644
index 000000000..7732bc303
--- /dev/null
+++ b/sci-libs/cdd+/Manifest
@@ -0,0 +1,6 @@
+AUX cdd+-077a.patch 2106 RMD160 8177f7cd9b573382bcf5ee7437b54dc8286ff4e2 SHA1 f4ff7776e64e911a3f96a6e041010e9c2cce737b SHA256 5e1163bed2ede64f06fc5037a2763c12380478e85579bbb96cb24ce151d05d12
+AUX makefile.patch 1141 RMD160 68015b2d4aabe459c5e30f4c4875a880b52c047c SHA1 995aa2688079068162a117e413b59d975492b724 SHA256 8a97bc1fc44397dfab71064807f2add136a30477018087a7ad648c54c1d839ab
+DIST cdd+-077a.tar.gz 186771 RMD160 059f9863dbaccb8facb4362ab8193b0156e1bdc0 SHA1 6e9a1ecd3d9bd3c4211dc252bfbb3aa0e900f9e3 SHA256 bace5c6c62fc48938b04a7b80fc55935e1bfe56cfb0b80f803842173a40ad616
+EBUILD cdd+-077a.ebuild 622 RMD160 00165225fba8373f42f9b8ded91783c0a8cd6a1f SHA1 dc20caf0744d847227d69a2b4f596e3d53c777f5 SHA256 980f543983673c776e803b4aed2984d560e4e6e93c761d68c19b26324b528c58
+MISC ChangeLog 304 RMD160 12f135e2b0cc0d127a2cf6487afe615cff5901af SHA1 1dba3c4a30ada336a286f578330ef6e97f572e96 SHA256 d90b91ebf4a83419285b1b5ad57cdcbe7ed332ccda5330f346c760eb34ceb49c
+MISC metadata.xml 541 RMD160 7c3a8db628a43679c88f8acce7ae3b04d4800c8b SHA1 89aee4e72517133785f1caf09d197be8006ee22e SHA256 4de4e7f93dbea18c079634d1bad9b4ce93f8a61cb4233bb90e220476d99aa987
diff --git a/sci-libs/cdd+/cdd+-077a.ebuild b/sci-libs/cdd+/cdd+-077a.ebuild
new file mode 100644
index 000000000..70d155c86
--- /dev/null
+++ b/sci-libs/cdd+/cdd+-077a.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://www.ifor.math.ethz.ch/~fukuda/cdd_home/"
+SRC_URI="ftp://ftp.ifor.math.ethz.ch/pub/fukuda/cdd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+
+DEPEND="dev-libs/gmp"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.patch"
+ epatch "${FILESDIR}/makefile.patch"
+}
+
+src_compile() {
+ emake all || die "emake failed"
+}
+
+src_install() {
+ dobin cddf+
+ dobin cddr+
+ dolib cddio.o
+}
diff --git a/sci-libs/cdd+/files/cdd+-077a.patch b/sci-libs/cdd+/files/cdd+-077a.patch
new file mode 100644
index 000000000..34b434058
--- /dev/null
+++ b/sci-libs/cdd+/files/cdd+-077a.patch
@@ -0,0 +1,69 @@
+Index: Integer.h
+===================================================================
+RCS file: /home/imocvs/cdd+/Integer.h,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 Integer.h
+--- Integer.h 2008/12/15 01:19:52 1.1.1.1
++++ Integer.h 2008/12/15 01:24:04
+@@ -23,6 +23,7 @@
+ #include <gmp_init.h>
+ #include <cctype>
+ #include <limits>
++#include <climits>
+
+ class Integer; class Rational;
+
+Index: Rational.cc
+===================================================================
+RCS file: /home/imocvs/cdd+/Rational.cc,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 Rational.cc
+--- Rational.cc 2008/12/15 01:19:52 1.1.1.1
++++ Rational.cc 2008/12/15 01:25:14
+@@ -17,6 +17,7 @@
+
+ #include <cctype>
+ #include "Rational.h"
++#include <cstring>
+
+ Rational& Rational::set(const char* s) throw (gmp_error)
+ {
+Index: Rational.h
+===================================================================
+RCS file: /home/imocvs/cdd+/Rational.h,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 Rational.h
+--- Rational.h 2008/12/15 01:19:52 1.1.1.1
++++ Rational.h 2008/12/15 01:27:08
+@@ -17,6 +17,7 @@
+ #define _POLYMAKE_GMP_RATIONAL_H "$Project: polymake $$Id: Rational.h,v 1.1.1.1 2008/12/15 01:19:52 mkoeppe Exp $"
+
+ #include <Integer.h>
++#include <cstring>
+
+ #if __GNU_MP_VERSION < 4
+ #define _tmp_little_Integer(x) \
+@@ -1178,7 +1179,7 @@ std::basic_ostream<char, Traits>& operat
+ Integer::little_buffer buf(s);
+ numerator(a).putstr(os.flags(), buf);
+ if (show_den) {
+- char *den_buf=buf+strlen(buf);
++ char *den_buf=buf+std::strlen(buf);
+ *den_buf++ = '/';
+ denominator(a).putstr(os.flags(), den_buf);
+ }
+Index: gmp_init.cc
+===================================================================
+RCS file: /home/imocvs/cdd+/gmp_init.cc,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 gmp_init.cc
+--- gmp_init.cc 2008/12/15 01:19:52 1.1.1.1
++++ gmp_init.cc 2008/12/15 01:23:45
+@@ -16,6 +16,7 @@
+ #ident "$Project: polymake $$Id: gmp_init.cc,v 1.1.1.1 2008/12/15 01:19:52 mkoeppe Exp $"
+
+ #include <memory>
++#include <cstring>
+ #include "gmp_init.h"
+
+ #if defined(__GNUC__)
diff --git a/sci-libs/cdd+/files/makefile.patch b/sci-libs/cdd+/files/makefile.patch
new file mode 100644
index 000000000..efe6d7035
--- /dev/null
+++ b/sci-libs/cdd+/files/makefile.patch
@@ -0,0 +1,43 @@
+--- makefile.orig 2010-01-19 20:22:59.000000000 +0100
++++ makefile 2010-01-19 20:52:01.000000000 +0100
+@@ -6,21 +6,21 @@
+ #CC = /bin/cc
+
+ # Location of gnu c++ library.
+-#LIBDIR = /usr/lib
+-LIBDIR = /usr/local/lib
++LIBDIR = /usr/lib
++#LIBDIR = /usr/local/lib
+
+ # Location of gnu gmp library libgmp.a
+-#GMPLIBDIR = /usr/lib
+-GMPLIBDIR = /usr/local/lib
++GMPLIBDIR = /usr/lib
++#GMPLIBDIR = /usr/local/lib
+
+ # Location of gnu gmp-library include file gmp.h
+-#GMPINCLUDEDIR = /usr/include
+-GMPINCLUDEDIR = /usr/local/include
++GMPINCLUDEDIR = /usr/include
++#GMPINCLUDEDIR = /usr/local/include
+
+ # Compiler optimization/debug options
+ #OPTFLAGS = -g -static -O
+ #OPTFLAGS = -g -static -pg -O
+-OPTFLAGS = -O3
++#OPTFLAGS = -O3
+
+ ########## You shouldn't have to change anything after this point ##########
+
+@@ -29,9 +29,8 @@
+ RATOBJ = gmp_init.o Integer.o Rational.o
+ RATEXE = cddr+
+
+-CFLAGS = $(OPTFLAGS) -I$(INCLUDEDIR) -I$(GMPINCLUDEDIR) -I. $(GMPFLAG)
+-
+-LDFLAGS = -L$(LIBDIR) -L$(GMPLIBDIR)
++CFLAGS += -I$(INCLUDEDIR) -I$(GMPINCLUDEDIR) -I. $(GMPFLAG)
++LDFLAGS += -L$(LIBDIR) -L$(GMPLIBDIR)
+
+ LIBS = -lstdc++ -l$(RATLIB)
+
diff --git a/sci-libs/cdd+/metadata.xml b/sci-libs/cdd+/metadata.xml
new file mode 100644
index 000000000..45ce8c6c4
--- /dev/null
+++ b/sci-libs/cdd+/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ The program cdd+ is a C++ implementation of the Double Description Method of Motzkin et al. for generating all
+ vertices (i.e. extreme points) and extreme rays of a general convex polyhedron in R^d given by a system of linear
+ inequalities: P = { x : A x <= b } where A is an m x d real matrix and b is a real m dimensional vector.
+ </longdescription>
+</pkgmetadata>