aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2013-09-15 07:18:11 +0200
committerKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2013-09-15 07:18:11 +0200
commit4ffb04de8cc4f64a6eb0582ceac43dbc2999cbbc (patch)
tree95b1a4d2ccc78b78e699ce7834e33dc8c8c902d2 /sci-libs
parent[dev-python/Forthon] version bump (diff)
parentsci-chemistry/freeon-20130912: Added new version. (diff)
downloadsci-4ffb04de8cc4f64a6eb0582ceac43dbc2999cbbc.tar.gz
sci-4ffb04de8cc4f64a6eb0582ceac43dbc2999cbbc.tar.bz2
sci-4ffb04de8cc4f64a6eb0582ceac43dbc2999cbbc.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/ChangeLog18
-rw-r--r--sci-libs/fftw/Manifest1
-rw-r--r--sci-libs/fftw/fftw-3.3.3-r3.ebuild187
-rw-r--r--sci-libs/fftw/fftw-9999.ebuild187
-rw-r--r--sci-libs/fftw/files/fftw-3.3.3-install-header.patch35
-rw-r--r--sci-libs/fftw/metadata.xml23
-rw-r--r--sci-libs/itk/ChangeLog9
-rw-r--r--sci-libs/itk/Manifest1
-rw-r--r--sci-libs/itk/itk-4.4.2.ebuild116
-rw-r--r--sci-libs/itk/metadata.xml18
-rw-r--r--sci-libs/modglue/ChangeLog5
-rw-r--r--sci-libs/modglue/Manifest2
-rw-r--r--sci-libs/modglue/modglue-1.16.ebuild6
-rw-r--r--sci-libs/nibabel/metadata.xml19
-rw-r--r--sci-libs/nibabel/nibabel-9999.ebuild40
-rw-r--r--sci-libs/nipy/Manifest1
-rw-r--r--sci-libs/nipy/metadata.xml12
-rw-r--r--sci-libs/nipy/nipy-0.3.0.ebuild37
-rw-r--r--sci-libs/nipy/nipy-9999.ebuild36
-rw-r--r--sci-libs/nipype/metadata.xml21
-rw-r--r--sci-libs/nipype/nipype-9999.ebuild33
-rw-r--r--sci-libs/pydicom/Manifest1
-rw-r--r--sci-libs/pydicom/pydicom-0.9.8.ebuild20
23 files changed, 823 insertions, 5 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
new file mode 100644
index 000000000..5bac2521e
--- /dev/null
+++ b/sci-libs/fftw/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for sci-libs/fftw
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 07 Sep 2013; Christoph Junghans <ottxor@gentoo.org> fftw-3.3.3-r3.ebuild,
+ fftw-9999.ebuild:
+ final clean up
+
+ 02 Sep 2013; Christoph Junghans <ottxor@gentoo.org> fftw-3.3.3-r3.ebuild,
+ fftw-9999.ebuild:
+ clean up
+
+*fftw-3.3.3-r3 (01 Sep 2013)
+*fftw-9999 (01 Sep 2013)
+
+ 01 Sep 2013; Christoph Junghans <ottxor@gentoo.org> +fftw-3.3.3-r3.ebuild,
+ +fftw-9999.ebuild, +files/fftw-3.3.3-install-header.patch, +metadata.xml:
+ import from gx86
diff --git a/sci-libs/fftw/Manifest b/sci-libs/fftw/Manifest
new file mode 100644
index 000000000..2aab3f825
--- /dev/null
+++ b/sci-libs/fftw/Manifest
@@ -0,0 +1 @@
+DIST fftw-3.3.3.tar.gz 3920661 SHA256 85cdfc0a0ba10d8fa4f0f8e733aac1a5936c859832a9e3d5c0731fb5c54a97f3 SHA512 1d88b6376ba8c15cceafd3381de1d181a974b921b72b31dd89c297e5771e8d665aa3c121ef2504a70e7b0bb562b1e0612ac2a02121c412d27df06c4d687507c4 WHIRLPOOL b410cb4d854988f9a57f08344d9207ece4ebf218ec6fa605036235e472bef91f5037d852793fa6a7bc0f8a6a7081dc1e71b25b15ab1259e299bb95affca40d3b
diff --git a/sci-libs/fftw/fftw-3.3.3-r3.ebuild b/sci-libs/fftw/fftw-3.3.3-r3.ebuild
new file mode 100644
index 000000000..fb359955f
--- /dev/null
+++ b/sci-libs/fftw/fftw-3.3.3-r3.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.3-r2.ebuild,v 1.3 2013/06/27 14:30:29 aballier Exp $
+
+EAPI=5
+
+#AUTOTOOLS_AUTORECONF=1
+FORTRAN_NEEDED=fortran
+
+inherit autotools-multilib eutils flag-o-matic fortran-2 multibuild toolchain-funcs versionator
+
+DESCRIPTION="Fast C library for the Discrete Fourier Transform"
+HOMEPAGE="http://www.fftw.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="http://www.fftw.org/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+LICENSE="GPL-2"
+SLOT="3.0"
+IUSE="altivec avx doc fma fortran mpi neon openmp quad sse sse2 static-libs test threads zbus"
+
+RDEPEND="
+ mpi? ( virtual/mpi )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r2
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ test? ( dev-lang/perl )"
+
+#can go once mpi is multlib
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/fftw3-mpi.h
+ /usr/include/fftw3l-mpi.f03
+ /usr/include/fftw3-mpi.f03
+ /usr/include/fftw3q.f03
+)
+
+pkg_setup() {
+ # XXX: this looks like it should be used with BUILD_TYPE!=binary
+
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+
+ fortran-2_pkg_setup
+
+ MULTIBUILD_VARIANTS=( single double longdouble )
+ if use quad; then
+ if [[ $(tc-getCC) == *gcc ]] && ! version_is_at_least 4.6 $(gcc-version); then
+ ewarn "quad precision only available for gcc >= 4.6"
+ die "need quad precision capable gcc"
+ fi
+ MULTIBUILD_VARIANTS+=( quad )
+ fi
+}
+
+src_prepare() {
+ # fix info file for category directory
+ [[ ${PV} = *9999 ]] || sed -i \
+ -e 's/Texinfo documentation system/Libraries/' \
+ doc/fftw3."info" || die "failed to fix info file"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local x
+
+ # filter -Os according to docs
+ replace-flags -Os -O2
+
+ my_configure() {
+ #a bit hacky improve after #483758 is solved
+ local x=${BUILD_DIR%-${ABI}}
+ x=${x##*-}
+ # there is no abi_x86_32 port of virtual/mpi right now
+ local enable_mpi=$(use_enable mpi)
+ multilib_is_native_abi || enable_mpi="--disable-mpi"
+
+ #jlec reported USE=quad on abi_x86_32 has too less registers
+ #stub Makefiles
+ if use amd64 && ! multilib_is_native_abi && [[ $x = quad ]]; then
+ mkdir -p "${BUILD_DIR}/tests" || die
+ echo "all: ;" > "${BUILD_DIR}/Makefile" || die
+ echo "install: ;" >> "${BUILD_DIR}/Makefile" || die
+ echo "smallcheck: ;" > "${BUILD_DIR}/tests/Makefile" || die
+ return 0
+ fi
+
+ myeconfargs=(
+ $(use_enable fma)
+ $(use_enable fortran)
+ $(use_enable zbus mips-zbus-timer)
+ $(use_enable threads)
+ $(use_enable openmp)
+ )
+ if [[ $x == single ]]; then
+ #altivec, sse, single-paired only work for single
+ myeconfargs+=(
+ --enable-single
+ $(use_enable altivec)
+ $(use_enable avx)
+ $(use_enable sse)
+ ${enable_mpi}
+ $(use_enable neon)
+ )
+ elif [[ $x == double ]]; then
+ myeconfargs+=(
+ $(use_enable avx)
+ $(use_enable sse2)
+ ${enable_mpi}
+ )
+ elif [[ $x == longdouble ]]; then
+ myeconfargs+=(
+ --enable-long-double
+ ${enable_mpi}
+ )
+ elif [[ $x == quad ]]; then
+ #quad does not support mpi
+ myeconfargs+=( --enable-quad-precision )
+ else
+ die "${x} precision not implemented in this ebuild"
+ fi
+
+ autotools-utils_src_configure
+ }
+
+ multibuild_foreach_variant multilib_parallel_foreach_abi my_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant autotools-multilib_src_compile
+}
+
+src_test () {
+ # We want this to be a reasonably quick test, but that is still hard...
+ ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
+ # Do not increase the number of threads, it will not help your performance
+ #local testbase="perl check.pl --nthreads=1 --estimate"
+ # ${testbase} -${p}d || die "Failure: $n"
+ multibuild_foreach_variant autotools-multilib_src_compile -C tests smallcheck
+}
+
+src_install () {
+ local u x
+ DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
+ HTML_DOCS=( doc/html/ )
+
+ #copied from autotools-multilib_secure_install
+ my_abi_src_install() {
+ autotools-utils_src_install
+ #https://github.com/FFTW/fftw3/pull/6
+ # f03 are installed unconditionally, not a big problem as the quad
+ # header is the only one to be wrapped.
+ [[ ${BUILD_DIR} = *-quad* ]] || rm -f "${ED}/usr/include/fftw3q.f03"
+ if [[ ${#MULTIBUILD_VARIANTS[@]} -gt 1 ]]; then
+ multilib_prepare_wrappers
+ multilib_check_headers
+ fi
+ }
+ multibuild_foreach_variant multilib_foreach_abi my_abi_src_install
+ multilib_install_wrappers
+
+ if use doc; then
+ dodoc doc/*.pdf
+ insinto /usr/share/doc/${PF}/faq
+ doins -r doc/FAQ/fftw-faq.html/*
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/html
+ fi
+
+ for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
+ for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
+ sed -e "s|-lfftw3[flq]\?|&_$u &|" "$x" > "${x%.pc}_$u.pc" || die
+ done
+ done
+}
diff --git a/sci-libs/fftw/fftw-9999.ebuild b/sci-libs/fftw/fftw-9999.ebuild
new file mode 100644
index 000000000..fb359955f
--- /dev/null
+++ b/sci-libs/fftw/fftw-9999.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.3-r2.ebuild,v 1.3 2013/06/27 14:30:29 aballier Exp $
+
+EAPI=5
+
+#AUTOTOOLS_AUTORECONF=1
+FORTRAN_NEEDED=fortran
+
+inherit autotools-multilib eutils flag-o-matic fortran-2 multibuild toolchain-funcs versionator
+
+DESCRIPTION="Fast C library for the Discrete Fourier Transform"
+HOMEPAGE="http://www.fftw.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="http://www.fftw.org/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+LICENSE="GPL-2"
+SLOT="3.0"
+IUSE="altivec avx doc fma fortran mpi neon openmp quad sse sse2 static-libs test threads zbus"
+
+RDEPEND="
+ mpi? ( virtual/mpi )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r2
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ test? ( dev-lang/perl )"
+
+#can go once mpi is multlib
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/fftw3-mpi.h
+ /usr/include/fftw3l-mpi.f03
+ /usr/include/fftw3-mpi.f03
+ /usr/include/fftw3q.f03
+)
+
+pkg_setup() {
+ # XXX: this looks like it should be used with BUILD_TYPE!=binary
+
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+
+ fortran-2_pkg_setup
+
+ MULTIBUILD_VARIANTS=( single double longdouble )
+ if use quad; then
+ if [[ $(tc-getCC) == *gcc ]] && ! version_is_at_least 4.6 $(gcc-version); then
+ ewarn "quad precision only available for gcc >= 4.6"
+ die "need quad precision capable gcc"
+ fi
+ MULTIBUILD_VARIANTS+=( quad )
+ fi
+}
+
+src_prepare() {
+ # fix info file for category directory
+ [[ ${PV} = *9999 ]] || sed -i \
+ -e 's/Texinfo documentation system/Libraries/' \
+ doc/fftw3."info" || die "failed to fix info file"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local x
+
+ # filter -Os according to docs
+ replace-flags -Os -O2
+
+ my_configure() {
+ #a bit hacky improve after #483758 is solved
+ local x=${BUILD_DIR%-${ABI}}
+ x=${x##*-}
+ # there is no abi_x86_32 port of virtual/mpi right now
+ local enable_mpi=$(use_enable mpi)
+ multilib_is_native_abi || enable_mpi="--disable-mpi"
+
+ #jlec reported USE=quad on abi_x86_32 has too less registers
+ #stub Makefiles
+ if use amd64 && ! multilib_is_native_abi && [[ $x = quad ]]; then
+ mkdir -p "${BUILD_DIR}/tests" || die
+ echo "all: ;" > "${BUILD_DIR}/Makefile" || die
+ echo "install: ;" >> "${BUILD_DIR}/Makefile" || die
+ echo "smallcheck: ;" > "${BUILD_DIR}/tests/Makefile" || die
+ return 0
+ fi
+
+ myeconfargs=(
+ $(use_enable fma)
+ $(use_enable fortran)
+ $(use_enable zbus mips-zbus-timer)
+ $(use_enable threads)
+ $(use_enable openmp)
+ )
+ if [[ $x == single ]]; then
+ #altivec, sse, single-paired only work for single
+ myeconfargs+=(
+ --enable-single
+ $(use_enable altivec)
+ $(use_enable avx)
+ $(use_enable sse)
+ ${enable_mpi}
+ $(use_enable neon)
+ )
+ elif [[ $x == double ]]; then
+ myeconfargs+=(
+ $(use_enable avx)
+ $(use_enable sse2)
+ ${enable_mpi}
+ )
+ elif [[ $x == longdouble ]]; then
+ myeconfargs+=(
+ --enable-long-double
+ ${enable_mpi}
+ )
+ elif [[ $x == quad ]]; then
+ #quad does not support mpi
+ myeconfargs+=( --enable-quad-precision )
+ else
+ die "${x} precision not implemented in this ebuild"
+ fi
+
+ autotools-utils_src_configure
+ }
+
+ multibuild_foreach_variant multilib_parallel_foreach_abi my_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant autotools-multilib_src_compile
+}
+
+src_test () {
+ # We want this to be a reasonably quick test, but that is still hard...
+ ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
+ # Do not increase the number of threads, it will not help your performance
+ #local testbase="perl check.pl --nthreads=1 --estimate"
+ # ${testbase} -${p}d || die "Failure: $n"
+ multibuild_foreach_variant autotools-multilib_src_compile -C tests smallcheck
+}
+
+src_install () {
+ local u x
+ DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
+ HTML_DOCS=( doc/html/ )
+
+ #copied from autotools-multilib_secure_install
+ my_abi_src_install() {
+ autotools-utils_src_install
+ #https://github.com/FFTW/fftw3/pull/6
+ # f03 are installed unconditionally, not a big problem as the quad
+ # header is the only one to be wrapped.
+ [[ ${BUILD_DIR} = *-quad* ]] || rm -f "${ED}/usr/include/fftw3q.f03"
+ if [[ ${#MULTIBUILD_VARIANTS[@]} -gt 1 ]]; then
+ multilib_prepare_wrappers
+ multilib_check_headers
+ fi
+ }
+ multibuild_foreach_variant multilib_foreach_abi my_abi_src_install
+ multilib_install_wrappers
+
+ if use doc; then
+ dodoc doc/*.pdf
+ insinto /usr/share/doc/${PF}/faq
+ doins -r doc/FAQ/fftw-faq.html/*
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/html
+ fi
+
+ for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
+ for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
+ sed -e "s|-lfftw3[flq]\?|&_$u &|" "$x" > "${x%.pc}_$u.pc" || die
+ done
+ done
+}
diff --git a/sci-libs/fftw/files/fftw-3.3.3-install-header.patch b/sci-libs/fftw/files/fftw-3.3.3-install-header.patch
new file mode 100644
index 000000000..4456c189e
--- /dev/null
+++ b/sci-libs/fftw/files/fftw-3.3.3-install-header.patch
@@ -0,0 +1,35 @@
+From f450afa1cc0bb962abecfc1ffdbef8e1f7b748e4 Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <ottxor@gentoo.org>
+Date: Sat, 31 Aug 2013 21:21:28 -0600
+Subject: [PATCH] Only install f03 header of the active precision
+
+---
+ api/Makefile.am | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/api/Makefile.am b/api/Makefile.am
+index e4eaad7..bb6c042 100644
+--- a/api/Makefile.am
++++ b/api/Makefile.am
+@@ -4,8 +4,17 @@ AM_CFLAGS = $(STACK_ALIGN_CFLAGS)
+
+ EXTRA_DIST = f03api.sh genf03.pl fftw3.f03.in
+
+-include_HEADERS = fftw3.h fftw3.f fftw3l.f03 fftw3q.f03
++include_HEADERS = fftw3.h fftw3.f
++noinst_HEADERS = fftw3l.f03 fftw3q.f03
++if LDOUBLE
++include_HEADERS += fftw3l.f03
++else
++if QUAD
++include_HEADERS += fftw3q.f03
++else
+ nodist_include_HEADERS = fftw3.f03
++endif
++endif
+ noinst_LTLIBRARIES = libapi.la
+
+ # pkgincludedir = $(includedir)/fftw3@PREC_SUFFIX@
+--
+1.8.1.5
+
diff --git a/sci-libs/fftw/metadata.xml b/sci-libs/fftw/metadata.xml
new file mode 100644
index 000000000..50e74c164
--- /dev/null
+++ b/sci-libs/fftw/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The Fastest Fourier Transform in the West is a C subroutine library
+ for computing the Discrete Fourier Transform (DFT) in one or more
+ dimensions, of both real and complex data, and of arbitrary input
+ size. It is becoming the FFT library of choice for most
+ applications. Benchmarks, performed on a variety of platforms, show
+ that FFTW's performance is typically superior to that of other
+ publicly available FFT software.
+</longdescription>
+ <use>
+ <flag name="avx">Adds support for Advanced Vector Extensions</flag>
+ <flag name="fma">Use the Fused Multiply Add instruction set (fma3/fma4 either one)</flag>
+ <flag name="quad">Build quadruple precision lib</flag>
+ <flag name="zbus">Adds support for ZBus cycle-counter of mips</flag>
+ </use>
+ <upstream>
+ <remote-id type="freecode">fftw</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/itk/ChangeLog b/sci-libs/itk/ChangeLog
new file mode 100644
index 000000000..618618847
--- /dev/null
+++ b/sci-libs/itk/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-libs/itk
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*itk-4.4.2 (12 Sep 2013)
+
+ 12 Sep 2013; Sébastien Fabbro <bicatali@gentoo.org> +itk-4.4.2.ebuild,
+ -files/itk-4.4-v3compat_I2VI_const-fix.patch, -itk-4.4.0.ebuild, metadata.xml:
+ sci-libs/itk: Version bump. Cleaned-up ebuild and metadata.xml
diff --git a/sci-libs/itk/Manifest b/sci-libs/itk/Manifest
new file mode 100644
index 000000000..2a83eb01b
--- /dev/null
+++ b/sci-libs/itk/Manifest
@@ -0,0 +1 @@
+DIST InsightToolkit-4.4.2.tar.gz 231905134 SHA256 071a7929c295b80bc8a6ab80d50c06cdfb0e6aafd936103c6d0a4a086cf8bec3 SHA512 c65beca4dd60aa769871bb3089cbb421729a2dcbd8bd3ec42c378ed60828e4327f1faf062f77bcca34306315a1daee6bc29d858dab9aea1c08f4843405fd21e3 WHIRLPOOL 4036bce61d0900ef2f1484ca06e9b513f6154c2233122e41fe694c648dd6eef53510749bf75368f9851a4dbd45777ca7033ad43f28c86259d5efae9e0d4200bd
diff --git a/sci-libs/itk/itk-4.4.2.ebuild b/sci-libs/itk/itk-4.4.2.ebuild
new file mode 100644
index 000000000..542216b7e
--- /dev/null
+++ b/sci-libs/itk/itk-4.4.2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit eutils toolchain-funcs cmake-utils python-single-r1
+
+MYP=InsightToolkit-${PV}
+
+DESCRIPTION="NLM Insight Segmentation and Registration Toolkit"
+HOMEPAGE="http://www.itk.org"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+RESTRICT="primaryuri"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug examples fftw itkv3compat python review sse2 test"
+
+RDEPEND="
+ sci-libs/hdf5[cxx]
+ virtual/jpeg
+ media-libs/libpng
+ media-libs/tiff:0
+ sys-libs/zlib
+ fftw? ( sci-libs/fftw:3.0 )
+"
+DEPEND="${RDEPEND}
+ python? ( ${PYTHON_DEPS}
+ >=dev-lang/swig-2.0
+ >=dev-cpp/gccxml-0.9.0_pre20120309 )
+"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_pretend() {
+ if [[ -z ${ITK_COMPUTER_MEMORY_SIZE} ]]; then
+ elog "To tune ITK to make the best use ouf working memory you can set"
+ elog " ITK_COMPUTER_MEMORY_SIZE=XX"
+ elog "in make.conf, default is 1 (unit is GB)"
+ fi
+ if use python && [[ -z ${ITK_WRAP_DIMS} ]]; then
+ elog "For Python language bindings, you can define the dimensions"
+ elog "you want to create bindings for by setting"
+ elog " ITK_WRAP_DIMS=X;Y;Z..."
+ elog "in make.conf, default is 2;3 for 2D and 3D data"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWRAP_ITK_JAVA=OFF
+ -DWRAP_ITK_TCL=OFF
+ -DITK_USE_SYSTEM_HDF5=ON
+ -DITK_USE_SYSTEM_JPEG=ON
+ -DITK_USE_SYSTEM_PNG=ON
+ -DITK_USE_SYSTEM_TIFF=ON
+ -DITK_USE_SYSTEM_ZLIB=ON
+ -DITK_USE_SYSTEM_GCCXML=ON
+ -DITK_USE_SYSTEM_SWIG=ON
+ -DITK_BUILD_ALL_MODULES=ON
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_EXAMPLES=OFF
+ -DITK_COMPUTER_MEMORY_SIZE="${ITK_COMPUTER_MEMORY_SIZE:-1}"
+ $(cmake-utils_use_build test TESTING)
+ $(cmake-utils_use review ITK_USE_REVIEW)
+ $(cmake-utils_use itkv3compat ITKV3_COMPATIBILITY)
+ $(cmake-utils_use sse2 VNL_CONFIG_ENABLE_SSE2)
+ )
+ if use fftw; then
+ mycmakeargs+=(
+ -DUSE_FFTWD=ON
+ -DUSE_FFTWF=ON
+ -DUSE_SYSTEM_FFTW=ON
+ -DITK_WRAP_double=ON
+ -DITK_WRAP_vector_double=ON
+ -DITK_WRAP_covariant_vector_double=ON
+ -DITK_WRAP_complex_double=ON
+ )
+ fi
+ if use python; then
+ mycmakeargs+=(
+ -DITK_WRAP_PYTHON=ON
+ -DITK_WRAP_DIMS="${ITK_WRAP_DIMS:-2;3}"
+ )
+ else
+ mycmakeargs+=(
+ -DITK_WRAP_PYTHON=OFF
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ doins -r "${S}"/Examples/*
+ fi
+
+ echo "ITK_DATA_ROOT=${EROOT}/usr/share/${PN}/data" > ${T}/40${PN}
+ local ldpath="${EROOT}/usr/$(get_libdir)/InsightToolkit"
+ if use python; then
+ echo "PYTHONPATH=${EROOT}/usr/$(get_libdir)/InsightToolkit/WrapITK/Python" >> ${T}/40${PN}
+ ldpath="${ldpath}:${EROOT}/usr/$(get_libdir)/InsightToolkit/WrapITK/lib"
+ fi
+ echo "LDPATH=${ldpath}" >> ${T}/40${PN}
+
+ doenvd "${T}"/40${PN}
+}
diff --git a/sci-libs/itk/metadata.xml b/sci-libs/itk/metadata.xml
new file mode 100644
index 000000000..e941d4802
--- /dev/null
+++ b/sci-libs/itk/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-biology</herd>
+<maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ Insight Segmentation and Registration Toolkit (ITK) is a library
+ that provides developers with an extensive suite of tools for image
+ analysis.
+</longdescription>
+<use>
+ <flag name="itkv3compat">Enable compatibility with ITK version 3</flag>
+ <flag name="review">Enable compilation of methods under review</flag>
+</use>
+</pkgmetadata>
+
diff --git a/sci-libs/modglue/ChangeLog b/sci-libs/modglue/ChangeLog
index 732b78492..eb811e97d 100644
--- a/sci-libs/modglue/ChangeLog
+++ b/sci-libs/modglue/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 03 Sep 2013; François Bissey <francois.bissey@canterbury.ac.nz>
+ modglue-1.16.ebuild:
+ Fix PATCHES definition, it shouldn't include 'epatch'
+
03 Mar 2013; Justin Lecher <jlec@gentoo.org> modglue-1.16.ebuild,
metadata.xml:
Move to EPAI=5 and virtual/pkgconfig; clean usage of autotools-utils.eclass
@@ -39,4 +43,3 @@
03 Apr 2009; Francois Bissey <f.r.bissey@massey.ac.nz> ChangeLog:
Initial import for the science overlay
-
diff --git a/sci-libs/modglue/Manifest b/sci-libs/modglue/Manifest
index 05141a4d3..9c45f3be3 100644
--- a/sci-libs/modglue/Manifest
+++ b/sci-libs/modglue/Manifest
@@ -1 +1 @@
-DIST modglue-1.16.tar.gz 89987 SHA256 1da62910d7171cb5547c0757c366e5338f889c0155c33375e891df75e2ee429e
+DIST modglue-1.16.tar.gz 89987 SHA256 1da62910d7171cb5547c0757c366e5338f889c0155c33375e891df75e2ee429e SHA512 2ac93f771f99b33f6339ceb55ba95c034c37d84b3d8ee6a56a8c75e7b6129cf3a218adb5539df37da2c5f645983eb7c141c9716ad5c94699e2f44396609d7f2a WHIRLPOOL 39f399b30c3762fa6522444051f81bb8d484448681735e8e1c0d304f0f8ebc5e281853257dffc506ab3f864025cab373b608720e0645ed8397ec7fc2fe8625af
diff --git a/sci-libs/modglue/modglue-1.16.ebuild b/sci-libs/modglue/modglue-1.16.ebuild
index afabe76c7..ab4602cd4 100644
--- a/sci-libs/modglue/modglue-1.16.ebuild
+++ b/sci-libs/modglue/modglue-1.16.ebuild
@@ -25,12 +25,12 @@ AUTOTOOLS_IN_SOURCE_BUILD=1
PATCHES=(
# Respect LDFLAGS
- epatch "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-ldflags.patch
# fix parallel make. test are made at the same time as the library??
- epatch "${FILESDIR}"/${P}-parallelmake.patch
+ "${FILESDIR}"/${P}-parallelmake.patch
# take care of the lib/lib64 problem. Without this modglue installs
# stuff in /usr/usr/lib64 on 64bits systems.
- epatch "${FILESDIR}"/${P}-lib64.patch
+ "${FILESDIR}"/${P}-lib64.patch
)
src_install() {
diff --git a/sci-libs/nibabel/metadata.xml b/sci-libs/nibabel/metadata.xml
new file mode 100644
index 000000000..7ffd788e6
--- /dev/null
+++ b/sci-libs/nibabel/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+</maintainer>
+<longdescription lang="en">
+ The package provides read and write access to some common medical and
+ neuroimaging file formats, including: ANALYZE (plain, SPM99, SPM2), GIFTI,
+ NIfTI1, MINC, MGH and ECAT as well as PAR/REC. It can read and write Freesurfer
+ geometry, and read Freesurfer morphometry and annotation files. There is some
+ very limited support for DICOM. NiBabel is the successor of PyNIfTI.
+</longdescription>
+<use>
+ <flag name="dicom">Adds limited read support for the DICOM imaging format.</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-libs/nibabel/nibabel-9999.ebuild b/sci-libs/nibabel/nibabel-9999.ebuild
new file mode 100644
index 000000000..0070d0bfd
--- /dev/null
+++ b/sci-libs/nibabel/nibabel-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Access a cacophony of neuro-imaging file formats"
+HOMEPAGE="http://nipy.org/nibabel/"
+EGIT_REPO_URI="https://github.com/nipy/nibabel.git"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="dicom doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dicom? (
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ )
+ "
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ distutils-r1_install_for_testing
+ cd "${BUILD_DIR}" || die
+ echo "backend: Agg" > matplotlibrc
+ MPLCONFIGDIR=. nosetests || die
+}
diff --git a/sci-libs/nipy/Manifest b/sci-libs/nipy/Manifest
new file mode 100644
index 000000000..e2730eee9
--- /dev/null
+++ b/sci-libs/nipy/Manifest
@@ -0,0 +1 @@
+DIST nipy-0.3.0.tar.gz 2143887 SHA256 74fef65c832795a35e1757d8bd852177fae190517a964afcb0812cfc1107d155 SHA512 3eaab4628bfa1706c99d516242387e1a27330bbf03b5b79da80d9a5e697b4e779f8f059e6f7bcc4253c5ad7af1bf6c600bcc5bd87db95d2e38f445d1f4416106 WHIRLPOOL 8a27c42abd8c7ae5ce66b8cfb0686b79e3208950107fcc5090d88fa2c23bf15d4ce4ae5b598f6f51c6e70122c40a343b9b7b2950ef09aefaeb22e24efd854af0
diff --git a/sci-libs/nipy/metadata.xml b/sci-libs/nipy/metadata.xml
new file mode 100644
index 000000000..ac599a834
--- /dev/null
+++ b/sci-libs/nipy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+</maintainer>
+<longdescription lang="en">
+ NIPY is a python project for analysis of structural and functional neuroimaging data.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/nipy/nipy-0.3.0.ebuild b/sci-libs/nipy/nipy-0.3.0.ebuild
new file mode 100644
index 000000000..4d68e2a82
--- /dev/null
+++ b/sci-libs/nipy/nipy-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+DISTUTILS_NO_PARALLEL_BUILD=true
+
+inherit distutils-r1 eutils multilib flag-o-matic
+
+
+DESCRIPTION="Neuroimaging tools for Python"
+HOMEPAGE="http://nipy.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # bug #397605
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+
+ # nipy uses the horrible numpy.distutils automagic
+}
diff --git a/sci-libs/nipy/nipy-9999.ebuild b/sci-libs/nipy/nipy-9999.ebuild
new file mode 100644
index 000000000..6d752cbde
--- /dev/null
+++ b/sci-libs/nipy/nipy-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scikits_image/scikits_image-0.8.2.ebuild,v 1.3 2013/06/18 04:33:25 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+DISTUTILS_NO_PARALLEL_BUILD=true
+
+inherit distutils-r1 multilib git-2 flag-o-matic
+
+DESCRIPTION="Neuroimaging tools for Python"
+HOMEPAGE="http://nipy.org/"
+EGIT_REPO_URI="https://github.com/nipy/nipy"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # bug #397605
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+
+ # nipy uses the horrible numpy.distutils automagic
+}
diff --git a/sci-libs/nipype/metadata.xml b/sci-libs/nipype/metadata.xml
new file mode 100644
index 000000000..d41e11fc9
--- /dev/null
+++ b/sci-libs/nipype/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+</maintainer>
+<longdescription lang="en">
+ Nipype, an open-source, community-developed initiative under the
+ umbrella of NiPy, is a Python project that provides a uniform interface
+ to existing neuroimaging software and facilitates interaction between
+ these packages within a single workflow. Nipype provides an environment
+ that encourages interactive exploration of algorithms from different
+ packages (e.g., SPM, FSL, FreeSurfer, Camino, MRtrix, MNE, AFNI, Slicer),
+ eases the design of workflows within and between packages, and reduces
+ the learning curve necessary to use different packages. Nipype is
+ creating a collaborative platform for neuroimaging software development
+ in a high-level language and addressing limitations of existing pipeline systems.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/nipype/nipype-9999.ebuild b/sci-libs/nipype/nipype-9999.ebuild
new file mode 100644
index 000000000..7afb3b5f0
--- /dev/null
+++ b/sci-libs/nipype/nipype-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scikits_image/scikits_image-0.8.2.ebuild,v 1.3 2013/06/18 04:33:25 patrick Exp $
+
+EAPI=5
+
+# pyamg missing py3 support
+# PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
+HOMEPAGE="http://nipy.sourceforge.net/nipype/"
+EGIT_REPO_URI="https://github.com/nipy/nipype"
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]"
+RDEPEND="
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die
+}
+
+
diff --git a/sci-libs/pydicom/Manifest b/sci-libs/pydicom/Manifest
new file mode 100644
index 000000000..c6ce98860
--- /dev/null
+++ b/sci-libs/pydicom/Manifest
@@ -0,0 +1 @@
+DIST pydicom-0.9.8.zip 466418 SHA256 d73852cd6f2a0f95c5bd096806ca517f3c152f117638528dcbf7527793853141 SHA512 baba1963069caebd5f124e545356f07993733b4bd2e11d06e22b57b796bb48ad21734a72c0b4ced8e5607b40047ccc929886e449c956047cb293e5fb27038cbe WHIRLPOOL fba24f994ea76ab13bfa6432ba69afd61ca250c1f05573782d660b7c1b0db9aadfa15d6bce5a4a26b38f8cbdce7db16b1d00857f8f1bc4e54190217a8bedaa97
diff --git a/sci-libs/pydicom/pydicom-0.9.8.ebuild b/sci-libs/pydicom/pydicom-0.9.8.ebuild
new file mode 100644
index 000000000..1a31eb262
--- /dev/null
+++ b/sci-libs/pydicom/pydicom-0.9.8.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python package for parsing DICOM files"
+HOMEPAGE="https://code.google.com/p/pydicom/"
+SRC_URI="https://pydicom.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""