aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-02-20 09:26:43 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-02-20 09:26:43 +0000
commit57a97f6cd83fbabcb6e494e4a4edd25cb2da218a (patch)
tree313656738eed30e2df41919d8d19c8d055f8cd8f /sci-libs
parentgeneral cleaning (licenses, USE flags descriptions, headers) (diff)
downloadsci-57a97f6cd83fbabcb6e494e4a4edd25cb2da218a.tar.gz
sci-57a97f6cd83fbabcb6e494e4a4edd25cb2da218a.tar.bz2
sci-57a97f6cd83fbabcb6e494e4a4edd25cb2da218a.zip
scipy-0.4.6 version bump
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@108 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/ChangeLog6
-rw-r--r--sci-libs/scipy/Manifest4
-rw-r--r--sci-libs/scipy/scipy-0.4.6.ebuild55
3 files changed, 61 insertions, 4 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 7c3b0fd11..27c4fd81c 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -2,10 +2,10 @@
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
-*scipy-0.4.4 (07 Feb 2006)
+*scipy-0.4.6 (19 Feb 2006)
- 07 Feb 2006; Sebastien Fabbro <seb@ist.utl.pt>
- +metadata.xml, +scipy-0.4.4.ebuild:
+ 19 Feb 2006; Sebastien Fabbro <seb@ist.utl.pt>
+ +metadata.xml, +scipy-0.4.6.ebuild:
Version bump and slight modifs. Closes bug #119469.
Thanks to Alok Singhal <alok_singhal@yahoo.com> and others.
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
index 18fcef76f..2fb3d4628 100644
--- a/sci-libs/scipy/Manifest
+++ b/sci-libs/scipy/Manifest
@@ -1,4 +1,6 @@
-MD5 905b6ba15324c6c0733a99ced6995e40 ChangeLog 563
+MD5 e9fb7edfed65991c7026915252774a16 ChangeLog 563
MD5 a949de96fef5b6758302142a51404cce files/digest-scipy-0.4.4 64
+MD5 190361bc8c86c26f2509e2711bf3a82c files/digest-scipy-0.4.6 64
MD5 51dd57e78f009510e5b3a8384723e22d metadata.xml 686
MD5 6ee78283245d2fa4de4a4065a6058e3e scipy-0.4.4.ebuild 1389
+MD5 d7e90b39b59ff8a425d80355e174d8aa scipy-0.4.6.ebuild 1396
diff --git a/sci-libs/scipy/scipy-0.4.6.ebuild b/sci-libs/scipy/scipy-0.4.6.ebuild
new file mode 100644
index 000000000..0648ea3e3
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.4.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils fortran
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DESCRIPTION="Open source scientific tools for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+IUSE="fftw"
+KEYWORDS="~amd64 ~x86"
+#keyworded to x86 only because of numpy
+#could use any lapack, but it seems that lapack-atlas provides non-f2c clapack routines
+RDEPEND=">=dev-lang/python-2.3.3
+ >=dev-python/numpy-0.9.5
+ virtual/blas
+ sci-libs/lapack-atlas
+ fftw? ( =sci-libs/fftw-2.1* )"
+
+# install doc claims fftw-2 is faster for complex ffts.
+# install doc claims gcc-4 not fully tested
+# wxwindows seems to have disapeared.
+# f2py seems to be in numpy.
+#
+FORTRAN="g77"
+
+DEPEND="${RDEPEND}
+ app-admin/eselect
+ =sys-devel/gcc-3*"
+
+pkg_setup() {
+ if [ -z "$(/usr/bin/eselect lapack show | grep ATLAS)" ]; then
+ eerror "You need to set lapack-atlas to use this version of scipy"
+ einfo "Please run:"
+ einfo "\teselect lapack set ATLAS"
+ einfo "or, if you have the threaded version:"
+ einfo "\teselect lapack set threaded-ATLAS"
+ einfo "And re-emerge scipy"
+ die "setup failed"
+ fi
+}
+
+src_test() {
+ einfo "Testing installation ..."
+ python -c "import scipy; scipy.test(level=1)" || \
+ die "Unit tests failed!"
+}
+
+src_install() {
+ distutils_src_install
+ dodoc `ls *.txt`
+}