aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-28 06:20:20 -0400
committerHorea Christian <chr@chymera.eu>2020-09-28 06:20:20 -0400
commit5fef6fd1a5554e613fe333aba90399908e257456 (patch)
treeebb92b842898ae6bb2af9d23d2a6f2550d78d4c8 /sci-libs
parentpatches: removed patch for deprecated package (diff)
downloadsci-5fef6fd1a5554e613fe333aba90399908e257456.tar.gz
sci-5fef6fd1a5554e613fe333aba90399908e257456.tar.bz2
sci-5fef6fd1a5554e613fe333aba90399908e257456.zip
sci-libs/shtools: removed discontinued package
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/shtools/Manifest1
-rw-r--r--sci-libs/shtools/metadata.xml21
-rw-r--r--sci-libs/shtools/shtools-4.0.ebuild77
3 files changed, 0 insertions, 99 deletions
diff --git a/sci-libs/shtools/Manifest b/sci-libs/shtools/Manifest
deleted file mode 100644
index 4949ead8e..000000000
--- a/sci-libs/shtools/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST shtools-4.0.tar.gz 17372252 BLAKE2B 7c3ab722ae9c86ced3442ee936bccc9fc30aea73fea65a749d9658ec7e4f828e3da68c88ed447d45f1c6718ba6fbe3fc69d62d4bcfe733673b0e6aa5c6b63ac7 SHA512 13dae982d0b8b45a9193b9ffdf8433624b862fec5c071f4eed7f4883a498c36a039d7b037024eab6cef5d54a0459464e4dcc1771785e575e27c2a94131de90a3
diff --git a/sci-libs/shtools/metadata.xml b/sci-libs/shtools/metadata.xml
deleted file mode 100644
index 2fc842248..000000000
--- a/sci-libs/shtools/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>heroxbd@gentoo.org</email>
- <name>Benda Xu</name>
- </maintainer>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription>
-SHTOOLS is an archive of Fortran 95 and Python software that can
-be used to perform spherical harmonic transforms and
-reconstructions, rotations of data expressed in spherical
-harmonics, and multitaper spectral analyses on the sphere.
-</longdescription>
- <upstream>
- <remote-id type="github">SHTOOLS/SHTOOLS</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-libs/shtools/shtools-4.0.ebuild b/sci-libs/shtools/shtools-4.0.ebuild
deleted file mode 100644
index 82c690943..000000000
--- a/sci-libs/shtools/shtools-4.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-if [[ ${PV} == 9999 ]]; then
- _ECLASS="git-r3"
- EGIT_REPO_URI="https://github.com/heroxbd/${PN^^}.git"
- S="${WORKDIR}"/${P}
-else
- SRC_URI="https://github.com/${PN^^}/${PN^^}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}"/${PN^^}-${PV/_/-}
-fi
-
-PYTHON_COMPAT=( python{2_7,3_{4,5}} )
-
-inherit fortran-2 flag-o-matic python-single-r1 toolchain-funcs ${_ECLASS}
-
-DESCRIPTION="Spherical harmonic transforms and reconstructions, rotations"
-HOMEPAGE="http://shtools.ipgp.fr"
-
-LICENSE="BSD-4"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="static-libs"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- sci-libs/fftw:3.0=
- virtual/lapack
- virtual/blas
- ${PYTHON_DEPS}"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_prepare() {
- append-ldflags -shared # needed by f2py
- # needed by f2py in fortran 77 mode
- append-fflags -fPIC
- [[ $(tc-getFC) =~ gfortran ]] && append-fflags -fno-second-underscore
- export _pyver=$(python_is_python3 && echo 3 || echo 2)
- export OPTS=(
- LAPACK=$($(tc-getPKG_CONFIG) lapack --libs-only-l)
- BLAS=$($(tc-getPKG_CONFIG) blas --libs-only-l)
- FFTW=$($(tc-getPKG_CONFIG) fftw3 --libs-only-l)
- F95=$(tc-getFC)
- F95FLAGS="${FCFLAGS}"
- AR=$(tc-getAR)
- RLIB=$(tc-getRANLIB)
- PYTHON_VERSION=${_pyver}
- )
-
- sed \
- -e '/mv/s:.so:*.so:g' \
- -e "/SYSDOCPATH/s:${PN}:${PF}:g" \
- -e "/www/s:/$:/html/:g" \
- -i Makefile || die
-
- default
-}
-
-src_compile() {
- emake fortran "${OPTS[@]}"
- emake python${_pyver} "${OPTS[@]}"
-}
-
-src_install() {
- emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" "${OPTS[@]}" install-fortran
- emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" "${OPTS[@]}" install-python${_pyver}
- if ! use static-libs; then
- rm -rf "${ED}"/usr/$(get_libdir)/*.a || die
- fi
-}