aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhavlicek <havlicek@32389bae-6d03-0410-99cf-db05cde120eb>2008-05-12 09:18:13 +0000
committerhavlicek <havlicek@32389bae-6d03-0410-99cf-db05cde120eb>2008-05-12 09:18:13 +0000
commit629399c024838387ca8d49811a45fc26a85574f3 (patch)
tree2593c04174f0a3154e58b4326868f9e5a37c84ff /sci-libs
parentmathgl-1.6.2, udav-0.3.2: ~ppc added (diff)
downloadsci-629399c024838387ca8d49811a45fc26a85574f3.tar.gz
sci-629399c024838387ca8d49811a45fc26a85574f3.tar.bz2
sci-629399c024838387ca8d49811a45fc26a85574f3.zip
My first contrib on the science overlay is a library for DICOM files
(Digital Imaging and COmmunications in Medecine) git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1049 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/dcmtk/ChangeLog13
-rw-r--r--sci-libs/dcmtk/Manifest5
-rw-r--r--sci-libs/dcmtk/dcmtk-3.5.4-r3.ebuild79
-rw-r--r--sci-libs/dcmtk/metadata.xml19
4 files changed, 116 insertions, 0 deletions
diff --git a/sci-libs/dcmtk/ChangeLog b/sci-libs/dcmtk/ChangeLog
new file mode 100644
index 000000000..2600c576c
--- /dev/null
+++ b/sci-libs/dcmtk/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-libs/dcmtk
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 26 Apr 2008; Ivan Havlicek <ivan@modulix.org> dcmtk-3.5.4-r3 :
+ Changes in xmedcon-0.10.4.ebuild for conformance with repoman
+
+ 26 Apr 2008; Ivan Havlicek <ivan@modulix.org> ChangeLog :
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/sci-libs/dcmtk/Manifest b/sci-libs/dcmtk/Manifest
new file mode 100644
index 000000000..00d7ef9bc
--- /dev/null
+++ b/sci-libs/dcmtk/Manifest
@@ -0,0 +1,5 @@
+DIST dcmtk-3.5.4.tar.gz 3756374 RMD160 d1558c9c68e53e0ea3b080fd2fb50b9d8e30eeba SHA1 169056874947083e68eb941fcd53faaebc862ae5 SHA256 7b8575ba609516d76b681c0de8c1328cf23e57deb2c7085a6aa37d4292354d76
+DIST dcmtk_3.5.4-3.diff.gz 140253 RMD160 c06856a46513612c3a585bc3fea429d296ae6bb4 SHA1 75c14b8c6caa88155324b5bb8ed29363776ff7bf SHA256 8dd3ca447de4b0f1d553f672f36d5d88af86763604e2fc830667ce6fdd12677a
+EBUILD dcmtk-3.5.4-r3.ebuild 1651 RMD160 69aed5ef15c82adf2c8ac87372c40bdf1f538c05 SHA1 cfb7780f1181c82821f62c4ff5b1392cd31b5b41 SHA256 cb150ebed2924b0975bed42fcf2a65f1a0a077627f612937e3fe79135f4d3cce
+MISC ChangeLog 680 RMD160 c307eea722234fbfde4f351d75f28549bcc74bac SHA1 59b7c68bfae03a5441d72b876481e12ad06896a4 SHA256 a1de307a00b32dc0a188a8abbb89a1d9dcf285424f843d70759f985df23fd9c7
+MISC metadata.xml 938 RMD160 e6451a136c100b3cafe90e2e1064dffb77aca7d9 SHA1 1a3b698c05897246eb73666f205ec7d873d20270 SHA256 3541a8cb00af24c3b785d021e1d15a94d9c0883d43a60228dd81ab7898534925
diff --git a/sci-libs/dcmtk/dcmtk-3.5.4-r3.ebuild b/sci-libs/dcmtk/dcmtk-3.5.4-r3.ebuild
new file mode 100644
index 000000000..b25c86f59
--- /dev/null
+++ b/sci-libs/dcmtk/dcmtk-3.5.4-r3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Libraries and applications implementing large parts the DICOM standard"
+HOMEPAGE="http://dicom.offis.de/dcmtk.php.en"
+DEB_PV=3 # Debian patch dcmtk_3.5.4-3.diff
+SRC_URI="
+ftp://dicom.offis.de/pub/dicom/offis/software/dcmtk/dcmtk354/${P}.tar.gz
+mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PV}.diff.gz
+"
+
+# ftp://dicom.offis.de/pub/dicom/offis/software/dcmtk/dcmtk354/COPYRIGHT
+LICENSE="BSD"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="png ssl tcpd tiff xml zlib doc"
+
+RDEPEND="
+media-libs/jpeg
+png? ( media-libs/libpng )
+ssl? ( dev-libs/openssl )
+tcpd? ( sys-apps/tcp-wrappers )
+tiff? ( media-libs/tiff )
+xml? ( dev-libs/libxml2 )
+zlib? ( sys-libs/zlib )
+"
+DEPEND="
+doc? ( app-doc/doxygen )
+${RDEPEND}
+"
+
+src_unpack() {
+
+ unpack ${A}
+ epatch "${PN}_3.5.4-3.diff"
+
+}
+
+src_compile() {
+
+ econf \
+ --sysconfdir=/etc/dcmtk \
+ --with-private-tags \
+ $(use_with tiff libtiff) \
+ $(use_with zlib) \
+ $(use_with png libpng) \
+ $(use_with xml libxml) \
+ $(use_with tcpd libwrap) \
+ $(use_with ssl openssl) \
+ || die "econf failed"
+ # Don't compile without ARCH="" ?!
+ emake ARCH="" || die "emake failed"
+ if use doc; then
+ emake html
+ fi
+
+}
+
+src_install() {
+
+ if use doc; then
+ emake DESTDIR="${D}" install-all \
+ install-doc \
+ || die "emake install failed"
+ else
+ # Note : install-all = install install-lib install-html
+ emake DESTDIR="${D}" install \
+ install-lib \
+ || die "emake install failed"
+ fi
+ dodoc COPYRIGHT FAQ HISTORY *.txt
+ if use doc; then
+ dohtml "${PN}"/html/*
+ fi
+
+}
diff --git a/sci-libs/dcmtk/metadata.xml b/sci-libs/dcmtk/metadata.xml
new file mode 100644
index 000000000..fc6991d13
--- /dev/null
+++ b/sci-libs/dcmtk/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ DCMTK is a collection of libraries and applications implementing large
+ parts the DICOM standard. It includes software for examining,
+ constructing and converting DICOM image files, handling offline media,
+ sending and receiving images over a network connection, as well as
+ demonstrative image storage and worklist servers.
+ </longdescription>
+ <longdescription lang="fr">
+ DCMTK est un ensemble de bibliothèques et d'application implémentant
+ une grande partie du standard DICOM. Cela comprend des logiciels de
+ visualisation et de conversion des fichier image, de manipulation de
+ médias locaux, de réception et d'envoi d'images à travers un réseau
+ ainsi qu'un serveur d'images et de worklist de demonstration.
+ </longdescription>
+</pkgmetadata>