aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2018-10-20 10:31:02 +1300
committerHorea Christian <horea.christ@yandex.com>2018-10-20 23:29:18 +0200
commit6a917c1243b83065c81e4d82c78a6022891df3ef (patch)
tree4ffd2f8d590bc4178484a7b7312205441b3e1df8 /sci-libs
parentsci-biology/SPAdes: version bump, drop old and buggy version (diff)
downloadsci-6a917c1243b83065c81e4d82c78a6022891df3ef.tar.gz
sci-6a917c1243b83065c81e4d82c78a6022891df3ef.tar.bz2
sci-6a917c1243b83065c81e4d82c78a6022891df3ef.zip
sci-libs/ciftilib: compatibility with nifti_io
Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Horea Christian <horea.christ@yandex.com>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ciftilib/ciftilib-1.5.3-r1.ebuild61
-rw-r--r--sci-libs/ciftilib/ciftilib-1.5.3.ebuild38
-rw-r--r--sci-libs/ciftilib/files/ciftilib-1.5.3-openmp_in_pc.patch12
3 files changed, 73 insertions, 38 deletions
diff --git a/sci-libs/ciftilib/ciftilib-1.5.3-r1.ebuild b/sci-libs/ciftilib/ciftilib-1.5.3-r1.ebuild
new file mode 100644
index 000000000..ad4894dd1
--- /dev/null
+++ b/sci-libs/ciftilib/ciftilib-1.5.3-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="C++ Library for reading and writing CIFTI-2 and CIFTI-1 files"
+HOMEPAGE="https://github.com/Washington-University/CiftiLib"
+SRC_URI="https://github.com/Washington-University/CiftiLib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt5"
+
+DEPEND="
+ dev-libs/boost
+ qt5? ( dev-qt/qtcore:5 )
+ !qt5? ( dev-cpp/libxmlpp:2.6 )
+ sys-libs/zlib
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.3-openmp_in_pc.patch
+ )
+
+S="${WORKDIR}/CiftiLib-${PV}"
+
+#TODO: Enable doc building and installation
+
+src_prepare(){
+ # Make sure that CiftiLib headers and code can
+ # coexist with nifti_io headers.
+ # This takes care of the guard in the nifti1.h header
+ # found in both code base.
+ sed \
+ -e "s:NIFTI_:CIFTI_NIFTI__:g" \
+ -i `grep -rl NIFTI_ *`
+ sed \
+ -e "s:DT_:CIFTI_DT_:g" \
+ -i `grep -rl DT_ *`
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(-DBUILD_SHARED_LIBS=ON)
+ use qt5 || mycmakeargs+=(-DIGNORE_QT=TRUE)
+
+ cmake-utils_src_configure
+}
+
+src_test(){
+ #The testsuite is not designed to run in parallel
+ local myctestargs=(
+ -j1
+ )
+ cmake-utils_src_test
+}
diff --git a/sci-libs/ciftilib/ciftilib-1.5.3.ebuild b/sci-libs/ciftilib/ciftilib-1.5.3.ebuild
deleted file mode 100644
index fc473f38c..000000000
--- a/sci-libs/ciftilib/ciftilib-1.5.3.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit cmake-utils
-
-DESCRIPTION="C++ Library for reading and writing CIFTI-2 and CIFTI-1 files"
-HOMEPAGE="https://github.com/Washington-University/CiftiLib"
-SRC_URI="https://github.com/Washington-University/CiftiLib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-cpp/libxmlpp:2.6
- dev-libs/boost
- sys-libs/zlib
- "
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/CiftiLib-${PV}"
-
-src_configure() {
- local mycmakeargs=(
- -DIGNORE_QT=TRUE
- )
- cmake-utils_src_configure
-}
-
-src_test(){
- local myctestargs=(
- -j1
- )
- cmake-utils_src_test
-}
diff --git a/sci-libs/ciftilib/files/ciftilib-1.5.3-openmp_in_pc.patch b/sci-libs/ciftilib/files/ciftilib-1.5.3-openmp_in_pc.patch
new file mode 100644
index 000000000..6fd35159a
--- /dev/null
+++ b/sci-libs/ciftilib/files/ciftilib-1.5.3-openmp_in_pc.patch
@@ -0,0 +1,12 @@
+diff --git a/CiftiLib.pc.in b/CiftiLib.pc.in
+index 13cd78c..8db6c46 100644
+--- a/CiftiLib.pc.in
++++ b/CiftiLib.pc.in
+@@ -5,6 +5,6 @@ Name: CiftiLib
+ Description: C++ Library for reading and writing CIFTI-2 and CIFTI-1 files
+ Version: @CIFTILIB_VERSION@
+ URL: https://github.com/Washington-University/CiftiLib
+-Cflags: -I${includedir}/CiftiLib @CIFTILIB_PKGCONFIG_DEFINE@
++Cflags: -I${includedir}/CiftiLib @CIFTILIB_PKGCONFIG_DEFINE@ @OpenMP_CXX_FLAGS@
+ Libs: -L${libdir} -lCifti
+ @CIFTILIB_PKGCONFIG_REQUIRES_LINE@