aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-23 13:24:49 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-23 13:24:49 +0200
commit6f3a246f8e002a97901296b357183afd09b9e749 (patch)
treefb0faa417f534128c7c12ce93e87862f35aea56b /sci-libs
parentsci-libs/tmglib: Bump to EAPI=5 (diff)
downloadsci-6f3a246f8e002a97901296b357183afd09b9e749.tar.gz
sci-6f3a246f8e002a97901296b357183afd09b9e749.tar.bz2
sci-6f3a246f8e002a97901296b357183afd09b9e749.zip
sci-libs/pg2plplot: Bump to EAPI=5
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pg2plplot/pg2plplot-0.2.0.ebuild13
-rw-r--r--sci-libs/pg2plplot/pg2plplot-0.3.1.ebuild8
2 files changed, 10 insertions, 11 deletions
diff --git a/sci-libs/pg2plplot/pg2plplot-0.2.0.ebuild b/sci-libs/pg2plplot/pg2plplot-0.2.0.ebuild
index ad018dd6a..1606c7558 100644
--- a/sci-libs/pg2plplot/pg2plplot-0.2.0.ebuild
+++ b/sci-libs/pg2plplot/pg2plplot-0.2.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit cmake-utils fortran-2
@@ -15,14 +15,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="X png postscript static-libs"
-DEPEND="virtual/fortran
- sci-libs/plplot[fortran]"
+DEPEND="sci-libs/plplot[fortran]"
# If USE="png" or "postscript", ensure PLplot has USE="cairo":
RDEPEND="${DEPEND}
- sci-libs/plplot[fortran,X?]
- png? ( sci-libs/plplot[cairo] )
- postscript? ( sci-libs/plplot[cairo] )"
+ sci-libs/plplot[fortran,X?]
+ png? ( sci-libs/plplot[cairo] )
+ postscript? ( sci-libs/plplot[cairo] )"
src_configure() {
local mycmakeargs=(
diff --git a/sci-libs/pg2plplot/pg2plplot-0.3.1.ebuild b/sci-libs/pg2plplot/pg2plplot-0.3.1.ebuild
index 6a5cb331e..953ea72ed 100644
--- a/sci-libs/pg2plplot/pg2plplot-0.3.1.ebuild
+++ b/sci-libs/pg2plplot/pg2plplot-0.3.1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+FORTRAN_STANDARD=90
+
inherit cmake-utils fortran-2
DESCRIPTION="Assist the transition from PGPlot to PLplot in Fortran programs"
@@ -15,8 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="X png postscript static-libs"
-DEPEND="virtual/fortran
- sci-libs/plplot[fortran]"
+DEPEND="sci-libs/plplot[fortran]"
# If USE="png" or "postscript", ensure PLplot has USE="cairo":
RDEPEND="${DEPEND}
@@ -25,7 +26,6 @@ RDEPEND="${DEPEND}
postscript? ( sci-libs/plplot[cairo] )"
DOCS=( CHANGELOG README VERSION )
-FORTRAN_STANDARD=90
src_prepare() {
sed -i -e "s:/usr:${EPREFIX}/usr:g" CMake/CMakeLocations.cmake || die