aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoelof Wobben <rwobben@hotmail.com>2009-12-08 20:09:31 +0100
committerRoelof Wobben <rwobben@hotmail.com>2009-12-08 20:09:31 +0100
commit97566d0b9b27dbd7f0c43853a370d8230da9ce84 (patch)
treed9a6dc9500a906809f2fe89c7f4747ec3c8dc0ea /sci-libs
parentsci-chemistry/burrow-owl fixed starparse dpe to >=1.0 (diff)
downloadsci-97566d0b9b27dbd7f0c43853a370d8230da9ce84.tar.gz
sci-97566d0b9b27dbd7f0c43853a370d8230da9ce84.tar.bz2
sci-97566d0b9b27dbd7f0c43853a370d8230da9ce84.zip
Version bump of Coin to 3.1.2
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/coin/ChangeLog9
-rw-r--r--sci-libs/coin/Manifest2
-rw-r--r--sci-libs/coin/coin-3.1.2.ebuild64
-rw-r--r--sci-libs/coin/metadata.xml5
4 files changed, 80 insertions, 0 deletions
diff --git a/sci-libs/coin/ChangeLog b/sci-libs/coin/ChangeLog
new file mode 100644
index 000000000..a1ed73cae
--- /dev/null
+++ b/sci-libs/coin/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-libs/coin
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*coin-3.1.2 (08 Dec 2009)
+
+ 08 Dec 2009; <roelof@gentoo.org> +coin-3.1.2.ebuild, +metadata.xml:
+ Version bump of Coin to 3.1.2
+
diff --git a/sci-libs/coin/Manifest b/sci-libs/coin/Manifest
new file mode 100644
index 000000000..c0f67c05b
--- /dev/null
+++ b/sci-libs/coin/Manifest
@@ -0,0 +1,2 @@
+DIST Coin-3.1.2.tar.gz 5557072 RMD160 8b357238ed8f9d718b240911ee9c6fc7d1881213 SHA1 5cf0018da2e67e0fa2858f094bb170acb20f3055 SHA256 2b97c7fc738f73cb76e59f72d16013012ef07733d6455c5efa3a897ef7cb0845
+EBUILD coin-3.1.2.ebuild 1537 RMD160 c0481d888876ac2bbc73c818dc6973e3cc510959 SHA1 4932767a74e715b25b661fce15063a46cf6a6548 SHA256 5db9236955884bef804b763d06e015585f16b9c8b24de59d6fa6731af6bc47be
diff --git a/sci-libs/coin/coin-3.1.2.ebuild b/sci-libs/coin/coin-3.1.2.ebuild
new file mode 100644
index 000000000..3025fcecd
--- /dev/null
+++ b/sci-libs/coin/coin-3.1.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+MY_P=Coin"-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="a high-level 3D graphics toolkit, fully compatible with SGI Open Inventor 2.1"
+HOMEPAGE="http://www.coin3d.org/"
+SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/all/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 PEL )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="debug doc java javascript openal"
+
+RDEPEND="media-libs/fontconfig
+ media-libs/freetype
+ virtual/opengl
+ virtual/glu
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ java? ( virtual/jdk )
+ javascript? ( dev-lang/spidermonkey )
+ openal? ( media-libs/openal )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ htmldir=/usr/share/doc/${PF}/html \
+ --enable-3ds-import \
+ --enable-threadsafe \
+ --with-fontconfig \
+ --with-freetype \
+ $(use_enable debug) \
+ $(use_enable debug symbols) \
+ $(use_enable doc html) \
+ $(use_enable doc man) \
+ $(use_enable java java-wrapper) \
+ $(use_enable javascript javascript-api) \
+ $(use_enable openal sound) \
+ $(use_with javascript spidermonkey) \
+ $(use_with openal)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS FAQ FAQ.legal NEWS README RELNOTES THANKS docs/ChangeLog.v${PV}
+}
+
diff --git a/sci-libs/coin/metadata.xml b/sci-libs/coin/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/sci-libs/coin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>