aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-11 10:12:43 +0100
committerJustin Lecher <jlec@gentoo.org>2015-01-11 10:12:43 +0100
commitb57991369687010ca643fc11e2a09c7130d76add (patch)
treede3f27485bf5af058f84fe0f1048d3e1137999ec /sci-libs
parentsci-chemistry/dssp2pdb: Fix S (diff)
parentMerge pull request #320 from marbre/arrayfire (diff)
downloadsci-b57991369687010ca643fc11e2a09c7130d76add.tar.gz
sci-b57991369687010ca643fc11e2a09c7130d76add.tar.bz2
sci-b57991369687010ca643fc11e2a09c7130d76add.zip
Merge remote-tracking branch 'github/master'
* github/master: sci-libs/arrayfire: Improve and clean gtest src handling sci-libs/arrayfire: Fix DEPEND, unpacker is used instead of unzip sci-biology/rnaplex: Fixes according to jlec's advices sci-biology/codonw: Drop unnecessary dies Drop unnecessary die ci-biology/rnaplex: Move to EAPI=5; Update homepage and SRC_URI. sci-biology/codonw: Move to EAPI=5
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/arrayfire/arrayfire-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sci-libs/arrayfire/arrayfire-9999.ebuild b/sci-libs/arrayfire/arrayfire-9999.ebuild
index a1af26b91..107af240e 100644
--- a/sci-libs/arrayfire/arrayfire-9999.ebuild
+++ b/sci-libs/arrayfire/arrayfire-9999.ebuild
@@ -4,12 +4,14 @@
EAPI=5
-inherit cmake-utils git-r3 unpacker
+inherit cmake-utils git-r3
+
+GTEST_PV="1.7.0"
DESCRIPTION="A general purpose GPU library."
HOMEPAGE="http://www.arrayfire.com/"
EGIT_REPO_URI="https://github.com/arrayfire/arrayfire.git"
-SRC_URI="test? ( https://googletest.googlecode.com/files/gtest-1.7.0.zip )"
+SRC_URI="test? ( https://googletest.googlecode.com/files/gtest-${GTEST_PV}.zip )"
KEYWORDS="~amd64"
LICENSE="BSD"
@@ -22,8 +24,7 @@ RDEPEND="
virtual/cblas
cuda? ( >=dev-util/nvidia-cuda-toolkit-6.0 )
sci-libs/fftw:3.0"
-DEPEND="${RDEPEND}
- test? ( app-arch/unzip )"
+DEPEND="${RDEPEND}"
BUILD_DIR="${S}/build"
CMAKE_BUILD_TYPE=Release
@@ -52,8 +53,8 @@ src_unpack() {
if use test; then
mkdir -p "${BUILD_DIR}"/third_party/src/ || die
cd "${BUILD_DIR}"/third_party/src/ || die
- unpack_zip "${DISTDIR}/"gtest-1.7.0.zip
- mv "${BUILD_DIR}"/third_party/src/gtest-1.7.0 "${BUILD_DIR}"/third_party/src/googletest || die
+ unpack ${A}
+ mv "${BUILD_DIR}"/third_party/src/gtest-"${GTEST_PV}" "${BUILD_DIR}"/third_party/src/googletest || die
fi
}