aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-06-05 12:52:49 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-06-05 12:52:49 +0900
commitb82654f969dd805b8d0510f1034b0e9cc1e7258e (patch)
tree5d31230a640eac3c2ab722081ed86d8261723acd /sci-libs
parentsci-libs/lapack-reference: guide cmake to find eselected blas (diff)
downloadsci-b82654f969dd805b8d0510f1034b0e9cc1e7258e.tar.gz
sci-b82654f969dd805b8d0510f1034b0e9cc1e7258e.tar.bz2
sci-b82654f969dd805b8d0510f1034b0e9cc1e7258e.zip
sci-libs/cblas-reference: guide cmake to find eselected blas
same rational as commit e6181c66eac for lapack-reference. alternative.eclass blas.pc gives -L"${libdir}" -lxxx. The bare quotes confuses cmake parser. Escaping the quotes is tedious, but solves the problem. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cblas-reference/cblas-reference-20161223-r101.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sci-libs/cblas-reference/cblas-reference-20161223-r101.ebuild b/sci-libs/cblas-reference/cblas-reference-20161223-r101.ebuild
index 4b39f5657..821c3510f 100644
--- a/sci-libs/cblas-reference/cblas-reference-20161223-r101.ebuild
+++ b/sci-libs/cblas-reference/cblas-reference-20161223-r101.ebuild
@@ -80,7 +80,7 @@ src_configure() {
-DPROFNAME="${profname}"
-DLIBNAME="${libname}"
-DUSE_OPTIMIZED_BLAS=ON
- -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${blas_profname})"
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${blas_profname} | sed 's,",\\\\\\\",g')"
-DCMAKE_C_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CFLAGS}"
-DCMAKE_CXX_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CXXFLAGS}"
-DCMAKE_Fortran_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) $(get_abi_CFLAGS) $(numeric-int64_get_fortran_int64_abi_fflags) ${FCFLAGS}"