aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-26 07:38:19 -0400
committerHorea Christian <chr@chymera.eu>2020-09-26 07:38:19 -0400
commitbe7bc5dffb18eb95db07ce1c6d49c5ceab398096 (patch)
treed7bef9f4cc602ec2ec288a28be7033b20493d2a2 /sci-libs
parentsci-biology/pysurfer: removed package with missing dep (mayavi) (diff)
downloadsci-be7bc5dffb18eb95db07ce1c6d49c5ceab398096.tar.gz
sci-be7bc5dffb18eb95db07ce1c6d49c5ceab398096.tar.bz2
sci-be7bc5dffb18eb95db07ce1c6d49c5ceab398096.zip
sci-libs/nipy: PYTHON_COMPAT and live ebuild update
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nipy/nipy-0.4.1.ebuild2
-rw-r--r--sci-libs/nipy/nipy-0.4.2.ebuild2
-rw-r--r--sci-libs/nipy/nipy-9999.ebuild33
3 files changed, 27 insertions, 10 deletions
diff --git a/sci-libs/nipy/nipy-0.4.1.ebuild b/sci-libs/nipy/nipy-0.4.1.ebuild
index 93f16c86b..ea3c05d80 100644
--- a/sci-libs/nipy/nipy-0.4.1.ebuild
+++ b/sci-libs/nipy/nipy-0.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_7 )
inherit distutils-r1 eutils multilib flag-o-matic
diff --git a/sci-libs/nipy/nipy-0.4.2.ebuild b/sci-libs/nipy/nipy-0.4.2.ebuild
index b2151fb91..2793dc057 100644
--- a/sci-libs/nipy/nipy-0.4.2.ebuild
+++ b/sci-libs/nipy/nipy-0.4.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_7 )
inherit distutils-r1 eutils multilib flag-o-matic
diff --git a/sci-libs/nipy/nipy-9999.ebuild b/sci-libs/nipy/nipy-9999.ebuild
index 0fb447c4f..5eac0416a 100644
--- a/sci-libs/nipy/nipy-9999.ebuild
+++ b/sci-libs/nipy/nipy-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_7 )
-inherit distutils-r1 multilib git-r3 flag-o-matic
+inherit distutils-r1 eutils multilib flag-o-matic git-r3
DESCRIPTION="Neuroimaging tools for Python"
HOMEPAGE="http://nipy.org/"
@@ -14,17 +14,21 @@ EGIT_REPO_URI="https://github.com/nipy/nipy"
LICENSE="BSD"
SLOT="0"
-IUSE=""
KEYWORDS=""
+IUSE=""
-DEPEND="
+RDEPEND="
dev-python/prov[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/sympy[${PYTHON_USEDEP}]
- >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]"
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ "
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
python_prepare_all() {
distutils-r1_python_prepare_all
@@ -35,3 +39,16 @@ python_prepare_all() {
# nipy uses the horrible numpy.distutils automagic
}
+
+python_test() {
+ distutils-r1_install_for_testing
+ cp nipy/testing/*.nii.gz "${BUILD_DIR}/lib/nipy/testing/"
+ cp nipy/modalities/fmri/tests/*.{mat,npz,txt} "${BUILD_DIR}/lib/nipy/modalities/fmri/tests/"
+ cp nipy/algorithms/statistics/models/tests/test_data.bin "${BUILD_DIR}/lib/nipy/algorithms/statistics/models/tests"
+ cp nipy/labs/spatial_models/tests/some_blobs.nii "${BUILD_DIR}/lib/nipy/labs/spatial_models/tests/some_blobs.nii"
+ mkdir "${BUILD_DIR}/lib/nipy/algorithms/diagnostics/tests/data/"
+ cp nipy/algorithms/diagnostics/tests/data/tsdiff_results.mat "${BUILD_DIR}/lib/nipy/algorithms/diagnostics/tests/data/"
+ cd "${BUILD_DIR}" || die
+ echo "backend : agg" > matplotlibrc
+ nosetests || die
+}