aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-04 13:07:59 +0100
committerJustin Lecher <jlec@gentoo.org>2014-01-04 13:07:59 +0100
commitf6fdfb4d43a0608a1b48d0485272df4039387924 (patch)
treee2a7203ae61620df64bbaaebae0e8dd0ed405014 /sci-libs
parentmask sci-libs/dealii[metis] due to masked deps (diff)
downloadsci-f6fdfb4d43a0608a1b48d0485272df4039387924.tar.gz
sci-f6fdfb4d43a0608a1b48d0485272df4039387924.tar.bz2
sci-f6fdfb4d43a0608a1b48d0485272df4039387924.zip
sci-libs/dealii: Add missing die; shorten DESCRIPTION; add dummy locel USE description; Fix RDEPEND.suspect
Package-Manager: portage-2.2.7
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/dealii/ChangeLog9
-rw-r--r--sci-libs/dealii/dealii-9999.ebuild41
-rw-r--r--sci-libs/dealii/metadata.xml42
3 files changed, 53 insertions, 39 deletions
diff --git a/sci-libs/dealii/ChangeLog b/sci-libs/dealii/ChangeLog
new file mode 100644
index 000000000..ab51b21cb
--- /dev/null
+++ b/sci-libs/dealii/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-libs/dealii
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 04 Jan 2014; Justin Lecher <jlec@gentoo.org> dealii-9999.ebuild,
+ metadata.xml:
+ Add missing die; shorten DESCRIPTION; add dummy locel USE description; Fix
+ RDEPEND.suspect
+
diff --git a/sci-libs/dealii/dealii-9999.ebuild b/sci-libs/dealii/dealii-9999.ebuild
index 91fa994cb..89f714a4e 100644
--- a/sci-libs/dealii/dealii-9999.ebuild
+++ b/sci-libs/dealii/dealii-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 2013 Gentoo Foundation
+# Copyright 2013-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
if [[ "${PV}" == "9999" ]] ; then
- inherit cmake-utils subversion eutils multilib
+ inherit cmake-utils eutils multilib subversion
else
inherit cmake-utils eutils multilib
fi
-DESCRIPTION="library for solving partial differential equations with the finite element method"
+DESCRIPTION="Solving partial differential equations with the finite element method"
HOMEPAGE="http://www.dealii.org/"
if [[ "${PV}" == "9999" ]] ; then
@@ -18,7 +18,8 @@ if [[ "${PV}" == "9999" ]] ; then
ESVN_OPTIONS="--trust-server-cert --non-interactive"
KEYWORDS=""
else
- SRC_URI="https://dealii.googlecode.com/files/deal.II-${PV}.tar.gz
+ SRC_URI="
+ https://dealii.googlecode.com/files/deal.II-${PV}.tar.gz
doc? ( https://dealii.googlecode.com/files/deal.offlinedoc-${PV}.tar.gz )"
S="${WORKDIR}/deal.II"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
@@ -27,9 +28,9 @@ fi
LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="
- arpack avx +debug doc +examples hdf5 +lapack mesh_converter metis mpi
- mumps netcdf p4est parameter_gui petsc +sparse sse2 static-libs +tbb
- trilinos +zlib
+ arpack avx +debug doc +examples hdf5 +lapack mesh_converter metis mpi
+ mumps netcdf p4est parameter_gui petsc +sparse sse2 static-libs +tbb
+ trilinos +zlib
"
# TODO: add slepc use flag once slepc is packaged for gentoo-science
@@ -42,7 +43,6 @@ REQUIRED_USE="
RDEPEND="
dev-libs/boost
arpack? ( sci-libs/arpack[mpi=] )
- doc? ( app-doc/doxygen[dot] dev-lang/perl )
hdf5? ( sci-libs/hdf5[mpi=] )
lapack? ( virtual/lapack )
metis? ( >=sci-libs/parmetis-4 )
@@ -61,6 +61,7 @@ RDEPEND="
DEPEND="
${RDEPEND}
virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] dev-lang/perl )
"
src_configure() {
@@ -78,9 +79,16 @@ src_configure() {
local mycmakeargs=(
${live_version}
- "-DDEAL_II_ALLOW_AUTODETECTION=OFF"
- "-DDEAL_II_ALLOW_BUNDLED=OFF"
- "-DDEAL_II_ALLOW_PLATFORM_INTROSPECTION=OFF"
+ -DDEAL_II_ALLOW_AUTODETECTION=OFF
+ -DDEAL_II_ALLOW_BUNDLED=OFF
+ -DDEAL_II_ALLOW_PLATFORM_INTROSPECTION=OFF
+ -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=OFF
+ -DDEAL_II_COMPONENT_COMPAT_FILES=OFF
+ -DDEAL_II_CMAKE_MACROS_RELDIR=share/${PN}/cmake/macros
+ -DDEAL_II_DOCHTML_RELDIR=share/doc/${PF}/html
+ -DDEAL_II_DOCREADME_RELDIR=share/doc/${PF}/
+ -DDEAL_II_EXAMPLES_RELDIR=share/doc/${PF}/examples
+ -DDEAL_II_LIBRARY_RELDIR=$(get_libdir)
$(cmake-utils_use arpack DEAL_II_WITH_ARPACK)
$(cmake-utils_use avx DEAL_II_HAVE_AVX)
$(cmake-utils_use doc DEAL_II_COMPONENT_DOCUMENTATION)
@@ -102,24 +110,17 @@ src_configure() {
$(cmake-utils_use tbb DEAL_II_WITH_THREADS)
$(cmake-utils_use trilinos DEAL_II_WITH_TRILINOS)
$(cmake-utils_use zlib DEAL_II_WITH_ZLIB)
- "-DCMAKE_INSTALL_RPATH_USE_LINK_PATH=OFF"
- "-DDEAL_II_COMPONENT_COMPAT_FILES=OFF"
- "-DDEAL_II_CMAKE_MACROS_RELDIR=share/${PN}/cmake/macros"
- "-DDEAL_II_DOCHTML_RELDIR=share/doc/${PF}/html"
- "-DDEAL_II_DOCREADME_RELDIR=share/doc/${PF}/"
- "-DDEAL_II_EXAMPLES_RELDIR=share/doc/${PF}/examples"
- "-DDEAL_II_LIBRARY_RELDIR=$(get_libdir)"
)
cmake-utils_src_configure
}
src_install() {
- dodoc README
+ DOCS=( README )
if use doc; then
if [[ ${PV} != "9999" ]] ; then
# copy missing images to the build directory:
- cp -r "${WORKDIR}"/doc/doxygen/deal.II/images "${BUILD_DIR}"/doc/doxygen/deal.II
+ cp -r "${WORKDIR}"/doc/doxygen/deal.II/images "${BUILD_DIR}"/doc/doxygen/deal.II || die
# replace links:
sed -i \
's#"http://www.dealii.org/images/steps/developer/\(step-.*\)"#"images/\1"#g' \
diff --git a/sci-libs/dealii/metadata.xml b/sci-libs/dealii/metadata.xml
index 65475b58a..356ec3fef 100644
--- a/sci-libs/dealii/metadata.xml
+++ b/sci-libs/dealii/metadata.xml
@@ -1,28 +1,32 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>tamiko+GENTOO@kyomu.43-1.org</email>
- <name>Matthias Maier</name>
-</maintainer>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <maintainer>
+ <email>tamiko+GENTOO@kyomu.43-1.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <longdescription lang="en">
deal.II is a C++ program library targeted at the computational solution
of partial differential equations using adaptive finite elements. It uses
state-of-the-art programming techniques to offer you a modern interface
to the complex data structures and algorithms required.
</longdescription>
-<use>
- <flag name="arpack">Adds support for ARPACK (<pkg>sci-libs/arpack</pkg>)</flag>
- <flag name="avx">Use Advanced Vector Extensions for AVX capable chips</flag>
- <flag name="debug">Build an additional debug library with extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see &lt;http://www.gentoo.org/proj/en/qa/backtraces.xml&gt;</flag>
- <flag name="mesh_converter">Build and install the mesh_converter executable</flag>
- <flag name="metis">Add support for metis (<pkg>sci-libs/metis</pkg>)</flag>
- <flag name="mumps">Add support for mumps (<pkg>sci-libs/mumps</pkg>)</flag>
- <flag name="p4est">Add support for p4est (<pkg>sci-mathematics/p4est</pkg>)</flag>
- <flag name="parameter_gui">Build and install the parameter_gui executable</flag>
- <flag name="petsc">Add support for petsc (<pkg>sci-libs/petsc</pkg>)</flag>
- <flag name="tbb">Add threading support with the help of the tbb library (<pkg>dev-cpp/tbb</pkg>)</flag>
- <flag name="trilinos">Add support for trilinos (<pkg>sci-libs/trilinos</pkg>)</flag>
-</use>
+ <use>
+ <flag name="arpack">Adds support for ARPACK (<pkg>sci-libs/arpack</pkg>)</flag>
+ <flag name="avx">Use Advanced Vector Extensions for AVX capable chips</flag>
+ <flag name="debug">
+ Build an additional debug library with extra debug codepaths, like asserts
+ and extra output. If you want to get meaningful backtraces see
+ &lt;http://www.gentoo.org/proj/en/qa/backtraces.xml&gt;</flag>
+ <flag name="mesh_converter">Build and install the mesh_converter executable</flag>
+ <flag name="metis">Add support for metis (<pkg>sci-libs/metis</pkg>)</flag>
+ <flag name="mumps">Add support for mumps (<pkg>sci-libs/mumps</pkg>)</flag>
+ <flag name="p4est">Add support for p4est (<pkg>sci-mathematics/p4est</pkg>)</flag>
+ <flag name="parameter_gui">Build and install the parameter_gui executable</flag>
+ <flag name="petsc">Add support for petsc (<pkg>sci-libs/petsc</pkg>)</flag>
+ <flag name="sparse">A nice USE flag</flag>
+ <flag name="tbb">Add threading support with the help of the tbb library (<pkg>dev-cpp/tbb</pkg>)</flag>
+ <flag name="trilinos">Add support for trilinos (<pkg>sci-libs/trilinos</pkg>)</flag>
+ </use>
</pkgmetadata>