aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-21 20:29:53 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-21 20:29:53 +0200
commit0d912fad71b5b99852c8506abc966543335fa12d (patch)
tree1272e5150f383e5c71839e1edea5ffdcab6a26a0 /sci-mathematics/alt-ergo
parentsci-physics/clip: Add subslot operators (diff)
downloadsci-0d912fad71b5b99852c8506abc966543335fa12d.tar.gz
sci-0d912fad71b5b99852c8506abc966543335fa12d.tar.bz2
sci-0d912fad71b5b99852c8506abc966543335fa12d.zip
sci-mathematics/alt-ergo: Add subslot operators
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-mathematics/alt-ergo')
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-0.95.2.ebuild19
-rw-r--r--sci-mathematics/alt-ergo/metadata.xml4
2 files changed, 13 insertions, 10 deletions
diff --git a/sci-mathematics/alt-ergo/alt-ergo-0.95.2.ebuild b/sci-mathematics/alt-ergo/alt-ergo-0.95.2.ebuild
index 3cabe4d31..2ec5ece94 100644
--- a/sci-mathematics/alt-ergo/alt-ergo-0.95.2.ebuild
+++ b/sci-mathematics/alt-ergo/alt-ergo-0.95.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -15,11 +15,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+ocamlopt gtk"
-DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
- >=dev-ml/ocamlgraph-1.8.2[gtk?,ocamlopt?]
- dev-ml/zarith
- gtk? ( >=x11-libs/gtksourceview-2.8
- >=dev-ml/lablgtk-2.14[sourceview,ocamlopt?] )"
+DEPEND="
+ >=dev-lang/ocaml-3.12.1[ocamlopt?]
+ >=dev-ml/ocamlgraph-1.8.2[gtk?,ocamlopt?]
+ dev-ml/zarith
+ gtk? (
+ >=x11-libs/gtksourceview-2.8:2.0
+ >=dev-ml/lablgtk-2.14[sourceview,ocamlopt?]
+ )"
RDEPEND="${DEPEND}"
src_prepare(){
@@ -29,12 +32,12 @@ src_prepare(){
-i "${S}"/Makefile.in || die
}
src_compile(){
- emake
+ default
use gtk && emake gui
}
src_install(){
- emake install DESTDIR="${D}"
+ default
use gtk && emake install-gui DESTDIR="${D}"
dodoc README.md CHANGES
}
diff --git a/sci-mathematics/alt-ergo/metadata.xml b/sci-mathematics/alt-ergo/metadata.xml
index 70209e070..388d8d755 100644
--- a/sci-mathematics/alt-ergo/metadata.xml
+++ b/sci-mathematics/alt-ergo/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription>
+ <herd>sci-mathematics</herd>
+ <longdescription>
Alt-Ergo is an open source automatic theorem prover dedicated to program verification.
It is an SMT solver based on CC(X): a congruence closure algorithm parameterized by an
equational theory X. Alt-Ergo is based on a home-made SAT-solver and implements an