aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan-Christofer Demay <jcdemay@gmail.com>2010-07-04 11:08:41 +0000
committerJonathan-Christofer Demay <jcdemay@gmail.com>2010-07-04 11:08:41 +0000
commit16ab0299a022f4e92283e1dbd4daf7a55d085486 (patch)
tree4709ec8c3fbb0a70b9934e918741a421c6a5710b /sci-mathematics/apron/apron-0.9.10.ebuild
parentAdded longdescription to metadata.xml (diff)
downloadsci-16ab0299a022f4e92283e1dbd4daf7a55d085486.tar.gz
sci-16ab0299a022f4e92283e1dbd4daf7a55d085486.tar.bz2
sci-16ab0299a022f4e92283e1dbd4daf7a55d085486.zip
sci-mathematics/apron: building process fixed for the latest sources
Diffstat (limited to 'sci-mathematics/apron/apron-0.9.10.ebuild')
-rw-r--r--sci-mathematics/apron/apron-0.9.10.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sci-mathematics/apron/apron-0.9.10.ebuild b/sci-mathematics/apron/apron-0.9.10.ebuild
index 284d2132b..ad2356bec 100644
--- a/sci-mathematics/apron/apron-0.9.10.ebuild
+++ b/sci-mathematics/apron/apron-0.9.10.ebuild
@@ -33,8 +33,8 @@ src_prepare() {
sed -i Makefile.config \
-e "s/FLAGS = \\\/FLAGS += \\\/g" \
-e "s/-O3 -DNDEBUG/-DNDEBUG/g" \
- -e "s/APRON_PREFIX = \/usr/APRON_PREFIX = \${DESTDIR}\/usr/g" \
- -e "s/MLGMPIDL_PREFIX = \/usr\/local/MLGMPIDL_PREFIX = \${DESTDIR}\/usr/g"
+ -e "s/APRON_PREFIX =.*/APRON_PREFIX = \${DESTDIR}\/usr/g" \
+ -e "s/MLGMPIDL_PREFIX =.*/MLGMPIDL_PREFIX = \${DESTDIR}\/usr/g"
#fix doc building process
sed -i Makefile -e "s/; make html/; make/g"
@@ -59,16 +59,14 @@ src_prepare() {
else
die "USE flag 'cxx' needs USE flag 'ppl' set"
fi
-
- epatch "${FILESDIR}/${P}-pkgrid_manager.patch"
}
src_compile() {
#damn crappy Makefile
emake || emake || die "emake failed"
- if use doc; then
- emake doc || "emake doc failed"
+ if use doc && use cxx; then
+ emake -C apronxx doc || "emake doc failed"
fi
}