aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2012-11-23 17:21:35 +0100
committerJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2012-11-23 17:21:35 +0100
commitb8f32087e941442da3a4e1f453a962f8f212ac28 (patch)
tree6b4a05ab26ae088a9be4ef44e2db24d974860db1 /sci-mathematics/cdfplayer
parentsci-physics/LoopTools: Manifest fixed (diff)
downloadsci-b8f32087e941442da3a4e1f453a962f8f212ac28.tar.gz
sci-b8f32087e941442da3a4e1f453a962f8f212ac28.tar.bz2
sci-b8f32087e941442da3a4e1f453a962f8f212ac28.zip
sci-mathematics/cdfplayer: new ebuild for bug #421019
Diffstat (limited to 'sci-mathematics/cdfplayer')
-rw-r--r--sci-mathematics/cdfplayer/ChangeLog11
-rw-r--r--sci-mathematics/cdfplayer/Manifest1
-rw-r--r--sci-mathematics/cdfplayer/cdfplayer-8.0.4.ebuild39
-rw-r--r--sci-mathematics/cdfplayer/files/cdfplayer-8.0.4-installer.patch19
-rw-r--r--sci-mathematics/cdfplayer/metadata.xml12
5 files changed, 82 insertions, 0 deletions
diff --git a/sci-mathematics/cdfplayer/ChangeLog b/sci-mathematics/cdfplayer/ChangeLog
new file mode 100644
index 000000000..e9ba9c3b9
--- /dev/null
+++ b/sci-mathematics/cdfplayer/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/cdfplayer
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*cdfplayer-8.0.4 (23 Nov 2012)
+
+ 23 Nov 2012; Jauhien Piatlicki (jauhien) <piatlicki@gmail.com>
+ +cdfplayer-8.0.4.ebuild, +files/cdfplayer-8.0.4-installer.patch,
+ +metadata.xml:
+ initial commit for bug #421019
+
diff --git a/sci-mathematics/cdfplayer/Manifest b/sci-mathematics/cdfplayer/Manifest
new file mode 100644
index 000000000..cc6b32c4c
--- /dev/null
+++ b/sci-mathematics/cdfplayer/Manifest
@@ -0,0 +1 @@
+DIST CDFPlayer_8.0.4_LINUX.sh 235344672 SHA256 e0d5c72e90ba96c959fb06b39bc50064c52ea1cd31556fa658307c0a0d56ea1b SHA512 31f7ee997366d286e4b2897165f0eac21d514b48fb2808940a8ec8fd51a5d87f86805413a109d07f46c117dc5aa1a2b9900d7c6c30d5b6f70e352229d18962b4 WHIRLPOOL 2c696e1040bc86b1d7eaac4658d196dbe11a06e4efecb39172e3b1315b2b88053296ac34031f5027a683db291ff6c398bf24b859bede0e657a3b78585c593140
diff --git a/sci-mathematics/cdfplayer/cdfplayer-8.0.4.ebuild b/sci-mathematics/cdfplayer/cdfplayer-8.0.4.ebuild
new file mode 100644
index 000000000..e6cbca8ce
--- /dev/null
+++ b/sci-mathematics/cdfplayer/cdfplayer-8.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+MY_SCRIPT=CDFPlayer_${PV}_LINUX.sh
+
+DESCRIPTION="Player for Wolfram CDF"
+HOMEPAGE="http://www.wolfram.com/cdf-player/"
+SRC_URI="http://www.wolfram.com/cdf-player/${MY_SCRIPT}"
+LICENSE="cdfplayer"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+RESTRICT="fetch test"
+
+pkg_nofetch() {
+ einfo Download ${MY_SCRIPT} from ${HOMEPAGE}
+ einfo and move it to ${DISTDIR}
+}
+
+src_unpack() {
+ mkdir "${S}"
+ cp "${DISTDIR}/${MY_SCRIPT}" "${S}/${MY_SCRIPT}"
+ chmod u+x "${S}/${MY_SCRIPT}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-installer.patch"
+}
+
+src_install() {
+ "${S}/${MY_SCRIPT}" --target "${S}/${P}" -- -auto -verbose -createdir=y \
+ -targetdir="${D}/opt" -execdir="${D}/usr/bin"
+}
diff --git a/sci-mathematics/cdfplayer/files/cdfplayer-8.0.4-installer.patch b/sci-mathematics/cdfplayer/files/cdfplayer-8.0.4-installer.patch
new file mode 100644
index 000000000..9deef53c5
--- /dev/null
+++ b/sci-mathematics/cdfplayer/files/cdfplayer-8.0.4-installer.patch
@@ -0,0 +1,19 @@
+--- CDFPlayer_8.0.4_LINUX.sh
++++ CDFPlayer_8.0.4_LINUX.sh
+@@ -261,11 +261,11 @@
+ fi
+ done
+ chmod a+x $0 || echo Please add execution rights on $0
+- if test `echo "$0" | cut -c1` = "/"; then # Spawn a terminal!
+- exec $XTERM -title "$label" -e "$0" --xwin "$@"
+- else
+- exec $XTERM -title "$label" -e "./$0" --xwin "$@"
+- fi
++ #if test `echo "$0" | cut -c1` = "/"; then # Spawn a terminal!
++ # exec $XTERM -title "$label" -e "$0" --xwin "$@"
++ #else
++ # exec $XTERM -title "$label" -e "./$0" --xwin "$@"
++ #fi
+ fi
+ fi
+ fi
diff --git a/sci-mathematics/cdfplayer/metadata.xml b/sci-mathematics/cdfplayer/metadata.xml
new file mode 100644
index 000000000..9a62da3ef
--- /dev/null
+++ b/sci-mathematics/cdfplayer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>piatlicki@gmail.com</email>
+</maintainer>
+<longdescription>
+ Player for Wolfram CDF files. It can play Mathematica
+ notebooks.
+</longdescription>
+</pkgmetadata>