aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-22 21:41:13 +0200
committerJustin Lecher <jlec@gentoo.org>2012-05-22 21:41:13 +0200
commit5b8029e7b1d685832b07ef5532b46a16fa5caec5 (patch)
tree51b8356fd2f661b5ef528dc52f2d480a0661ff9f /sci-mathematics/dolfin/dolfin-0.9.9.ebuild
parentsci-physics/abinit: Add missing eutils.eclass (diff)
downloadsci-5b8029e7b1d685832b07ef5532b46a16fa5caec5.tar.gz
sci-5b8029e7b1d685832b07ef5532b46a16fa5caec5.tar.bz2
sci-5b8029e7b1d685832b07ef5532b46a16fa5caec5.zip
sci-mathematics/dolfin: Add missing eutils.eclass, bump to EAPI=4
(Portage version: 2.2.0_alpha107/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/dolfin/dolfin-0.9.9.ebuild')
-rw-r--r--sci-mathematics/dolfin/dolfin-0.9.9.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/sci-mathematics/dolfin/dolfin-0.9.9.ebuild b/sci-mathematics/dolfin/dolfin-0.9.9.ebuild
index 465a72332..249fcbc13 100644
--- a/sci-mathematics/dolfin/dolfin-0.9.9.ebuild
+++ b/sci-mathematics/dolfin/dolfin-0.9.9.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=4
PYTHON_DEPEND="python? 2"
-inherit cmake-utils python
+inherit cmake-utils eutils python
DESCRIPTION="C++/Python interface of FEniCS"
-HOMEPAGE="https://launchpad.net/dolfin"
+HOMEPAGE="https://launchpad.net/dolfin/"
SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -19,15 +19,16 @@ IUSE="cgal cholmod gmp mpi parmetis python scotch umfpack zlib"
# scotch and parmetis require mpi; wait for EAPI 4
DEPEND="
+ dev-libs/boost
dev-libs/libxml2:2
- sci-mathematics/ufc
sci-libs/armadillo
- dev-libs/boost
- python? ( dev-python/ufl
- dev-python/ffc
- dev-python/fiat
- dev-python/instant
- dev-python/viper )"
+ sci-mathematics/ufc
+ python? (
+ dev-python/ufl
+ dev-python/ffc
+ dev-python/fiat
+ dev-python/instant
+ dev-python/viper )"
RDEPEND="${DEPEND}"
pkg_setup() {