aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan-Christofer Demay <jcdemay@gmail.com>2014-06-22 16:29:25 +0200
committerJonathan-Christofer Demay <jcdemay@gmail.com>2014-06-22 16:29:25 +0200
commit03917aeca50f3a5bfb3382205e973e7777a67570 (patch)
tree9b012497b885586aaa60975bf8e486663f1adcc6 /sci-mathematics/flocq/flocq-2.3.0.ebuild
parentadded missing deps (bug #514084) (diff)
downloadsci-03917aeca50f3a5bfb3382205e973e7777a67570.tar.gz
sci-03917aeca50f3a5bfb3382205e973e7777a67570.tar.bz2
sci-03917aeca50f3a5bfb3382205e973e7777a67570.zip
multiple version bumps
Diffstat (limited to 'sci-mathematics/flocq/flocq-2.3.0.ebuild')
-rw-r--r--sci-mathematics/flocq/flocq-2.3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/flocq/flocq-2.3.0.ebuild b/sci-mathematics/flocq/flocq-2.3.0.ebuild
new file mode 100644
index 000000000..6c32445dc
--- /dev/null
+++ b/sci-mathematics/flocq/flocq-2.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+DESCRIPTION="A floating-point formalization for the Coq system"
+HOMEPAGE="http://flocq.gforge.inria.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/33502/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sci-mathematics/coq"
+
+src_prepare() {
+ sed -i Remakefile.in \
+ -e "s:mkdir -p @libdir@:mkdir -p \$(DESTDIR)@libdir@:g" \
+ -e "s:cp \$f @libdir@:cp \$f \$(DESTDIR)@libdir@:g"
+}
+
+src_configure() {
+ econf --libdir="`coqc -where`/user-contrib/Flocq"
+}
+
+src_compile() {
+ ./remake || die "emake failed"
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die "emake install failed"
+ dodoc NEWS README AUTHORS ChangeLog
+}
+