aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordavide <davide@kerr.(none)>2009-05-24 21:06:11 +0200
committerdavide <davide@kerr.(none)>2009-05-24 21:06:11 +0200
commit5d57f95b5315612e0257e70d68944981d655c9b0 (patch)
tree931e57948ea73ebf68df022910966e679596ff57 /sci-mathematics/freefem++/files
parentin tree (diff)
downloadsci-5d57f95b5315612e0257e70d68944981d655c9b0.tar.gz
sci-5d57f95b5315612e0257e70d68944981d655c9b0.tar.bz2
sci-5d57f95b5315612e0257e70d68944981d655c9b0.zip
sci-mathematics/freefem++: New ebuild for freefem++-3
Diffstat (limited to 'sci-mathematics/freefem++/files')
-rw-r--r--sci-mathematics/freefem++/files/freefem++-lamboot.patch12
-rw-r--r--sci-mathematics/freefem++/files/freefem++-make-clean.patch12
-rw-r--r--sci-mathematics/freefem++/files/freefem++-opengl-automagic.patch24
3 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/freefem++/files/freefem++-lamboot.patch b/sci-mathematics/freefem++/files/freefem++-lamboot.patch
new file mode 100644
index 000000000..0de0e0e6b
--- /dev/null
+++ b/sci-mathematics/freefem++/files/freefem++-lamboot.patch
@@ -0,0 +1,12 @@
+diff -urN freefem++-3.2.old/regtests.sh freefem++-3.2.new/regtests.sh
+--- freefem++-3.2.old/regtests.sh 2008-11-25 17:21:06.000000000 +0100
++++ freefem++-3.2.new/regtests.sh 2009-05-24 16:51:49.000000000 +0200
+@@ -76,7 +76,7 @@
+ if [ $mpich -ne 0 ] ; then
+ dotest "mpirun -np $nprocs -machinefile machinefile ${PROGLOC}/mpi/FreeFem++-mpi${EXEEXT}" mpi $script
+ else
+- lamboot
++ [[ -f "$(which lamboot 2>/dev/null)" ]] && lamboot
+ dotest "mpirun -np $nprocs ${PROGLOC}/mpi/FreeFem++-mpi${EXEEXT}" mpi $script
+ fi
+ fi
diff --git a/sci-mathematics/freefem++/files/freefem++-make-clean.patch b/sci-mathematics/freefem++/files/freefem++-make-clean.patch
new file mode 100644
index 000000000..4f3478637
--- /dev/null
+++ b/sci-mathematics/freefem++/files/freefem++-make-clean.patch
@@ -0,0 +1,12 @@
+diff -urN freefem++-3.2.old/download/fftw/Makefile freefem++-3.2.new/download/fftw/Makefile
+--- freefem++-3.2.old/download/fftw/Makefile 2009-04-30 09:52:57.000000000 +0200
++++ freefem++-3.2.new/download/fftw/Makefile 2009-05-24 16:43:03.000000000 +0200
+@@ -40,6 +40,8 @@
+ $(PKGDIR)/$(PACKAGE):
+ cd $(PKGDIR); $(WGET) $(SERVER)/$(PACKAGE)
+
++clean: clean-local
++
+ clean-local:
+ -rm -rf fftw-* FAIT
+
diff --git a/sci-mathematics/freefem++/files/freefem++-opengl-automagic.patch b/sci-mathematics/freefem++/files/freefem++-opengl-automagic.patch
new file mode 100644
index 000000000..79834d89f
--- /dev/null
+++ b/sci-mathematics/freefem++/files/freefem++-opengl-automagic.patch
@@ -0,0 +1,24 @@
+diff -urN freefem++-3.2.old/configure.ac freefem++-3.2.new/configure.ac
+--- freefem++-3.2.old/configure.ac 2009-05-13 16:11:44.000000000 +0200
++++ freefem++-3.2.new/configure.ac 2009-05-24 17:36:34.000000000 +0200
+@@ -403,7 +403,12 @@
+ ff_glx_ok=no
+ ff_agl_ok=no
+ ff_libs="$LIBS"
++AC_ARG_WITH(flib,[ --with-flib= the fortran library ])
++AC_ARG_ENABLE([opengl],AS_HELP_STRING([--enable-opengl],
++ [Enable/disable support for OpenGL]))
++
+ # echo " .... LIBS = $LIBS .... "
++if test x$enable_opengl != xno; then
+ # GL libraries seem to depend on some dlopen capabilities
+ if test "$enable_static" != yes -a "$ff_glut_ok" != yes
+ then
+@@ -476,6 +481,7 @@
+
+
+ fi
++fi
+
+ if test "$ff_glut_ok" = yes
+ then