aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Radice <david.e.pi.3.14@gmail.com>2009-07-24 22:22:47 +0200
committerDavid Radice <david.e.pi.3.14@gmail.com>2009-07-24 22:22:47 +0200
commitc3ac405c24ef8debf97a71c8434bfccd45c7f345 (patch)
tree1120aa81357e6afb7c2a16678d1d6ceeac789dde /sci-mathematics/freefem++/files
parentatpy initial import (diff)
downloadsci-c3ac405c24ef8debf97a71c8434bfccd45c7f345.tar.gz
sci-c3ac405c24ef8debf97a71c8434bfccd45c7f345.tar.bz2
sci-c3ac405c24ef8debf97a71c8434bfccd45c7f345.zip
sci-mathematics/freefem++: fix dependencies for document building, cleanup old files for freefem++-3.2.
Diffstat (limited to 'sci-mathematics/freefem++/files')
-rw-r--r--sci-mathematics/freefem++/files/freefem++-3.4-mortar-DN-4.patch81
-rw-r--r--sci-mathematics/freefem++/files/freefem++-3.4-no-doc-autobuild.patch30
-rw-r--r--sci-mathematics/freefem++/files/freefem++-lamboot.patch12
-rw-r--r--sci-mathematics/freefem++/files/freefem++-make-clean.patch12
-rw-r--r--sci-mathematics/freefem++/files/freefem++-opengl-automagic.patch24
5 files changed, 111 insertions, 48 deletions
diff --git a/sci-mathematics/freefem++/files/freefem++-3.4-mortar-DN-4.patch b/sci-mathematics/freefem++/files/freefem++-3.4-mortar-DN-4.patch
new file mode 100644
index 000000000..59541d4a2
--- /dev/null
+++ b/sci-mathematics/freefem++/files/freefem++-3.4-mortar-DN-4.patch
@@ -0,0 +1,81 @@
+diff -urN freefem++-3.4.old/examples++-mpi/mortar-DN-4-mpi.edp freefem++-3.4.new/examples++-mpi/mortar-DN-4-mpi.edp
+--- freefem++-3.4.old/examples++-mpi/mortar-DN-4-mpi.edp 2009-07-15 17:19:57.000000000 +0200
++++ freefem++-3.4.new/examples++-mpi/mortar-DN-4-mpi.edp 2009-07-24 15:01:27.000000000 +0200
+@@ -1,6 +1,5 @@
+ assert(version>=2.23);
+-
+-if ( mpisize )
++if ( mpisize != 4 )
+ {
+ cout << " sorry number of processeur !=4 " << endl;
+ exit(1);
+@@ -31,9 +30,20 @@
+ if(mpirank==0)
+ {
+
+- mesh Thacopy=square(NN,NN);
+-
+-
++ mesh Thacopy; //hack to dcl Tha ouside of mortar-msh.hdp
++ {
++ include "mortar-msh.hdp"
++ Thacopy=Tha;
++ regsd=regi;
++ }
++ Tha=Thacopy;
++ cout << "mortar : " << endl;
++ Thm=Tha;
++ Thm=adaptmesh(Thm,meshsizem,IsMetric=1,thetamax=60);
++ Thm=emptymesh(Thm); Thmm=Thm;
++ Thmm=trunc(Thm,split=4,1); // for fine integration
++ Thmm=emptymesh(Thmm);
++ plot(Thm,wait=0,ps="mortar-Thm.eps");
+ }
+
+ // send meshes
+diff -urN freefem++-3.4.old/examples++-mpi/mortar-msh.hdp freefem++-3.4.new/examples++-mpi/mortar-msh.hdp
+--- freefem++-3.4.old/examples++-mpi/mortar-msh.hdp 1970-01-01 01:00:00.000000000 +0100
++++ freefem++-3.4.new/examples++-mpi/mortar-msh.hdp 2009-07-24 15:01:40.000000000 +0200
+@@ -0,0 +1,42 @@
++// --- begin meshes building --------------
++real[int] theta(nbsd+1),cost(nbsd),sint(nbsd);
++
++for (int i=0;i<nbsd;i++)
++ {
++ real t=i*2*pi/nbsd;
++ theta[i]= t;
++ theta[i+1]= (i+1)*2*pi/nbsd;
++ cost[i]=cos(t);
++ sint[i]=sin(t);
++ }
++
++
++border g1(t=0,1){x=cost[0]*t;y=sint[0]*t;label=1;};
++border g2(t=0,1){x=cost[1]*t;y=sint[1]*t;label=1;};
++border g3(t=0,1){x=cost[2]*t;y=sint[2]*t;label=1;};
++border g4(t=0,1){x=cost[3]*t;y=sint[3]*t;label=1;};
++
++border e12(t=theta[0],theta[1]){x=cos(t);y=sin(t);label=labext;};
++border e23(t=theta[1],theta[2]){x=cos(t);y=sin(t);label=labext;};
++border e34(t=theta[2],theta[3]){x=cos(t);y=sin(t);label=labext;};
++border e41(t=theta[3],theta[4]){x=cos(t);y=sin(t);label=labext;};
++
++ int Ng = 5;
++ int Ne = 5 ;
++
++plot(g1(Ng)+g2(Ng)+g3(Ng)+g4(Ng) + e12(Ne) + e23(Ne)+ e34(Ne) + e41(Ne) ,wait=1);
++
++mesh Tha = buildmesh( g1(Ng)+g2(Ng)+g3(Ng)+g4(Ng) + e12(Ne) + e23(Ne)+ e34(Ne) + e41(Ne) );
++
++int [int] regi(4);
++for (int i=0;i<4;i++)
++ {
++ real tt = (theta[i]+theta[i+1])*0.5;
++ regi[i]=Tha(0.5*cos(tt),0.5*sin(tt)).region;
++ }
++
++
++Tha=adaptmesh(Tha,meshsize*3,IsMetric=1,thetamax=60,nbvx=100000);
++Tha=adaptmesh(Tha,meshsize*1.5,IsMetric=1,thetamax=60,nbvx=100000);
++Tha=adaptmesh(Tha,meshsize,IsMetric=1,thetamax=60,nbvx=100000);
++
diff --git a/sci-mathematics/freefem++/files/freefem++-3.4-no-doc-autobuild.patch b/sci-mathematics/freefem++/files/freefem++-3.4-no-doc-autobuild.patch
new file mode 100644
index 000000000..add003aea
--- /dev/null
+++ b/sci-mathematics/freefem++/files/freefem++-3.4-no-doc-autobuild.patch
@@ -0,0 +1,30 @@
+diff -urN freefem++-3.4.old/DOC/Makefile.am freefem++-3.4.new/DOC/Makefile.am
+--- freefem++-3.4.old/DOC/Makefile.am 2009-07-15 17:19:57.000000000 +0200
++++ freefem++-3.4.new/DOC/Makefile.am 2009-07-15 17:20:22.000000000 +0200
+@@ -1,4 +1,4 @@
+-dist_pkgdata_DATA=$(DOCPDF)
++all:
+ documentation: $(DOCPDF)
+ docps: $(DOCPS) $(DOCPSGZ)
+ docpdf: $(DOCPDF)
+@@ -117,4 +117,4 @@
+
+
+ # do not delete the copy figure to long to created
+-.PRECIOUS: $(CPFIGS_PDF) $(CPFIGS_EPS)
+\ No newline at end of file
++.PRECIOUS: $(CPFIGS_PDF) $(CPFIGS_EPS)
+diff -urN freefem++-3.4.old/Makefile.am freefem++-3.4.new/Makefile.am
+--- freefem++-3.4.old/Makefile.am 2009-07-15 17:19:57.000000000 +0200
++++ freefem++-3.4.new/Makefile.am 2009-07-15 17:55:42.000000000 +0200
+@@ -147,10 +147,6 @@
+
+ # Native MacOS packaging
+ # ----------------------
+-install-exec-local::
+- $(mkinstalldirs) -m 755 $(DESTDIR)$(pkgdatadir)/$(VERSION)
+- tar cvf - $(FF_EXAMPLES_FILES)| (cd $(DESTDIR)$(pkgdatadir)/$(VERSION); tar xvf -)
+-
+ ListFiles-natives: .FORCE
+ # echo COPYRIGHT HISTORY HISTORY_BEFORE_2005 README BUGS TODO INSTALL INSTALL-MacOSX INNOVATION >$@
+ # echo mode-mi-edp.zip >> $@
diff --git a/sci-mathematics/freefem++/files/freefem++-lamboot.patch b/sci-mathematics/freefem++/files/freefem++-lamboot.patch
deleted file mode 100644
index 0de0e0e6b..000000000
--- a/sci-mathematics/freefem++/files/freefem++-lamboot.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN freefem++-3.2.old/regtests.sh freefem++-3.2.new/regtests.sh
---- freefem++-3.2.old/regtests.sh 2008-11-25 17:21:06.000000000 +0100
-+++ freefem++-3.2.new/regtests.sh 2009-05-24 16:51:49.000000000 +0200
-@@ -76,7 +76,7 @@
- if [ $mpich -ne 0 ] ; then
- dotest "mpirun -np $nprocs -machinefile machinefile ${PROGLOC}/mpi/FreeFem++-mpi${EXEEXT}" mpi $script
- else
-- lamboot
-+ [[ -f "$(which lamboot 2>/dev/null)" ]] && lamboot
- dotest "mpirun -np $nprocs ${PROGLOC}/mpi/FreeFem++-mpi${EXEEXT}" mpi $script
- fi
- fi
diff --git a/sci-mathematics/freefem++/files/freefem++-make-clean.patch b/sci-mathematics/freefem++/files/freefem++-make-clean.patch
deleted file mode 100644
index 4f3478637..000000000
--- a/sci-mathematics/freefem++/files/freefem++-make-clean.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN freefem++-3.2.old/download/fftw/Makefile freefem++-3.2.new/download/fftw/Makefile
---- freefem++-3.2.old/download/fftw/Makefile 2009-04-30 09:52:57.000000000 +0200
-+++ freefem++-3.2.new/download/fftw/Makefile 2009-05-24 16:43:03.000000000 +0200
-@@ -40,6 +40,8 @@
- $(PKGDIR)/$(PACKAGE):
- cd $(PKGDIR); $(WGET) $(SERVER)/$(PACKAGE)
-
-+clean: clean-local
-+
- clean-local:
- -rm -rf fftw-* FAIT
-
diff --git a/sci-mathematics/freefem++/files/freefem++-opengl-automagic.patch b/sci-mathematics/freefem++/files/freefem++-opengl-automagic.patch
deleted file mode 100644
index 79834d89f..000000000
--- a/sci-mathematics/freefem++/files/freefem++-opengl-automagic.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -urN freefem++-3.2.old/configure.ac freefem++-3.2.new/configure.ac
---- freefem++-3.2.old/configure.ac 2009-05-13 16:11:44.000000000 +0200
-+++ freefem++-3.2.new/configure.ac 2009-05-24 17:36:34.000000000 +0200
-@@ -403,7 +403,12 @@
- ff_glx_ok=no
- ff_agl_ok=no
- ff_libs="$LIBS"
-+AC_ARG_WITH(flib,[ --with-flib= the fortran library ])
-+AC_ARG_ENABLE([opengl],AS_HELP_STRING([--enable-opengl],
-+ [Enable/disable support for OpenGL]))
-+
- # echo " .... LIBS = $LIBS .... "
-+if test x$enable_opengl != xno; then
- # GL libraries seem to depend on some dlopen capabilities
- if test "$enable_static" != yes -a "$ff_glut_ok" != yes
- then
-@@ -476,6 +481,7 @@
-
-
- fi
-+fi
-
- if test "$ff_glut_ok" = yes
- then