aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens-Malte Gottfried <jmgottfried@web.de>2010-11-13 16:07:00 +0100
committerJens-Malte Gottfried <jmgottfried@web.de>2010-11-13 16:07:00 +0100
commitf46740aefe1ce189d99d969a6045fd4001c2582e (patch)
treec13867146e8269bd0b41f556d709c046ac1fc4ea /sci-mathematics/hypre
parentsci-chemistry/openbabel-python: Version bump to 2.3.0 (diff)
downloadsci-f46740aefe1ce189d99d969a6045fd4001c2582e.tar.gz
sci-f46740aefe1ce189d99d969a6045fd4001c2582e.tar.bz2
sci-f46740aefe1ce189d99d969a6045fd4001c2582e.zip
added hypre package
Diffstat (limited to 'sci-mathematics/hypre')
-rw-r--r--sci-mathematics/hypre/ChangeLog11
-rw-r--r--sci-mathematics/hypre/Manifest4
-rw-r--r--sci-mathematics/hypre/hypre-2.6.0b.ebuild52
-rw-r--r--sci-mathematics/hypre/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/sci-mathematics/hypre/ChangeLog b/sci-mathematics/hypre/ChangeLog
new file mode 100644
index 000000000..8a36ce266
--- /dev/null
+++ b/sci-mathematics/hypre/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/hypre
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*hypre-2.6.0b (13 Nov 2010)
+
+ 13 Nov 2010; Jens-Malte Gottfried <jmgottfried@web.de>
+ +hypre-2.6.0b.ebuild, +metadata.xml:
+ new ebuild: hypre parallel high performance preconditioner for linear
+ systems
+
diff --git a/sci-mathematics/hypre/Manifest b/sci-mathematics/hypre/Manifest
new file mode 100644
index 000000000..8a32df2b6
--- /dev/null
+++ b/sci-mathematics/hypre/Manifest
@@ -0,0 +1,4 @@
+DIST hypre-2.6.0b.tar.gz 9599317 RMD160 4d683b41eb142b8aaf224ff5742d781a0c8ccea4 SHA1 7ef8ff0e980c3e78a0f55e3944f6d13c44ff7046 SHA256 b36a6c885d4ecf152ff476b23c83ef9f2dcb1a4c7661f80939fd1dae7590409c
+EBUILD hypre-2.6.0b.ebuild 1184 RMD160 0b512f41743d01f80308fb54cbe0774045e41926 SHA1 21440a07a119509663787c7ed48d59b2551bc194 SHA256 6f4c35179688c999cc151fa9b37f209d472ada24683a5fdf57ace18e74887cff
+MISC ChangeLog 330 RMD160 4c9e2c3fdddabe8e9dd5fe78ad4de6c301bedb0f SHA1 28e67759c872f69d6053ec7a5ddca015f94c9117 SHA256 0a9c740541dabcab4f0326cfe1238748c75368809a6a12e51531d6a64b2239cc
+MISC metadata.xml 270 RMD160 095cc24d79cf505fb399f4efe83c1fbd669a4777 SHA1 d694ac481815815d35bc28c0653b02b3c4bbcd08 SHA256 34185c01f89f4dac0de8133ad0d6f6e36f0e2c83f958a6cb03d0ae0f30fda007
diff --git a/sci-mathematics/hypre/hypre-2.6.0b.ebuild b/sci-mathematics/hypre/hypre-2.6.0b.ebuild
new file mode 100644
index 000000000..9fe981bb6
--- /dev/null
+++ b/sci-mathematics/hypre/hypre-2.6.0b.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="Parallel High Performance Preconditioners library for scalable
+solution of linear systems"
+HOMEPAGE="http://www.llnl.gov/casc/hypre/"
+SRC_URI="http://sourceforge.net/projects/charon-suite/files/thirdparty/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="fortran lapack mpi debug python static-libs"
+
+RDEPEND="
+ virtual/mpi
+ sys-devel/gcc[fortran?]
+ lapack? ( virtual/blas virtual/lapack )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+src_configure() {
+ local myconf
+ use static-libs \
+ && myconf[0]="--disable-shared" \
+ || myconf[0]="--enable-shared"
+ myconf[1]="$(use_enable debug)"
+ myconf[2]="$(use_enable fortran)"
+ myconf[3]="$(use_enable python)"
+ myconf[4]="--disable-java"
+ myconf[5]="$(use_with mpi MPI)"
+ myconf[6]="$(use_with lapack blas)"
+ myconf[7]="$(use_with lapack)"
+
+ econf "${myconf[@]}" || die "configure failed"
+}
+
+src_install() {
+ if use static-libs; then
+ dolib.a lib/libHYPRE*.a
+ else
+ dolib.so lib/libHYPRE*.so
+ fi
+ insinto /usr/include/${PN}
+ doins -r hypre/include/*
+}
diff --git a/sci-mathematics/hypre/metadata.xml b/sci-mathematics/hypre/metadata.xml
new file mode 100644
index 000000000..ba0d57077
--- /dev/null
+++ b/sci-mathematics/hypre/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<use>
+ <flag name="mpi">Build support for the message passing interface in virtual/mpi</flag>
+</use>
+</pkgmetadata>