aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2010-09-18 04:02:36 +0200
committerThomas Kahle <tom111@gmx.de>2010-09-18 04:02:36 +0200
commit5a775f47d71c9ef74bd40b83b93b90fc5be1aba0 (patch)
tree83d91c3ea736dd5498512c015160d8d222470273 /sci-mathematics/nauty/nauty-2.4.2.ebuild
parentnew license: 'nauty' for sci-math/nauty (diff)
downloadsci-5a775f47d71c9ef74bd40b83b93b90fc5be1aba0.tar.gz
sci-5a775f47d71c9ef74bd40b83b93b90fc5be1aba0.tar.bz2
sci-5a775f47d71c9ef74bd40b83b93b90fc5be1aba0.zip
New package: sci-mathematics/nauty
Corresponding bug 337810
Diffstat (limited to 'sci-mathematics/nauty/nauty-2.4.2.ebuild')
-rw-r--r--sci-mathematics/nauty/nauty-2.4.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/nauty/nauty-2.4.2.ebuild b/sci-mathematics/nauty/nauty-2.4.2.ebuild
new file mode 100644
index 000000000..9cd4d8268
--- /dev/null
+++ b/sci-mathematics/nauty/nauty-2.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 2 'r')
+MY_PV=$(delete_version_separator 1 ${MY_PV})
+
+DESCRIPTION="nauty is a program for computing automorphism groups of graphs and digraphs."
+HOMEPAGE="http://cs.anu.edu.au/~bdm/nauty/"
+SRC_URI="http://cs.anu.edu.au/~bdm/${PN}/${PN}${MY_PV}.tar.gz"
+
+LICENSE="nauty"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}${MY_PV}"
+
+src_prepare () {
+ # configure does not use LDFLAGS from the environment
+ sed -i "s/LDFLAGS=/LDFLAGS=${LDFLAGS}/" makefile.in \
+ || die "sed on makefile failes"
+}
+
+src_test () {
+ make checks || die "tests failed"
+}
+
+src_install () {
+ dobin addedgeg amtog biplabg catg complg copyg countg \
+ deledgeg directg dreadnaut dretog genbg geng genrang \
+ gentourng labelg listg multig newedgeg NRswitchg pickg \
+ planarg shortg showg || die "install failed"
+ dodoc README formats.txt
+}