aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorje_fro <je_fro@32389bae-6d03-0410-99cf-db05cde120eb>2007-06-10 21:07:55 +0000
committerje_fro <je_fro@32389bae-6d03-0410-99cf-db05cde120eb>2007-06-10 21:07:55 +0000
commit2e143d43cf39eb9daa66cc0f90623c2429acba9d (patch)
treeec98a8c77dde9428b6d9a4eabbecb6077cd08ca3 /sci-mathematics/octave
parentadd bullet (diff)
downloadsci-2e143d43cf39eb9daa66cc0f90623c2429acba9d.tar.gz
sci-2e143d43cf39eb9daa66cc0f90623c2429acba9d.tar.bz2
sci-2e143d43cf39eb9daa66cc0f90623c2429acba9d.zip
Bumping to octave-2.9.12
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@650 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/Manifest8
-rw-r--r--sci-mathematics/octave/files/digest-octave-2.9.123
-rw-r--r--sci-mathematics/octave/octave-2.9.12.ebuild135
3 files changed, 146 insertions, 0 deletions
diff --git a/sci-mathematics/octave/Manifest b/sci-mathematics/octave/Manifest
new file mode 100644
index 000000000..05beb5384
--- /dev/null
+++ b/sci-mathematics/octave/Manifest
@@ -0,0 +1,8 @@
+DIST octave-2.9.12.tar.bz2 7699564 RMD160 dcb34351791fe3c00b93a6f173c59a534502f561 SHA1 3b2435d24e4ae8d34d8ef1c5d82c02a0419c5af9 SHA256 82a7c2b380d67e9c65eb5a5c8d6d39590e9caa72015967e68636ba0a94281fc1
+EBUILD octave-2.9.12.ebuild 4065 RMD160 44a12ddb5b91ab489955baf578c6a5c10f492de6 SHA1 4d278bd2cbdc94737653f2801ac443487169f94c SHA256 2fa30bf4b723fb6d6290f5abccea74a0c5ca5c5684f601eb98e6c9107c5a0a2c
+MD5 e62e3541c3a5202fdb200722ed0c0bd0 octave-2.9.12.ebuild 4065
+RMD160 44a12ddb5b91ab489955baf578c6a5c10f492de6 octave-2.9.12.ebuild 4065
+SHA256 2fa30bf4b723fb6d6290f5abccea74a0c5ca5c5684f601eb98e6c9107c5a0a2c octave-2.9.12.ebuild 4065
+MD5 f9baf04ed82d6e7a5b0b3bbaa5b8b4a9 files/digest-octave-2.9.12 247
+RMD160 f18d9e753f361e909d10d00459a9eec6e51b8914 files/digest-octave-2.9.12 247
+SHA256 9b5bda860bf0f80d04c3dd4fd9f84a3ed89939c1871832757a490f2b1d0ed266 files/digest-octave-2.9.12 247
diff --git a/sci-mathematics/octave/files/digest-octave-2.9.12 b/sci-mathematics/octave/files/digest-octave-2.9.12
new file mode 100644
index 000000000..9466bf6fe
--- /dev/null
+++ b/sci-mathematics/octave/files/digest-octave-2.9.12
@@ -0,0 +1,3 @@
+MD5 cd1cfde5ef28e0faf79ce306cf178276 octave-2.9.12.tar.bz2 7699564
+RMD160 dcb34351791fe3c00b93a6f173c59a534502f561 octave-2.9.12.tar.bz2 7699564
+SHA256 82a7c2b380d67e9c65eb5a5c8d6d39590e9caa72015967e68636ba0a94281fc1 octave-2.9.12.tar.bz2 7699564
diff --git a/sci-mathematics/octave/octave-2.9.12.ebuild b/sci-mathematics/octave/octave-2.9.12.ebuild
new file mode 100644
index 000000000..60867aa12
--- /dev/null
+++ b/sci-mathematics/octave/octave-2.9.12.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic fortran autotools
+
+# This was bumped from octave-2.1.73-r2.ebuild because of some complaining I saw on IRC.
+# I disabled the patches and it seems to compile and run okay.
+# I don't use this program in my work, so it's unlikely I'll find any bugs :)
+# Feel free to ping me if you find any.
+
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2
+ ftp://ftp.math.uni-hamburg.de/pub/soft/math/octave/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="static readline zlib doc hdf5 mpi"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="virtual/libc
+ dev-util/dejagnu
+ >=sys-libs/ncurses-5.2-r3
+ >=sci-visualization/gnuplot-3.7.1-r3
+ >=sci-libs/fftw-2.1.3
+ >=dev-util/gperf-2.7.2
+ virtual/blas
+ virtual/lapack
+ zlib? ( sys-libs/zlib )
+ hdf5? ( sci-libs/hdf5 )
+ doc? ( virtual/tetex )
+ mpi? ( virtual/mpi )
+ !=app-text/texi2html-1.70"
+
+# NOTE: octave supports blas/lapack from intel but this is not open
+# source nor is it free (as in beer OR speech) Check out...
+# http://developer.intel.com/software/products/mkl/mkl52/index.htm for
+# more information
+FORTRAN="gfortran g77 f2c"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+# epatch "${FILESDIR}"/${P}-gcc4.1-gentoo.patch
+# epatch "${FILESDIR}"/${PN}-example-fix.patch
+# epatch "${FILESDIR}"/${P}-f2c-fix.patch
+ eautoconf
+}
+
+
+src_compile() {
+ filter-flags -ffast-math
+
+ local myconf="--localstatedir=/var/state/octave --enable-rpath"
+ myconf="${myconf} --enable-lite-kernel"
+ use static || myconf="${myconf} --disable-static --enable-shared --enable-dl"
+ # Only add -lz to LDFLAGS if we have zlib in USE !
+ # BUG #52604
+ # Danny van Dyk 2004/08/26
+ use zlib && append-ldflags -lz
+
+ # MPI requires the use of gcc/g++ wrappers
+ # mpicc/mpic++
+ # octave links agains -lmpi by default
+ # mpich needs -lmpich instead
+ if use mpi; then
+ CC="mpicc" && CXX="mpiCC"
+ if has_version 'sys-cluster/mpich'; then
+ myconf="${myconf} --with-mpi=mpich"
+ else
+ myconf="${myconf} --with-mpi=mpi"
+ fi
+ else
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ myconf="${myconf} --without-mpi"
+ fi
+
+ # force use of external blas and lapack
+ myconf="${myconf} --with-blas=blas --with-lapack=lapack"
+
+ CC="${CC}" CXX="${CXX}" \
+ econf \
+ $(use_with hdf5) \
+ $(use_enable readline) \
+ ${myconf} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ if use doc; then
+ octave-install-doc || die "Octave doc install failed"
+ fi
+
+ dodir /etc/env.d || die
+ echo "LDPATH=/usr/lib/octave-${PV}" > "${D}"/etc/env.d/99octave || die
+
+ # Fixes ls-R files to remove /var/tmp/portage references.
+ sed -i -e "s:${D}::g" "${D}"/usr/libexec/${PN}/ls-R || die
+ sed -i -e "s:${D}::g" "${D}"/usr/share/${PN}/ls-R || die
+}
+
+pkg_postinst() {
+ echo
+ einfo "Some users have reported failures at running simple tests if"
+ einfo "octave was built with agressive optimisations. You can check if"
+ einfo "your setup is affected by this bug by running the following test"
+ einfo "(inside the octave interpreter):"
+ einfo
+ einfo "octave:1> y = [1 3 4 2 1 5 3 5 6 7 4 5 7 10 11 3];"
+ einfo "octave:2> g = [1 1 1 1 1 1 1 1 2 2 2 2 2 3 3 3];"
+ einfo "octave:3> anova(y, g)"
+ einfo
+ einfo "If these commands complete successfully with no error message,"
+ einfo "your installation should be ok. Otherwise, try recompiling"
+ einfo "octave using less agressive \"CFLAGS\" (combining \"-O3\" and"
+ einfo "\"-march=pentium4\" is known to cause problems)."
+ echo
+}
+
+octave-install-doc() {
+ echo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins doc/faq/Octave-FAQ.dvi || die
+ doins doc/interpreter/octave.dvi || die
+ doins doc/liboctave/liboctave.dvi || die
+ doins doc/refcard/refcard-a4.dvi || die
+ doins doc/refcard/refcard-legal.dvi || die
+ doins doc/refcard/refcard-letter.dvi || die
+}