aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzcj <ustcscgy@163.com>2013-12-29 08:26:58 +0800
committerzcj <ustcscgy@163.com>2013-12-29 09:02:38 +0800
commitd6083b505183e3be523f0ce2f52c72556a8a34df (patch)
treef0618e6104cfeb74120688cc7d64e170eae262e9 /sci-mathematics/open-axiom
parentsci-physics/fullprof-bin: Version Bump (diff)
downloadsci-d6083b505183e3be523f0ce2f52c72556a8a34df.tar.gz
sci-d6083b505183e3be523f0ce2f52c72556a8a34df.tar.bz2
sci-d6083b505183e3be523f0ce2f52c72556a8a34df.zip
sci-mathematics/open-axiom: version bump to 1.4.2
Diffstat (limited to 'sci-mathematics/open-axiom')
-rw-r--r--sci-mathematics/open-axiom/Manifest1
-rw-r--r--sci-mathematics/open-axiom/open-axiom-1.4.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/open-axiom/Manifest b/sci-mathematics/open-axiom/Manifest
index b77753948..15dcde960 100644
--- a/sci-mathematics/open-axiom/Manifest
+++ b/sci-mathematics/open-axiom/Manifest
@@ -1 +1,2 @@
DIST open-axiom-1.3.0.tar.bz2 11821857 SHA256 5c35d0c8b6da17ff2254d833c5f6694d3f5d49064e312e61719cdeb386f888c4
+DIST open-axiom-1.4.2.tar.bz2 9862899 SHA256 745024aadb4fefdd09980e3076141e1a4646ea8588b4d9b0ece486d581b8a119
diff --git a/sci-mathematics/open-axiom/open-axiom-1.4.2.ebuild b/sci-mathematics/open-axiom/open-axiom-1.4.2.ebuild
new file mode 100644
index 000000000..ebcb9946f
--- /dev/null
+++ b/sci-mathematics/open-axiom/open-axiom-1.4.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Symbolic and algebraic computations system"
+HOMEPAGE="http://www.open-axiom.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ app-text/noweb
+ >=dev-lisp/sbcl-1.0.22"
+
+src_configure() {
+ # There is an option to compile with other lisps. However:
+ # - gcl is getting obsolete and unmaintained and is hard masked
+ # - could not make it work with ecls
+ econf \
+ --with-lisp=sbcl \
+ $(use_with X x)
+}
+
+src_compile() {
+ # unfortunately could not track down the broken parallel build
+ # -j5 ok but -j30 sbcl stalled
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog* NEWS README AUTHORS MAINTAINERS TODO STYLES
+}