aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan-Christofer Demay <jcdemay@gmail.com>2014-06-22 16:29:25 +0200
committerJonathan-Christofer Demay <jcdemay@gmail.com>2014-06-22 16:29:25 +0200
commit03917aeca50f3a5bfb3382205e973e7777a67570 (patch)
tree9b012497b885586aaa60975bf8e486663f1adcc6 /sci-mathematics/pff/pff-8.4.ebuild
parentadded missing deps (bug #514084) (diff)
downloadsci-03917aeca50f3a5bfb3382205e973e7777a67570.tar.gz
sci-03917aeca50f3a5bfb3382205e973e7777a67570.tar.bz2
sci-03917aeca50f3a5bfb3382205e973e7777a67570.zip
multiple version bumps
Diffstat (limited to 'sci-mathematics/pff/pff-8.4.ebuild')
-rw-r--r--sci-mathematics/pff/pff-8.4.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/sci-mathematics/pff/pff-8.4.ebuild b/sci-mathematics/pff/pff-8.4.ebuild
index 183dd611d..747366c36 100644
--- a/sci-mathematics/pff/pff-8.4.ebuild
+++ b/sci-mathematics/pff/pff-8.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=5
+EAPI="2"
DESCRIPTION="Library for reasoning about floating point numbers in coq"
HOMEPAGE="http://lipforge.ens-lyon.fr/www/pff/"
@@ -19,12 +19,16 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/Float${PV}"
src_prepare() {
- sed \
- -e "s|\`\$(COQC) -where\`/user-contrib| \
- \$(DESTDIR)/\`\$(COQC) -where\`/user-contrib|g" \
- -i Makefile || die
+ sed -i Makefile \
+ -e "s|\`\$(COQC) -where\`/user-contrib|\$(DSTROOT)/\`\$(COQC) -where\`/user-contrib|g" \
+ -e "s|VOFILESINC=\$(filter \$(wildcard \./\*),\$(VOFILES))|VOFILESINC:=\$(filter-out ,\$(VOFILES))|g"
}
src_compile(){
- emake DESTDIR="/"
+ emake || die "emake failed"
}
+
+src_install(){
+ emake install DSTROOT="${D}" || die "emake install failed"
+}
+