aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2009-12-16 20:58:39 +0100
committerThomas Kahle <tom111@gmx.de>2009-12-16 20:59:05 +0100
commit8c7fea758c53f0a3d3db812e476fbfa33f8cd6ff (patch)
tree363b85754438f31da9582bc34c4981a9d2311606 /sci-mathematics/polymake
parentRepairing some depencies of freecad (diff)
downloadsci-8c7fea758c53f0a3d3db812e476fbfa33f8cd6ff.tar.gz
sci-8c7fea758c53f0a3d3db812e476fbfa33f8cd6ff.tar.bz2
sci-8c7fea758c53f0a3d3db812e476fbfa33f8cd6ff.zip
sci-mathematics/polymake revbump
Diffstat (limited to 'sci-mathematics/polymake')
-rw-r--r--sci-mathematics/polymake/ChangeLog5
-rw-r--r--sci-mathematics/polymake/Manifest4
-rw-r--r--sci-mathematics/polymake/polymake-2.9.7.ebuild76
3 files changed, 84 insertions, 1 deletions
diff --git a/sci-mathematics/polymake/ChangeLog b/sci-mathematics/polymake/ChangeLog
index 058f50041..5962dad35 100644
--- a/sci-mathematics/polymake/ChangeLog
+++ b/sci-mathematics/polymake/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*polymake-2.9.7 (16 Dec 2009)
+
+ 16 Dec 2009; Thomas Kahle <tom@gentoo.org> +polymake-2.9.7.ebuild:
+ sci-mathematics/polymake revbump
+
26 Nov 2009; Thomas Kahle <tom111@gmx.de>
QA fixes
diff --git a/sci-mathematics/polymake/Manifest b/sci-mathematics/polymake/Manifest
index 00380fe45..c685e56e8 100644
--- a/sci-mathematics/polymake/Manifest
+++ b/sci-mathematics/polymake/Manifest
@@ -1,4 +1,6 @@
DIST polymake-2.9.6.tar.bz2 1099047 RMD160 e7955f3d0413be53e994f98b58a3cdea6ccb6a2c SHA1 c8c25a62378000032b3135825fe95cd557d2e621 SHA256 4473edee0aef6c855aa77d29d9d92f320564612fdf219098eb2fb215e15b2632
+DIST polymake-2.9.7.tar.bz2 1063331 RMD160 f8984d1a031e2269d8dd24f514c04614af30e0e2 SHA1 7db9ca5c58264ca4c7028255b106a05325203924 SHA256 53a106ac57b3d5d24a1b3f02d43c516b8e1f7adfc164c1d58fe14d63bb651d58
EBUILD polymake-2.9.6.ebuild 2033 RMD160 3ea5288ae5a9dbb1268ac12589a474c9fe92c693 SHA1 c85c24dff9bf076ed4439e5fc10b6858d3f08cb5 SHA256 9f94a8b64bb25b92349b157afdb563e062fc7740163dd627bfe763eeed351c52
-MISC ChangeLog 371 RMD160 58c5caaba1821bc1cb23de3e0659a587e73653fa SHA1 ae7f4c532c23ece85c22c3400c6e52ed69ab232e SHA256 02611d94e9048f9416451206423de62885f963acff00ceeea9a0b61e19172e43
+EBUILD polymake-2.9.7.ebuild 2117 RMD160 215d9e484d5af0ffcd8522ec665afefc15d66b34 SHA1 f1fe769b7f82f6ac66bb431aefd3597c014cd025 SHA256 6283ca9a51c487a05cd475c3f52eb1bd5297caf2acfb319bbaa8dc21f4f29797
+MISC ChangeLog 507 RMD160 a6ba14c4c1c557442427540e8380038de349ac9f SHA1 adf9b66ad9e4917cbcf1a674b4e28897baa5a3c6 SHA256 93833cd097acb10e1916f311fda9a3d01f2a434a49c854a5ae160549ae8ba2bf
MISC metadata.xml 479 RMD160 d0ee0804cba7126da178753fd5ef006c20bcdc9f SHA1 d659e80c8bc729b22a2e91acafe7cc70ad199748 SHA256 8c36e369a2cc989eccc98ac79166daff6269323d0bb8a29def22817a1beb4e04
diff --git a/sci-mathematics/polymake/polymake-2.9.7.ebuild b/sci-mathematics/polymake/polymake-2.9.7.ebuild
new file mode 100644
index 000000000..5c49a17d1
--- /dev/null
+++ b/sci-mathematics/polymake/polymake-2.9.7.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit flag-o-matic
+
+DESCRIPTION="research tool for polyhedral geometry and combinatorics"
+SRC_URI="http://www.opt.tu-darmstadt.de/polymake/lib/exe/fetch.php/download/${P}.tar.bz2"
+
+HOMEPAGE="http://www.math.tu-berlin.de/polymake"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="dev-libs/gmp
+ dev-libs/libxml2
+ dev-perl/XML-LibXML
+ dev-libs/libxslt
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-Writer
+ dev-perl/Term-ReadLine-Gnu
+ >=virtual/jdk-1.5.0"
+RDEPEND="${DEPEND}"
+
+src_compile(){
+ # Fixing makefile to not use escaped characters
+ sed -i 's/uname -p/uname -i/' support/locate_build_dir
+ # Remove stripping from install.pl
+ sed -i '/system "strip $to"/d' support/install.pl
+
+ # Configure is asking questions
+ # First accept defaults
+ touch defaults || die "Cannot touch file"
+ emake configure < defaults
+ rm defaults
+
+ OFLAG=`get-flag -O`
+
+ # Now inject our answers
+ cd "${S}/build.`uname -i`"
+ sed -i 's,InstallTop=.*$,InstallTop=/usr/share/polymake,' conf.make
+ sed -i 's,InstallArch=.*$,InstallArch=/usr/lib/polymake,' conf.make
+ sed -i 's,InstallBin=.*$,InstallBin=/usr/bin,' conf.make
+ sed -i 's,InstallDoc=.*$,InstallDoc=/usr/share/doc/${PF},' conf.make
+ sed -i "s,CXXOPT=.*$,CXXOPT=${OFLAG}," conf.make
+ cd "${S}"
+ # The makefile respects CXXFLAGS and friends from the environment
+
+ einfo "During compile this package uses up to"
+ einfo "400MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
+ einfo "you run into trouble."
+
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_postinst(){
+ elog "Polymake uses Perl Modules compiled during install."
+ elog "If something does not work after an upgrade of Perl"
+ elog "please re-emerge polymake"
+ elog " "
+ elog "This version of polymake does not ship docs. Sorry."
+ elog " "
+ elog "On first start, polymake will ask you about the locations"
+ elog "of external programs it can use."
+ elog "If the initial run crashes, please report to the developers."
+}
+