aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortimcera <tim@cerazone.net>2011-12-02 18:00:12 -0500
committertimcera <tim@cerazone.net>2011-12-02 18:00:12 -0500
commitc9423f63377f198f3e1f809a1a4d8e33b13ee6f5 (patch)
treede2bbef9ad44333a8c87492cb7eec0f21fa8c23b /sci-mathematics/pulp
parentAnother Version bump (diff)
downloadsci-c9423f63377f198f3e1f809a1a4d8e33b13ee6f5.tar.gz
sci-c9423f63377f198f3e1f809a1a4d8e33b13ee6f5.tar.bz2
sci-c9423f63377f198f3e1f809a1a4d8e33b13ee6f5.zip
sci-mathematics/pulp: Initial ebuild.
Diffstat (limited to 'sci-mathematics/pulp')
-rw-r--r--sci-mathematics/pulp/ChangeLog9
-rw-r--r--sci-mathematics/pulp/Manifest4
-rw-r--r--sci-mathematics/pulp/metadata.xml6
-rw-r--r--sci-mathematics/pulp/pulp-1.4.9.ebuild41
4 files changed, 60 insertions, 0 deletions
diff --git a/sci-mathematics/pulp/ChangeLog b/sci-mathematics/pulp/ChangeLog
new file mode 100644
index 000000000..306cf7d49
--- /dev/null
+++ b/sci-mathematics/pulp/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-mathematics/pulp
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pulp-1.4.9 (02 Dec 2011)
+
+ 02 Dec 2011; Tim Cera <tim@cerazone.net> +pulp-1.4.9.ebuild, +metadata.xml:
+ Initial ebuild.
+
diff --git a/sci-mathematics/pulp/Manifest b/sci-mathematics/pulp/Manifest
new file mode 100644
index 000000000..27f590812
--- /dev/null
+++ b/sci-mathematics/pulp/Manifest
@@ -0,0 +1,4 @@
+DIST PuLP-1.4.9.tar.gz 7075569 RMD160 85de60cb2a5cb0d393fb570165e39cdb09d63709 SHA1 aeb52b2cffefc0aca75003912147e76ceb312490 SHA256 14e385b7c4c4e7b0ea89c111bf4201263a740eaa563c3371525c7b4beacaec77
+EBUILD pulp-1.4.9.ebuild 846 RMD160 b3ebc71878ac33d639ce7d1d61bd393380604db8 SHA1 abb7a73979088e2ecc93c1b67ce82353c95ad090 SHA256 c38a822c6cd70d68eccfe5ea60c2c20adc819fd216752cfe1b52586e49dc2af0
+MISC ChangeLog 245 RMD160 6a52391ee7c966077a867881ca2d1cb044f0f438 SHA1 3e3f566c52a89ccd9aa61025907a72cb75649f94 SHA256 6a163bc22736d6d875577d07d610adb2729a3539be8544bef45d1c2a5391d086
+MISC metadata.xml 198 RMD160 6a84cce6c68e9428224430cce679e9884faedf66 SHA1 46810b7767dedd534650c053f8e512e6bb81e1df SHA256 a6cced7fd655d4e5e10239d91957eb486c00169084460d93433922262241bcab
diff --git a/sci-mathematics/pulp/metadata.xml b/sci-mathematics/pulp/metadata.xml
new file mode 100644
index 000000000..09239037c
--- /dev/null
+++ b/sci-mathematics/pulp/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <longdescription></longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/pulp/pulp-1.4.9.ebuild b/sci-mathematics/pulp/pulp-1.4.9.ebuild
new file mode 100644
index 000000000..1d210973e
--- /dev/null
+++ b/sci-mathematics/pulp/pulp-1.4.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.1
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="PuLP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python linear programming wrapper that creates MPS/LP files,
+calls solvers, and presents results."
+
+HOMEPAGE="http://pulp-or.googlecode.com/"
+SRC_URI="mirror://pypi/packages/source/P/PuLP/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=">=dev-python/pyparsing-1.5.2
+ >=sci-mathematics/glpk-4.35
+ dev-python/setuptools"
+
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/"${PF}"/
+ doins -r examples
+ fi
+}