aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-22 10:28:33 +0100
committerJustin Lecher <jlec@gentoo.org>2013-02-22 10:28:33 +0100
commiteaf3cb37466102348bffec03089d522286db7721 (patch)
tree7a4e1626b14b080248f6e334da61dcca2e64cc7d /sci-mathematics/scilab
parentsci-physics/atompaw: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead... (diff)
downloadsci-eaf3cb37466102348bffec03089d522286db7721.tar.gz
sci-eaf3cb37466102348bffec03089d522286db7721.tar.bz2
sci-eaf3cb37466102348bffec03089d522286db7721.zip
sci-mathematics/scilab: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
Package-Manager: portage-2.2.0_alpha163 RepoMan-Options: --force
Diffstat (limited to 'sci-mathematics/scilab')
-rw-r--r--sci-mathematics/scilab/ChangeLog6
-rw-r--r--sci-mathematics/scilab/metadata.xml16
-rw-r--r--sci-mathematics/scilab/scilab-5.3.3-r1.ebuild26
-rw-r--r--sci-mathematics/scilab/scilab-5.4.0.ebuild19
4 files changed, 37 insertions, 30 deletions
diff --git a/sci-mathematics/scilab/ChangeLog b/sci-mathematics/scilab/ChangeLog
index 840b1427b..6d0b6122b 100644
--- a/sci-mathematics/scilab/ChangeLog
+++ b/sci-mathematics/scilab/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-mathematics/scilab
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 22 Feb 2013; Justin Lecher <jlec@gentoo.org> scilab-5.3.3-r1.ebuild,
+ scilab-5.4.0.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
+
18 Oct 2012; Guillaume Horel <guillaume.horel@gmail.com>
scilab-5.3.3-r1.ebuild, scilab-5.4.0.ebuild:
remove virtual/fortran as intended with the updated fortran-2 eclass
diff --git a/sci-mathematics/scilab/metadata.xml b/sci-mathematics/scilab/metadata.xml
index e87dba073..9e4966904 100644
--- a/sci-mathematics/scilab/metadata.xml
+++ b/sci-mathematics/scilab/metadata.xml
@@ -1,20 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
Scilab is a matrix-based scientific software package. Scilab contains
hundreds of built-in mathematical functions, rich data structures
(including polynomials, rationals,linear systems, lists, etc...) and
comes with a number of specific toolboxes for control, signal
processing, ...
</longdescription>
-<use>
- <flag name='gui'>Build the Java base graphical interface</flag>
- <flag name="umfpack">Adds support for sparse solving
+ <use>
+ <flag name="gui">Build the Java base graphical interface</flag>
+ <flag name="umfpack">Adds support for sparse solving
with <pkg>sci-libs/umfpack</pkg></flag>
- <flag name='matio'>Enable support for MATLAB file through <pkg>sci-libs/matio</pkg></flag>
- <flag name='xcos'>Enable building hybrid dynamic systems modeler and
+ <flag name="matio">Enable support for MATLAB file through <pkg>sci-libs/matio</pkg></flag>
+ <flag name="xcos">Enable building hybrid dynamic systems modeler and
simulator Xcos</flag>
-</use>
+ </use>
</pkgmetadata>
diff --git a/sci-mathematics/scilab/scilab-5.3.3-r1.ebuild b/sci-mathematics/scilab/scilab-5.3.3-r1.ebuild
index a9883eaf8..19fe80b4b 100644
--- a/sci-mathematics/scilab/scilab-5.3.3-r1.ebuild
+++ b/sci-mathematics/scilab/scilab-5.3.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -20,11 +20,12 @@ inherit eutils autotools check-reqs fdo-mime bash-completion-r1 \
# celestlab, jims,...
DESCRIPTION="Scientific software package for numerical computations"
-LICENSE="CeCILL-2"
HOMEPAGE="http://www.scilab.org/"
SRC_URI="http://www.scilab.org/download/${PV}/${P}-src.tar.gz"
SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86"
IUSE="bash-completion debug doc fftw +gui hdf5 +matio nls openmp
static-libs test tk +umfpack xcos"
REQUIRED_USE="xcos? ( hdf5 gui ) doc? ( gui )"
@@ -39,9 +40,8 @@ for l in ${LINGUASLONG}; do
IUSE="${IUSE} linguas_${l%_*}"
done
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="dev-libs/libpcre
+CDEPEND="
+ dev-libs/libpcre
dev-libs/libxml2:2
sys-devel/gettext
sys-libs/ncurses
@@ -66,8 +66,9 @@ CDEPEND="dev-libs/libpcre
dev-java/xmlgraphics-commons
virtual/opengl
doc? ( dev-java/saxon:6.5 )
- hdf5? ( dev-java/hdf-java
- xcos? ( =dev-java/jgraphx-1.4.1.0 ) ) )
+ hdf5? (
+ dev-java/hdf-java
+ xcos? ( =dev-java/jgraphx-1.4.1.0 ) ) )
hdf5? ( sci-libs/hdf5 )
matio? ( <sci-libs/matio-1.5 )
tk? ( dev-lang/tk )
@@ -81,9 +82,10 @@ DEPEND="${CDEPEND}
debug? ( dev-util/lcov )
gui? (
>=virtual/jdk-1.5
- doc? ( app-text/docbook-xsl-stylesheets
- >=dev-java/jlatexmath-fop-0.9.4
- dev-java/xml-commons-external )
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ >=dev-java/jlatexmath-fop-0.9.4
+ dev-java/xml-commons-external )
xcos? ( dev-lang/ocaml ) )
test? ( gui? ( ${VIRTUALX_DEPEND} ) )"
@@ -182,8 +184,8 @@ src_configure() {
unset JAVAC
fi
- export BLAS_LIBS="$(pkg-config --libs blas)"
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
+ export BLAS_LIBS="$($(tc-getPKG_CONFIG) --libs blas)"
+ export LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
export F77_LDFLAGS="${LDFLAGS}"
# gentoo bug #302621
use hdf5 && has_version sci-libs/hdf5[mpi] && \
diff --git a/sci-mathematics/scilab/scilab-5.4.0.ebuild b/sci-mathematics/scilab/scilab-5.4.0.ebuild
index f5616379e..bffe76e7c 100644
--- a/sci-mathematics/scilab/scilab-5.4.0.ebuild
+++ b/sci-mathematics/scilab/scilab-5.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -12,14 +12,15 @@ inherit eutils autotools bash-completion-r1 check-reqs fdo-mime flag-o-matic \
# Things that don't work:
# - tests
-# - can't build without docs (-doc)
+# - can't build without docs (-doc)
DESCRIPTION="Scientific software package for numerical computations"
-LICENSE="CeCILL-2"
HOMEPAGE="http://www.scilab.org/"
SRC_URI="http://www.scilab.org/download/${PV}/${P}-src.tar.gz"
SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86"
IUSE="bash-completion debug +doc fftw +gui +matio nls openmp
static-libs test tk +umfpack xcos"
REQUIRED_USE="xcos? ( gui ) doc? ( gui )"
@@ -34,9 +35,8 @@ for l in ${LINGUASLONG}; do
IUSE="${IUSE} linguas_${l%_*}"
done
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="dev-libs/libpcre
+CDEPEND="
+ dev-libs/libpcre
dev-libs/libxml2:2
sci-libs/hdf5
>=sci-libs/arpack-3
@@ -77,9 +77,10 @@ DEPEND="${CDEPEND}
debug? ( dev-util/lcov )
gui? (
>=virtual/jdk-1.5
- doc? ( app-text/docbook-xsl-stylesheets
- dev-java/jlatexmath-fop:1
- dev-java/xml-commons-external:1.4 )
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-java/jlatexmath-fop:1
+ dev-java/xml-commons-external:1.4 )
xcos? ( dev-lang/ocaml ) )
test? (
dev-java/junit:4