aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan-Christofer Demay <jcdemay@gmail.com>2009-09-22 23:14:23 +0000
committerJonathan-Christofer Demay <jcdemay@gmail.com>2009-09-22 23:14:23 +0000
commitebf58363a9d3f881600fe9fdaf671161aac34951 (patch)
tree8438b7f1e61f1b8ca0852e2de9e5f65227aeabd8 /sci-mathematics/why/why-2.19.ebuild
parentremoved h5py now in main tree (diff)
downloadsci-ebf58363a9d3f881600fe9fdaf671161aac34951.tar.gz
sci-ebf58363a9d3f881600fe9fdaf671161aac34951.tar.bz2
sci-ebf58363a9d3f881600fe9fdaf671161aac34951.zip
Various updates related to Frama-C.
Diffstat (limited to 'sci-mathematics/why/why-2.19.ebuild')
-rw-r--r--sci-mathematics/why/why-2.19.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-mathematics/why/why-2.19.ebuild b/sci-mathematics/why/why-2.19.ebuild
index 353650be8..60c0c6ffa 100644
--- a/sci-mathematics/why/why-2.19.ebuild
+++ b/sci-mathematics/why/why-2.19.ebuild
@@ -29,17 +29,23 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch "${FILESDIR}/${P}-sandbox.patch"
+ epatch "${FILESDIR}/${P}-makefile_sandbox.patch"
mv jc/jc_ast.mli jc/jc_ast.ml
mv jc/jc_env.mli jc/jc_env.ml
epatch "${FILESDIR}/${P}-jessie_lib.patch"
+ #to build with apron-0.9.10
+ sed -i configure.in \
+ -e "s/oct_caml/octMPQ_caml/g" \
+ -e "s/box_caml/boxMPQ_caml/g" \
+ -e "s/polka_caml/polkaMPQ_caml/g"
+
eautoreconf
}
src_compile(){
- econf $(use_enable apron) || die "econf failed"
+ econf $(use_enable apron) PATH="/usr/bin:$PATH" || die "econf failed"
emake DESTDIR="/" || die "emake failed"
}