aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-20 21:16:00 +0100
committerJakov Smolic <jakov.smolic@sartura.hr>2021-02-20 22:57:42 +0100
commit0713dd406eeb0fab717f46f357d3c2524e5fccc2 (patch)
tree03ef7233ccb7280612280e27bf59c3e6c801a2e9 /sci-mathematics
parentsci-biology/tagdust: Port to EAPI 7 (diff)
downloadsci-0713dd406eeb0fab717f46f357d3c2524e5fccc2.tar.gz
sci-0713dd406eeb0fab717f46f357d3c2524e5fccc2.tar.bz2
sci-0713dd406eeb0fab717f46f357d3c2524e5fccc2.zip
sci-mathematics/ltl2ba: Port to EAPI 7
Closes: https://bugs.gentoo.org/755374 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild b/sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild
index 29609c146..6172bb985 100644
--- a/sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild
+++ b/sci-mathematics/ltl2ba/ltl2ba-1.1.ebuild
@@ -1,29 +1,31 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
+inherit flag-o-matic
DESCRIPTION="Fast LTL to Buechi Automata Translation"
-HOMEPAGE="http://www.lsv.ens-cachan.fr/~gastin/${PN}/"
+HOMEPAGE="http://www.lsv.ens-cachan.fr/~gastin/ltl2ba"
SRC_URI="http://www.lsv.ens-cachan.fr/~gastin/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-src_compile() {
+src_prepare() {
+ default
sed -i Makefile \
-e "s/CC=gcc/#CC=gcc/g" \
- -e "s/CFLAGS= -O3 -ansi -DNXT/CFLAGS+= -ansi -DNXT/g"
+ -e "s/CFLAGS= -O3 -ansi -DNXT/CFLAGS+= -ansi -DNXT/g" || die
+}
+src_configure() {
+ append-cflags -fcommon
default
}
src_install() {
- dobin ltl2ba || die "dobin failed"
+ dobin ltl2ba
dodoc README
}