aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Schmidt <das1993@hotmail.com>2014-08-09 09:36:33 +0200
committerDominik Schmidt <das1993@hotmail.com>2014-08-09 18:28:08 +0200
commit0ad0380dbf0cb537b121adbe6e6fcf8ba0a2e080 (patch)
tree4a50cd2b924074f0dc9468934d98bdc691bf66e1 /sci-mathematics
parent2.0.4 is already in main tree (diff)
downloadsci-0ad0380dbf0cb537b121adbe6e6fcf8ba0a2e080.tar.gz
sci-0ad0380dbf0cb537b121adbe6e6fcf8ba0a2e080.tar.bz2
sci-0ad0380dbf0cb537b121adbe6e6fcf8ba0a2e080.zip
sci-mathematics/giac: Ebuild fix
FLTK paths added to CPPFLAGS and LDFLAGS. The code invokes fltk-config, which breaks crosscompileability.
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/giac/ChangeLog3
-rw-r--r--sci-mathematics/giac/Manifest3
-rw-r--r--sci-mathematics/giac/giac-1.1.0.ebuild16
3 files changed, 19 insertions, 3 deletions
diff --git a/sci-mathematics/giac/ChangeLog b/sci-mathematics/giac/ChangeLog
index 56351675c..40d2c71bf 100644
--- a/sci-mathematics/giac/ChangeLog
+++ b/sci-mathematics/giac/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 09 Aug 2014; Dominik Schmidt <das1993@hotmail.com>
+ Fixed fltk handling
+
21 Jun 2014; Jonathan-Christofer Demay <jcdemay@gmail.com>
-giac-1.0.0.ebuild, +giac-1.1.0.ebuild:
version bump
diff --git a/sci-mathematics/giac/Manifest b/sci-mathematics/giac/Manifest
index 13b25d98d..e523daca1 100644
--- a/sci-mathematics/giac/Manifest
+++ b/sci-mathematics/giac/Manifest
@@ -1,4 +1 @@
DIST giac-1.1.0.tar.bz2 43295079 SHA256 8d4f96a577d526caa201d8311f462828b92eead2938b00e563b208b4e255a340 SHA512 2b34c7913a6a24aa770094bc839c01f7f3d16689ed9673d56b72ce39d07004e20218e039c85fb15e9f39f5f9e6993e6cfff62e755997f1107cddf7e601658434 WHIRLPOOL ca761a1f2bd6ad88655a079a29f54344d101542ba7a0c09fe7d8e0077e36ab06235341210a7b2a0ef98d09d416756be2725b9cc7be676957eaa199a67d67e375
-EBUILD giac-1.1.0.ebuild 1584 SHA256 647f4888e098bf2b4028051ced9c90cc0369956e6d87c003ab1c197a052476fe SHA512 524d63c72bc0e5d03467e6348eb58c220fcb2bd8afffdee765d5c53e29aafa5a158bdaf637258a20f01e678d34810fdfb581eedd2a0a9fc1583d16dc4e78ed3f WHIRLPOOL f6ce13bf63bb36c911633150db22d6b7fa8ddb4b93735b3c13e1875f4ec9272f390f2d8c53c7de79a8c445846ef347d1f71089f1c142cb657fcfb2bf8d3dbaec
-MISC ChangeLog 575 SHA256 4d53d5e54802add14b5b345e50f4051f5e933065ebe5a73848eab8e797b3c50a SHA512 bc959aaac0f3bbf2da3bfff78f26fc296e6516e75f09e9609a930ee6579331ed3adb2481c5a988b3df79d7227db48ed9e44b81735305773db310d2b6fba3d272 WHIRLPOOL bff8f1ac917c96548719d05e9a0bc8336aeda0d4a28e5346f92a6d4fb8e7a5d96ad2b6ee1e0d5ccd1fcacbc31b1a6e03305499529561ce08920bc3763828b374
-MISC metadata.xml 560 SHA256 4ba9774ad18672ee878b17322024b055be1dda24a28b14ad16d8716fc7922bd5 SHA512 eaa7f5fe1c0c37fe75bda2fb15783d919ea1be438c4225c83b5bf39d7ce3b52d16cecf478eff459c8958da28c7b45fc33389bf1b529ac2d425c764ca09e200b5 WHIRLPOOL b3e8b82a948e6f1429e9e746861d8208d692de03bda97d6218f3e84836c672757dd1e1805bf58987632fbdcb01df10958705d56d7c3b4bf5c3cc4ad643f138e2
diff --git a/sci-mathematics/giac/giac-1.1.0.ebuild b/sci-mathematics/giac/giac-1.1.0.ebuild
index 4b2232ca9..4993db4f7 100644
--- a/sci-mathematics/giac/giac-1.1.0.ebuild
+++ b/sci-mathematics/giac/giac-1.1.0.ebuild
@@ -13,6 +13,9 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="doc examples fltk"
+AUTOTOOLS_IN_SOURCE_BUILD=true
+inherit autotools-utils flag-o-matic
+
RDEPEND=">=dev-libs/gmp-3
>=sys-libs/readline-4.2
fltk? ( >=x11-libs/fltk-1.1.9 )
@@ -32,6 +35,19 @@ src_prepare(){
fi
}
+src_configure(){
+ if use fltk
+ then
+ append-cppflags -I$(fltk-config --includedir)
+ append-lfs-flags
+ append-libs $(fltk-config --ldflags | sed -e 's/\(-L\S*\)\s.*/\1/')
+ fi
+ local myeconfargs=(
+ user_enable fltk gui
+ )
+ autotools-utils_src_configure || die "configuring failed"
+}
+
src_install() {
emake install DESTDIR="${D}" || die "emake install failed"
mv ${D}/usr/bin/{aide,giac-help}