aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-04 17:13:12 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-04 17:13:12 +0100
commit2b2b0911e462b932d97529ca3b0203d6e6a3b47e (patch)
tree3fbd35ce10b95dfa6aa6ac1d55cc7e665b794f29 /sci-mathematics
parentsci-electronics/player: Fix deps (diff)
downloadsci-2b2b0911e462b932d97529ca3b0203d6e6a3b47e.tar.gz
sci-2b2b0911e462b932d97529ca3b0203d6e6a3b47e.tar.bz2
sci-2b2b0911e462b932d97529ca3b0203d6e6a3b47e.zip
sci-mathematics/dolfin: Bump EAPI to 5; Bump to python-single-r1 eclass
Package-Manager: portage-2.2.7
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/dolfin/ChangeLog6
-rw-r--r--sci-mathematics/dolfin/dolfin-0.9.9.ebuild24
-rw-r--r--sci-mathematics/dolfin/metadata.xml18
3 files changed, 28 insertions, 20 deletions
diff --git a/sci-mathematics/dolfin/ChangeLog b/sci-mathematics/dolfin/ChangeLog
index b1909e572..980a24abe 100644
--- a/sci-mathematics/dolfin/ChangeLog
+++ b/sci-mathematics/dolfin/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-mathematics/dolfin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 04 Dec 2013; Justin Lecher <jlec@gentoo.org> dolfin-0.9.9.ebuild,
+ metadata.xml:
+ Bump EAPI to 5; Bump to python-single-r1 eclass
+
22 May 2012; Justin Lecher <jlec@gentoo.org> dolfin-0.9.9.ebuild,
metadata.xml:
Add missing eutils.eclass, bump to EAPI=4
diff --git a/sci-mathematics/dolfin/dolfin-0.9.9.ebuild b/sci-mathematics/dolfin/dolfin-0.9.9.ebuild
index 249fcbc13..0fef0f9d9 100644
--- a/sci-mathematics/dolfin/dolfin-0.9.9.ebuild
+++ b/sci-mathematics/dolfin/dolfin-0.9.9.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="python? 2"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit cmake-utils eutils python
+inherit cmake-utils eutils python-single-r1
DESCRIPTION="C++/Python interface of FEniCS"
HOMEPAGE="https://launchpad.net/dolfin/"
@@ -18,21 +18,25 @@ KEYWORDS="~amd64"
IUSE="cgal cholmod gmp mpi parmetis python scotch umfpack zlib"
# scotch and parmetis require mpi; wait for EAPI 4
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
DEPEND="
dev-libs/boost
dev-libs/libxml2:2
sci-libs/armadillo
sci-mathematics/ufc
python? (
- dev-python/ufl
- dev-python/ffc
- dev-python/fiat
- dev-python/instant
- dev-python/viper )"
+ ${PYTHON_DEPS}
+ dev-python/ufl[${PYTHON_USEDEP}]
+ dev-python/ffc[${PYTHON_USEDEP}]
+ dev-python/fiat[${PYTHON_USEDEP}]
+ dev-python/instant[${PYTHON_USEDEP}]
+ dev-python/viper[${PYTHON_USEDEP}]
+ )"
RDEPEND="${DEPEND}"
pkg_setup() {
- use python && python_set_active_version 2
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
diff --git a/sci-mathematics/dolfin/metadata.xml b/sci-mathematics/dolfin/metadata.xml
index 964c3eea5..9c1b5e566 100644
--- a/sci-mathematics/dolfin/metadata.xml
+++ b/sci-mathematics/dolfin/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-mathematics</herd>
- <longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
DOLFIN is the C++/Python interface of FEniCS, providing a consistent PSE (Problem Solving Environment) for ordinary and partial differential equations.
</longdescription>
- <use>
- <flag name="cgal">Adds support for geometric algorithms with <pkg>sci-mathematics/cgal</pkg></flag>
- <flag name="cholmod">Adds support for sparse Cholesky factorization with <pkg>sci-libs/cholmod</pkg></flag>
- <flag name="parmetis">Adds support for parallel graph partitioning with <pkg>sci-libs/parmetis</pkg></flag>
- <flag name="scotch">Adds support for graph partitioning with <pkg>sci-libs/scotch</pkg></flag>
- <flag name="umfpack">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
- </use>
+ <use>
+ <flag name="cgal">Adds support for geometric algorithms with <pkg>sci-mathematics/cgal</pkg></flag>
+ <flag name="cholmod">Adds support for sparse Cholesky factorization with <pkg>sci-libs/cholmod</pkg></flag>
+ <flag name="parmetis">Adds support for parallel graph partitioning with <pkg>sci-libs/parmetis</pkg></flag>
+ <flag name="scotch">Adds support for graph partitioning with <pkg>sci-libs/scotch</pkg></flag>
+ <flag name="umfpack">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
+ </use>
</pkgmetadata>