aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2009-11-16 18:33:57 +0100
committerThomas Kahle <tom111@gmx.de>2009-11-16 18:34:28 +0100
commit46a51bada01b7b75c18d2cfcbfbd8364d16d27cf (patch)
treeb6213faffc544c1751952342b575e5980dff7b10 /sci-mathematics
parentNew Package: dev-libs/mpir (diff)
downloadsci-46a51bada01b7b75c18d2cfcbfbd8364d16d27cf.tar.gz
sci-46a51bada01b7b75c18d2cfcbfbd8364d16d27cf.tar.bz2
sci-46a51bada01b7b75c18d2cfcbfbd8364d16d27cf.zip
sci-mathematics/Macaulay2-1.3.1 revbump
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog4
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-1.3.1.ebuild127
-rw-r--r--sci-mathematics/Macaulay2/Manifest5
-rw-r--r--sci-mathematics/Macaulay2/files/paths-of-dependencies.patch48
4 files changed, 183 insertions, 1 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index 6bd9fc790..09d3e3a10 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Nov 2009; Thomas Kahle <tom111@gmx.de> +Macaulay2-1.3.1.ebuild
+
+ Version bump
+
26 Aug 2009; Thomas Kahle <tom111@gmx.de>
Changed -r3 ebuild since #282174 was fixed and workarounds are not
diff --git a/sci-mathematics/Macaulay2/Macaulay2-1.3.1.ebuild b/sci-mathematics/Macaulay2/Macaulay2-1.3.1.ebuild
new file mode 100644
index 000000000..3eb94698d
--- /dev/null
+++ b/sci-mathematics/Macaulay2/Macaulay2-1.3.1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools elisp-common eutils flag-o-matic subversion
+
+# For the time being Upstream does not provide source tarballs,
+# but realease branches in their svn
+
+# Todolist:
+# Ebuild for gfan
+# factory, libfac
+# .m2 files patchen
+
+ESVN_REPO_URI="svn://macaulay2.math.uiuc.edu/Macaulay2/release-branches/1.3.1"
+
+IUSE="emacs"
+
+PACKURL="http://www.math.uiuc.edu/Macaulay2/Downloads/OtherSourceCode/1.3/"
+DESCRIPTION="research tool for commutative algebra and algebraic geometry"
+SRC_URI="ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Factory/factory-3-1-0.tar.gz \
+ ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Libfac/libfac-3-1-0.tar.gz \
+ ${PACKURL}/frobby_v0.8.2.tar.gz"
+# mirror://gentoo/${P}-src.tar.bz2
+
+HOMEPAGE="http://www.math.uiuc.edu/Macaulay2/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+# mpir 1.3.0_rc3 does not work!
+DEPEND="sys-libs/gdbm
+ >=dev-libs/ntl-5.5.2
+ >=dev-libs/boehm-gc-7.1
+ >=sci-mathematics/pari-2.3.4[gmp]
+ >=sys-libs/readline-6.0
+ dev-libs/libxml2
+ >=sci-mathematics/4ti2-1.3.2
+ >=sci-mathematics/normaliz-2.2
+ sci-mathematics/gfan
+ >=dev-libs/mpfr-2.4.1
+ =dev-libs/mpir-1.2.1[-nocxx]
+ sys-libs/gdbm
+ virtual/blas
+ virtual/lapack
+ dev-util/ctags
+ sys-libs/ncurses
+ sys-process/time
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=70Macaulay2-gentoo.el
+
+S="${WORKDIR}/1.3.1"
+
+src_unpack() {
+ subversion_src_unpack
+ # Patching .m2 files to look for external programs in
+ # /usr/bin
+ cd "${S}"
+ epatch "${FILESDIR}/paths-of-dependencies.patch"
+
+ mkdir "${S}/BUILD/tarfiles"
+ # Put sourcfile in the right location:
+ cp "${DISTDIR}/frobby_v0.8.2.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+ cp "${DISTDIR}/factory-3-1-0.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+ cp "${DISTDIR}/libfac-3-1-0.tar.gz" "${S}/BUILD/tarfiles/" \
+ || die "copy failed"
+
+ # Remove the external programs from built list,
+ # configure does not check for them
+ cd "${S}"
+ sed "s/4ti2 gfan normaliz//" -i configure.ac
+ eautoreconf
+
+}
+
+src_configure (){
+
+ # Recommended in bug #268064 Possibly unecessary
+ # but should not hurt anybody.
+ if ! use emacs; then
+ tags="ctags"
+ fi
+
+ ./configure --prefix="${D}/usr" --disable-encap \
+ || die "failed to configure Macaulay"
+}
+
+src_compile() {
+ # Parallel build not yet supported
+ emake -j1 || die "failed to build Macaulay"
+}
+
+src_test() {
+ make check || die "tests failed"
+}
+
+src_install () {
+
+ make install || die "install failed"
+
+ # nothing useful in here, get rid of it
+ # NOTE: Macaulay installs into lib even on amd64 hence don't
+ # replace lib with $(get_libdir) below!
+ rm -fr "${D}"/usr/lib \
+ || die "failed to remove empty /usr/lib"
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "If you want to set a hot key for Macaulay2 in Emacs add a line similar to"
+ elog "(global-set-key [ f12 ] 'M2)"
+ elog "in order to set it to F12 (or choose a different one)."
+ fi
+}
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/Macaulay2/Manifest b/sci-mathematics/Macaulay2/Manifest
index b94d63219..8a526427e 100644
--- a/sci-mathematics/Macaulay2/Manifest
+++ b/sci-mathematics/Macaulay2/Manifest
@@ -1,10 +1,13 @@
AUX 70Macaulay2-gentoo.el 57 RMD160 07b266ed45b28e5ebe7ee8e46ea73571a401dea3 SHA1 877ac4fd55e2b42922212bce587c2aa68e010bf2 SHA256 427d14300a958b0970837191006641f5e1c9952cf3492c640bc1e8c223b221f5
AUX patch-3.1.0b 399 RMD160 1f28f88c7e84ff2d6de35cc600ca03681db53436 SHA1 e5f27b2f2da9ad3c3f5456d9c625761ee6287ae6 SHA256 9cc468162ae6d94e5eab71ef77dd289c733ff575bc98cb5677f6eb8c89cd7e40
+AUX paths-of-dependencies.patch 2437 RMD160 9b63baeee97428406bed8bfbf67cf6fead95974a SHA1 cf245ad8bcdbe119e127242119b2b96342100035 SHA256 bffbaaf077f99f1e135fe0eff61be702c6eb138f4b4ae715cec8c5be62ee8046
DIST Macaulay2-1.2-r8438-src.tar.bz2 3198159 RMD160 bfd5fc5498e0ca7507277e9b2997d3b429a372df SHA1 c02b943a1cf43e74e566afa6a89c01e2f9f2e01c SHA256 ad28262a007afc6fa96afae2d3f294548d0376f39d4db0d2fb17cc43f23fc317
DIST factory-3-1-0.tar.gz 565374 RMD160 059ed1697f282d309e89d1cc2e0ce8bd94a8b4b3 SHA1 c41ab3cdc6ea51332169645e35c35c3fd6c4d94b SHA256 cb1768ccaaa71557ace880be0e88100bcfd420d3094ffac59d229cd852edc0ff
+DIST frobby_v0.8.2.tar.gz 746484 RMD160 3644813d14feea3e361c1669c3f5460e1fa0974e SHA1 0e75a0b78eeef43df491393a5c1fd1421b9e47d8 SHA256 aa6c686b00375283d125d6d5c2f4af40947a4ea2977c95e488c2339ab640353e
DIST frobby_vmike3.tar.gz 235794 RMD160 d9bf705895f4ccb8a1db9fd3909d4ae53fb05b08 SHA1 e478c0d0ac66f4d315ab246a1b2e0cb563991367 SHA256 98c58c0bb99f81344d1a647840f32e062923f2a45bf4cbafbf03ad1160e0a673
DIST libfac-3-1-0.tar.gz 91544 RMD160 2500d402328ad532756c677015c1d01f8594e394 SHA1 d005ddd58a180b8a91fe5728b96bde515c5d9cc5 SHA256 fc3dda08f7ec039635f8d7f1629546f4ac7620a69cf9332ca39e29dd822aee7d
EBUILD Macaulay2-1.2-r2.ebuild 3140 RMD160 4228497ba8c22038b496744c494c6ab0c808d90b SHA1 33ef56c4cbfe449e119d5b7fb1a2801421c5f30a SHA256 bfb59f0a752f4dd90ed87ade901010dc26d2fa6b5c70872638f898399072bb5c
EBUILD Macaulay2-1.2-r3.ebuild 2974 RMD160 cabf35edad035f139fd3a19ef66162d1791fac78 SHA1 89bf3bf6ec3c756855ee38f7f746aa6bd9dc2a7a SHA256 d9ac5a514993b57af7204319330734d164303bfa0db33bd11cb2fd07e7642bdc
-MISC ChangeLog 810 RMD160 2eaf46ae8cee98cb1a72f761a190575cb61d9088 SHA1 5ed628fd0f7cc09c7758caaa6384f0635abe0a45 SHA256 8cf6eef7ed58fc5c4f350f1ab79def9ac5c6bcf84f95167624c543238861b17c
+EBUILD Macaulay2-1.3.1.ebuild 3133 RMD160 792f25c1c259f2c493e5598369f1d3ce9df0a146 SHA1 ea69ff71764e1545e58fb9e2845b4ddfd553cde9 SHA256 97ab0e6b498037d2017761d75c7425f3a8607c37ef7fc5936236e1079af7050a
+MISC ChangeLog 893 RMD160 8ffe81cee10a7ef8641e47aa3a17bedb6972407e SHA1 3bcdf406af5ab3c6d239fb19b08d2c0593ab3210 SHA256 43cba25774ac5c9858af20e45ab4190d144a81d3b422bf07729c00a09b22aebe
MISC metadata.xml 361 RMD160 273db3a009b85938f85e60ea0d34d6fc625f9477 SHA1 7f6e903d81af55b08c7dbb9feb4f7ad39852a23e SHA256 71a0f19b08b1e752e754bbc5faf15880601d00c5b9df2bc5ca5a3b8e93e83b7f
diff --git a/sci-mathematics/Macaulay2/files/paths-of-dependencies.patch b/sci-mathematics/Macaulay2/files/paths-of-dependencies.patch
new file mode 100644
index 000000000..f8117a5fa
--- /dev/null
+++ b/sci-mathematics/Macaulay2/files/paths-of-dependencies.patch
@@ -0,0 +1,48 @@
+diff -rupN 1.3.1/Macaulay2/packages/FourTiTwo.m2 1.3.1-pathspatched/Macaulay2/packages/FourTiTwo.m2
+--- 1.3.1/Macaulay2/packages/FourTiTwo.m2 2009-11-12 18:40:50.000000000 +0100
++++ 1.3.1-pathspatched/Macaulay2/packages/FourTiTwo.m2 2009-11-16 11:41:01.000000000 +0100
+@@ -47,7 +47,7 @@ export {
+
+ path'4ti2 = (options FourTiTwo).Configuration#"path"
+ -- NOTE: the absolute path should be put into the .init file for 4ti2 inside the .Macaulay2 directory.
+-if path'4ti2 == "" then path'4ti2 = prefixDirectory | currentLayout#"programs"
++if path'4ti2 == "" then path'4ti2 = "/usr/bin/"
+
+ getFilename = () -> (
+ filename := temporaryFileName();
+diff -rupN 1.3.1/Macaulay2/packages/gfanInterface.m2 1.3.1-pathspatched/Macaulay2/packages/gfanInterface.m2
+--- 1.3.1/Macaulay2/packages/gfanInterface.m2 2009-11-12 18:40:50.000000000 +0100
++++ 1.3.1-pathspatched/Macaulay2/packages/gfanInterface.m2 2009-11-16 11:41:17.000000000 +0100
+@@ -26,7 +26,7 @@ export {
+ }
+
+ gfan'path = gfanInterface#Options#Configuration#"path"
+-if gfan'path == "" then gfan'path = prefixDirectory | currentLayout#"programs"
++if gfan'path == "" then gfan'path = "/usr/bin/"
+
+ fig2dev'path = gfanInterface#Options#Configuration#"fig2devpath"
+
+diff -rupN 1.3.1/Macaulay2/packages/Normaliz.m2 1.3.1-pathspatched/Macaulay2/packages/Normaliz.m2
+--- 1.3.1/Macaulay2/packages/Normaliz.m2 2009-11-12 18:40:50.000000000 +0100
++++ 1.3.1-pathspatched/Macaulay2/packages/Normaliz.m2 2009-11-16 11:42:01.000000000 +0100
+@@ -30,7 +30,7 @@ export{setNmzExecPath, getNmzExecPath,
+
+
+ -- initialising some values
+-nmzExecPath=prefixDirectory|currentLayout#"programs";
++nmzExecPath="/usr/bin/";
+ nmzDataPath="";
+ nmzFilename="";
+ nmzUserCalled=true; -- wether the user calls a method
+diff -rupN 1.3.1/Macaulay2/packages/StatePolytope.m2 1.3.1-pathspatched/Macaulay2/packages/StatePolytope.m2
+--- 1.3.1/Macaulay2/packages/StatePolytope.m2 2009-11-12 18:40:50.000000000 +0100
++++ 1.3.1-pathspatched/Macaulay2/packages/StatePolytope.m2 2009-11-16 11:41:13.000000000 +0100
+@@ -31,7 +31,7 @@ export {
+
+
+ gfanCommand = (options StatePolytope)#Configuration#"gfan command"
+-if gfanCommand === "gfan" then gfanCommand = prefixDirectory | currentLayout#"programs" | gfanCommand
++if gfanCommand === "gfan" then gfanCommand = "/usr/bin/" | gfanCommand
+ gfanCommand = "!" | gfanCommand
+
+ --The next two functions print out the ring and the ideal in the format required by gfan