aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens-Malte Gottfried <jmgottfried@web.de>2012-03-04 22:15:19 +0100
committerJens-Malte Gottfried <jmgottfried@web.de>2012-03-04 22:15:19 +0100
commit4b1440543f9105301337cd671a6e7e563db64b73 (patch)
tree2f680b805da46bebd0ecd36b7c05b91d4dcc9102 /sci-mathematics
parentgot sparse flag working (diff)
downloadsci-4b1440543f9105301337cd671a6e7e563db64b73.tar.gz
sci-4b1440543f9105301337cd671a6e7e563db64b73.tar.bz2
sci-4b1440543f9105301337cd671a6e7e563db64b73.zip
added superlu on activated hypre flag
since superlu is in the hypre depencencies anyway. Also switched to using the econf macro to have configure options displayed during build.
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/petsc/metadata.xml4
-rw-r--r--sci-mathematics/petsc/petsc-3.2_p6.ebuild13
2 files changed, 8 insertions, 9 deletions
diff --git a/sci-mathematics/petsc/metadata.xml b/sci-mathematics/petsc/metadata.xml
index 9bbff566d..10bb79f90 100644
--- a/sci-mathematics/petsc/metadata.xml
+++ b/sci-mathematics/petsc/metadata.xml
@@ -4,10 +4,10 @@
<herd>sci-mathematics</herd>
<use>
<flag name="afterimage">Use Afterstep image library (media-libs/libafterimage)</flag>
- <flag name="hypre">Use HYPRE (sci-mathematics/hypre) for preconditioning</flag>
+ <flag name="hypre">Use HYPRE (sci-mathematics/hypre) and superlu (sci-libs/superlu) for preconditioning</flag>
<flag name="metis">Use METIS (sci-libs/parmetis) for partitioning</flag>
<flag name="complex-scalars">Make scalars complex</flag>
- <flag name="sparse">Use cholmod and suitesparse for sparse factorization</flag>
+ <flag name="sparse">Use suitesparse (sci-libs/suitesparse) including cholmod (sci-libs/cholmod) for sparse factorization</flag>
<!-- Disabled:
<flag name="boost">Use boost (dev-libs/boost)</flag>
-->
diff --git a/sci-mathematics/petsc/petsc-3.2_p6.ebuild b/sci-mathematics/petsc/petsc-3.2_p6.ebuild
index 46a234471..23dc7cad0 100644
--- a/sci-mathematics/petsc/petsc-3.2_p6.ebuild
+++ b/sci-mathematics/petsc/petsc-3.2_p6.ebuild
@@ -30,11 +30,11 @@ RDEPEND="mpi? ( virtual/mpi[cxx?,fortran?] )
X? ( x11-libs/libX11 )
virtual/lapack
virtual/blas
- hypre? ( sci-libs/hypre )
+ hypre? ( sci-libs/hypre sci-libs/superlu )
metis? ( sci-libs/parmetis )
hdf5? ( sci-libs/hdf5 )
afterimage? ( media-libs/libafterimage )
- sparse? ( sci-libs/suitesparse sci-libs/cholmod )
+ sparse? ( sci-libs/suitesparse >=sci-libs/cholmod-1.7.0 )
"
# boost? ( dev-libs/boost )
# imagemagick? ( media-gfx/imagemagick )
@@ -98,8 +98,7 @@ src_configure(){
fi
# run petsc configure script
- ./configure \
- --prefix="${EPREFIX}/usr" \
+ econf \
CFLAGS="${CFLAGS}" \
CXXFLAGS="${CXXFLAGS}" \
LDFLAGS="${LDFLAGS}" \
@@ -129,14 +128,14 @@ src_configure(){
/usr/$(get_libdir)/libAfterImage.so /usr/include/libAfterImage) \
$(petsc_with hdf5) \
$(petsc_with hypre hypre /usr/$(get_libdir)/libHYPRE.so /usr/include/hypre) \
+ $(petsc_with hypre superlu /usr/$(get_libdir)/libsuperlu.so /usr/include/superlu) \
$(petsc_with metis parmetis) \
$(petsc_with sparse cholmod) \
$(petsc_with X x) \
$(petsc_with X x11) \
- --with-scotch=0 \
- ${EXTRA_ECONF} || die "configuration failed"
+ --with-scotch=0
-# failed dependencies, perhaps fixed in upstream:
+# failed dependencies, perhaps fixed in upstream soon:
# $(petsc_with boost) \
# $(petsc_with imagemagick imagemagick /usr/$(get_libdir)/libMagickCore.so /usr/include/ImageMagick) \
}