aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-21 16:04:41 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-21 16:04:41 +0200
commit504356161b1a444c8dae450cad83ba2253a3262d (patch)
tree15092054f831ed56b74e9468afd9e885fca3e336 /sci-mathematics
parentDrop obsolete Sources unavailable (diff)
downloadsci-504356161b1a444c8dae450cad83ba2253a3262d.tar.gz
sci-504356161b1a444c8dae450cad83ba2253a3262d.tar.bz2
sci-504356161b1a444c8dae450cad83ba2253a3262d.zip
sci-mathematics/axiom: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/axiom/Manifest2
-rw-r--r--sci-mathematics/axiom/axiom-201009.ebuild112
-rw-r--r--sci-mathematics/axiom/axiom-201408.ebuild68
-rw-r--r--sci-mathematics/axiom/files/noweb-2.9-insecure-tmp-file.Makefile.patch10
-rw-r--r--sci-mathematics/axiom/files/noweb-2.9-insecure-tmp-file.patch.input168
5 files changed, 69 insertions, 291 deletions
diff --git a/sci-mathematics/axiom/Manifest b/sci-mathematics/axiom/Manifest
index 59d55b018..d0c761738 100644
--- a/sci-mathematics/axiom/Manifest
+++ b/sci-mathematics/axiom/Manifest
@@ -1 +1 @@
-DIST axiom-sept2010-src.tgz 119714986 SHA256 b750350f065ad5db3edda228908728b83bf5fec100052a83eeebc628bc3ef4bf
+DIST axiom-aug2014-src.tgz 166822164 SHA256 b68faba6e02902cd1c62d837a18f07d70dfc3bd208a91637db2f66fd0a540fed SHA512 88a27967a6e0b4d5ab1beffeb8a3d0968c432f71258e8d21d77191e8ad79e77ba3c316850af976a52b28d4d05f1001fba39a966c6f008a89bf493569fb183be0 WHIRLPOOL a12cc62d4a2feddfa3ac5173edadd36c96d66d4eaf504a23c108f460624e243627a20a7bfaf911764af509d15593550ebbc9af668f5bee95cb42fe8356ba404c
diff --git a/sci-mathematics/axiom/axiom-201009.ebuild b/sci-mathematics/axiom/axiom-201009.ebuild
deleted file mode 100644
index 3cb0804a6..000000000
--- a/sci-mathematics/axiom/axiom-201009.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="Axiom is a general purpose Computer Algebra system"
-HOMEPAGE="http://axiom.axiom-developer.org/"
-SRC_URI="http://www.axiom-developer.org/axiom-website/downloads/${PN}-sept2010-src.tgz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-# NOTE: Do not strip since this seems to remove some crucial
-# runtime paths as well, thereby, breaking axiom
-RESTRICT="strip"
-
-# Seems to need a working version of pstricks package these days Bummer: <gmp-5 is needed for the
-# interal gcl, otherwise axiom will try to build an internal copy of gmp-4 which fails.
-RDEPEND="
- dev-libs/gmp
- x11-libs/libXaw"
-DEPEND="${RDEPEND}
- app-text/dvipdfm
- dev-texlive/texlive-pstricks
- sys-apps/debianutils
- sys-process/procps
- virtual/latex-base"
-
-S="${WORKDIR}"/${PN}
-
-## The following stuff seems to be fixed?
-
-# pkg_setup() {
-# # for 2.6.25 kernels and higher we need to have
-# # /proc/sys/kernel/randomize_va_space set to somthing other
-# # than 2, otherwise gcl fails to compile (see bug #186926).
-# local current_setting=$(/sbin/sysctl kernel.randomize_va_space 2>/dev/null | cut -d' ' -f3)
-# if [[ ${current_setting} == 2 ]]; then
-# echo
-# eerror "Your kernel has brk randomization enabled. This will"
-# eerror "cause axiom to fail to compile *and* run (see bug #186926)."
-# eerror "You can issue:"
-# eerror
-# eerror " /sbin/sysctl -w kernel.randomize_va_space=1"
-# eerror
-# eerror "as root to turn brk randomization off temporarily."
-# eerror "However, when not using axiom you may want to turn"
-# eerror "brk randomization back on via"
-# eerror
-# eerror " /sbin/sysctl -w kernel.randomize_va_space=2"
-# eerror
-# eerror "since it results in a less secure kernel."
-# die "Kernel brk randomization detected"
-# fi
-# }
-
-src_prepare() {
- ## How weird, axiom ships these patches, but does not apply them.
- ## So, we keep our gentoo patches around.
- cp "${FILESDIR}"/noweb-2.9-insecure-tmp-file.patch.input \
- "${S}"/zips/noweb-2.9-insecure-tmp-file.patch \
- || die "Failed to fix noweb"
-# cp "${FILESDIR}"/${PN}-200711-gcl-configure.patch \
-# "${S}"/zips/gcl-2.6.7.configure.in.patch \
-# || die "Failed to fix gcl-2.6.7 configure"
- epatch "${FILESDIR}"/noweb-2.9-insecure-tmp-file.Makefile.patch
-
- # lots of strict-aliasing badness
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
-## I believe 2.6.8_pre4 can be used now.
- # use gcl 2.6.7
-# sed -e "s:GCLVERSION=gcl-2.6.8pre$:GCLVERSION=gcl-2.6.7:" \
-# -i Makefile.pamphlet Makefile \
-# || die "Failed to select proper gcl"
-#
- # fix libXpm.a location
- sed -e "s:X11R6/lib:$(get_libdir):g" -i Makefile.pamphlet \
- || die "Failed to fix libXpm lib paths"
-
- # This will fix the internal gmp. This package will stay unkeyworded until this is resolved
- # upstream.
- unset ABI
-
- # Let the fun begin...
- AXIOM="${S}"/mnt/linux emake -j1
-}
-
-src_install() {
- emake DESTDIR="${ED}"/opt/axiom COMMAND="${ED}"/opt/axiom/mnt/linux/bin/axiom install
-
- mv "${ED}"/opt/axiom/mnt/linux/* "${ED}"/opt/axiom \
- || die "Failed to mv axiom into its final destination path."
- rm -fr "${ED}"/opt/axiom/mnt \
- || die "Failed to remove old directory."
-
- dosym ../../axiom/bin/axiom /usr/bin/axiom
-
- sed \
- -e "2d;3i AXIOM=/opt/axiom" \
- -i "${D}"/opt/axiom/bin/axiom \
- || die "Failed to patch axiom runscript!"
-
- dodoc changelog readme faq
-}
diff --git a/sci-mathematics/axiom/axiom-201408.ebuild b/sci-mathematics/axiom/axiom-201408.ebuild
new file mode 100644
index 000000000..ee5813606
--- /dev/null
+++ b/sci-mathematics/axiom/axiom-201408.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Axiom is a general purpose Computer Algebra system"
+HOMEPAGE="http://axiom.axiom-developer.org/"
+SRC_URI="http://axiom.axiom-developer.org/axiom-website/downloads/axiom-aug2014-src.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+# NOTE: Do not strip since this seems to remove some crucial
+# runtime paths as well, thereby, breaking axiom
+RESTRICT="strip"
+
+# Seems to need a working version of pstricks package these days Bummer: <gmp-5 is needed for the
+# interal gcl, otherwise axiom will try to build an internal copy of gmp-4 which fails.
+RDEPEND="
+ dev-libs/gmp:0=
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ app-text/dvipdfm
+ dev-texlive/texlive-pstricks
+ sys-apps/debianutils
+ sys-process/procps
+ virtual/latex-base"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ append-flags -fno-strict-aliasing
+}
+
+src_compile() {
+ sed -e "s:X11R6/lib:$(get_libdir):g" -i Makefile.pamphlet \
+ || die "Failed to fix libXpm lib paths"
+
+ # This will fix the internal gmp. This package will stay unkeyworded until this is resolved
+ # upstream.
+ unset ABI
+
+ # Let the fun begin...
+ AXIOM="${S}"/mnt/linux emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${ED}"/opt/axiom COMMAND="${ED}"/opt/axiom/mnt/linux/bin/axiom install
+
+ mv "${ED}"/opt/axiom/mnt/linux/* "${ED}"/opt/axiom \
+ || die "Failed to mv axiom into its final destination path."
+ rm -fr "${ED}"/opt/axiom/mnt \
+ || die "Failed to remove old directory."
+
+ dosym ../../axiom/bin/axiom /usr/bin/axiom
+
+ sed \
+ -e "2d;3i AXIOM=/opt/axiom" \
+ -i "${D}"/opt/axiom/bin/axiom \
+ || die "Failed to patch axiom runscript!"
+
+ dodoc changelog readme faq
+}
diff --git a/sci-mathematics/axiom/files/noweb-2.9-insecure-tmp-file.Makefile.patch b/sci-mathematics/axiom/files/noweb-2.9-insecure-tmp-file.Makefile.patch
deleted file mode 100644
index b8cd40ea0..000000000
--- a/sci-mathematics/axiom/files/noweb-2.9-insecure-tmp-file.Makefile.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile~ 2005-09-05 19:50:31.000000000 +0100
-+++ Makefile 2006-02-17 17:08:31.000000000 +0000
-@@ -85,6 +85,7 @@
- ${PATCH} <${ZIPS}/noweb.modules.c.patch ; \
- cd ${OBJ}/noweb/src ; \
- ${PATCH} <${ZIPS}/noweb.src.Makefile.patch ; \
-+ ${PATCH} -p0 <${ZIPS}/noweb-2.9-insecure-tmp-file.patch ; \
- ./awkname ${AWK} ; \
- ${ENV} ${MAKE} BIN=${MNT}/${SYS}/bin/lib LIB=${MNT}/${SYS}/bin/lib \
- MAN=${MNT}/${SYS}/bin/man \
diff --git a/sci-mathematics/axiom/files/noweb-2.9-insecure-tmp-file.patch.input b/sci-mathematics/axiom/files/noweb-2.9-insecure-tmp-file.patch.input
deleted file mode 100644
index 00288a8a3..000000000
--- a/sci-mathematics/axiom/files/noweb-2.9-insecure-tmp-file.patch.input
+++ /dev/null
@@ -1,168 +0,0 @@
---- awkname
-+++ awkname
-@@ -5,7 +5,7 @@
- esac
-
- rc=0
--new=/tmp/$$.new; old=/tmp/$$.old
-+new=$(tempfile -p new); old=$(tempfile -p old)
-
- for file in lib/emptydefn lib/unmarkup lib/toascii \
- awk/noidx awk/totex awk/tohtml awk/noindex \
---- awk/totex.nw
-+++ awk/totex.nw
-@@ -24,7 +24,7 @@
- @
- On an ugly system, we have to put it in a file.
- <<invoke awk program using file>>=
--awkfile=/tmp/totex$$.awk
-+awkfile=$(tempfile -p totex)
- trap 'rm -f $awkfile; exit 1' 0 1 2 15 # clean up files
- cat > $awkfile << 'EOF'
- <<awk program for conversion to {\TeX}>>
---- lib/toascii
-+++ lib/toascii
-@@ -7,9 +7,9 @@
- *) echo "This can't happen -- $i passed to toascii" 1>&2 ; exit 1 ;;
- esac
- done
--awkfile="tmp/awk$$.tmp"
--textfile="/tmp/text$$.tmp"
--tagsfile="/tmp/tags$$.tmp"
-+awkfile=$(tempfile -p awk -s .tmp)
-+textfile=$(tempfile -p text -s .tmp)
-+tagsfile=$(tempfile -p tags -s .tmp)
- export awkfile textfile tagsfile
- trap 'rm -f $awkfile $textfile $tagsfile' 0 1 2 10 14 15
- nawk 'BEGIN { textfile=ENVIRON["textfile"]
---- shell/cpif
-+++ shell/cpif
-@@ -17,7 +17,7 @@
- 0) echo 'Usage: '`basename $0`' [ -eq -ne ] file...' 1>&2; exit 2
- esac
-
--new=/tmp/$$
-+new=$(tempfile)
- trap 'rm -f $new; exit 1' 1 2 15 # clean up files
-
- cat >$new
---- shell/nonu
-+++ shell/nonu
-@@ -2,7 +2,7 @@
- LIB=/usr/public/pkg/noweb/lib
- # attempt to convert nuweb to noweb using sam
-
--tmp=/tmp/nonu$$
-+tmp=$(tempfile -p nonu)
- trap '/bin/rm -f $tmp; exit 1' 1 2 15 # clean up files
- cp $1 $tmp || exit 1
-
---- shell/roff.nw
-+++ shell/roff.nw
-@@ -80,7 +80,7 @@
- other, and quoting each quote is ugly. The pragmatic solution is to
- copy the awk program into a temporary file, using a shell here-document.
- <<invoke awk program>>=
--awkfile="/tmp/noweb$$.awk"
-+awkfile=$(tempfile -p noweb -s .awk)
- trap 'rm -f $awkfile' 0 1 2 10 14 15
- cat > $awkfile << 'EOF'
- <<awk program>>
-@@ -662,12 +662,13 @@
-
- base="`basename $1 | sed '/\./s/\.[^.]*$//'`"
- tagsfile="$base.nwt"
-+tmpfile=$(tempfile -p tags)
- (echo ".so $macrodir/tmac.w"
- if [ -r "$tagsfile" ]; then
-- cp $tagsfile /tmp/tags.$$
-+ cp $tagsfile $tmpfile
- $AWK '<<action for [[tags]] line>>
-- <<functions>>' /tmp/tags.$$
-- rm -f /tmp/tags.$$
-+ <<functions>>' $tmpfile
-+ rm -f $tmpfile
- fi
- cat "$@") |
- ($ROFF $opts 2>$tagsfile)
---- shell/noroff
-+++ shell/noroff
-@@ -35,9 +35,10 @@
-
- base="`basename $1 | sed '/\./s/\.[^.]*$//'`"
- tagsfile="$base.nwt"
-+tmpfile=$(tempfile -p tags)
- (echo ".so $macrodir/tmac.w"
- if [ -r "$tagsfile" ]; then
-- cp $tagsfile /tmp/tags.$$
-+ cp $tagsfile $tmpfile
- $AWK '{
- if (sub(/^###TAG### / , "")) tags[$1] = $2
- else if (sub(/^###BEGINCHUNKS###/, "")) printf ".de CLIST\n.CLISTBEGIN\n"
-@@ -88,8 +89,8 @@
- # print str3
- # print convquote(str3)
- # }
-- function tag(s) { if (s in tags) return tags[s]; else return "???" }' /tmp/tags.$$
-- rm -f /tmp/tags.$$
-+ function tag(s) { if (s in tags) return tags[s]; else return "???" }' $tmpfile
-+ rm -f $tmpfile
- fi
- cat "$@") |
- ($ROFF $opts 2>$tagsfile)
---- shell/toroff
-+++ shell/toroff
-@@ -9,7 +9,7 @@
- exit 1;;
- esac
- done
--awkfile="/tmp/noweb$$.awk"
-+awkfile=$(tempfile -p noweb -s .awk)
- trap 'rm -f $awkfile' 0 1 2 10 14 15
- cat > $awkfile << 'EOF'
- /^@begin docs 0$/ { if (delay) next }
---- lib/toascii.nw
-+++ lib/toascii.nw
-@@ -28,9 +28,9 @@
- Also arranged here is a temporary file for storage of the awk program on an
- ugly system, as discussed below.
- <<arrange temporary files>>=
--awkfile="tmp/awk$$.tmp"
--textfile="/tmp/text$$.tmp"
--tagsfile="/tmp/tags$$.tmp"
-+awkfile=$(tempfile -p awk -s .tmp) || { echo "$0: Cannot create temporary file" >&2; exit 1; }
-+textfile=$(tempfile -p text -s .tmp) || { echo "$0: Cannot create temporary file" >&2; exit 1; }
-+tagsfile=$(tempfile -p tags -s .tmp) || { echo "$0: Cannot create temporary file" >&2; exit 1; }
- export awkfile textfile tagsfile
- trap 'rm -f $awkfile $textfile $tagsfile' 0 1 2 10 14 15
- @ %def textfile tagsfile awkfile
---- shell/roff.mm
-+++ shell/roff.mm
-@@ -214,7 +214,7 @@
- .ADDLIST 1a
- .PRINTLIST
-
--awkfile="/tmp/noweb$$.awk"
-+awkfile=$(tempfile -p noweb -s .awk) || { echo "$0: Cannot create temporary file" >&2; exit 1; }
- trap 'rm -f $awkfile' 0 1 2 10 14 15
- cat > $awkfile \&<< 'EOF'
- \c
-@@ -1628,14 +1628,15 @@
- tagsfile="$base.nwt"
- (echo ".so $macrodir/tmac.w"
- if [ -r "$tagsfile" ]; then
-- cp $tagsfile /tmp/tags.$$
-+ tagstemp=$(tempfile -p tags) || { echo "$0: Cannot create temporary file" >&2; exit 1; }
-+ cp $tagsfile $tagstemp
- $AWK '\c
- .USE "action for \*[BEGINCONVQUOTE]tags\*[ENDCONVQUOTE] line" 11c
- \&
- \c
- .USE "functions" 8a
--\&' /tmp/tags.$$
-- rm -f /tmp/tags.$$
-+\&' $tagstemp
-+ rm -f $tagstemp
- fi
- cat "$@") |
- ($ROFF $opts 2>$tagsfile)