aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2014-08-03 10:55:23 +0200
committerlayman <layman@localhost>2014-08-03 10:55:23 +0200
commit9d554536bddca6aa5d766020a3513ec16bc5000b (patch)
treee33a6b16e4d0a7feaf24a33b26a3a34b8a6c61e3 /sci-mathematics
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-9d554536bddca6aa5d766020a3513ec16bc5000b.tar.gz
sci-9d554536bddca6aa5d766020a3513ec16bc5000b.tar.bz2
sci-9d554536bddca6aa5d766020a3513ec16bc5000b.zip
Install the .f90 fortran includes.
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/petsc/petsc-3.5.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-mathematics/petsc/petsc-3.5.1.ebuild b/sci-mathematics/petsc/petsc-3.5.1.ebuild
index e4ea76a57..bacf55e6c 100644
--- a/sci-mathematics/petsc/petsc-3.5.1.ebuild
+++ b/sci-mathematics/petsc/petsc-3.5.1.ebuild
@@ -165,7 +165,7 @@ src_configure() {
--with-imagemagick=0 \
--with-python=0 \
$(petsc_with boost) \
- $(petsc_with fftw) \
+ $(petsc_with fftw)
# not yet tested:
# python bindings, netcdf, fftw
@@ -188,7 +188,7 @@ src_install() {
doins ${PETSC_ARCH}/include/*
if use fortran; then
insinto /usr/include/${PN}/finclude
- doins include/finclude/*.h
+ doins -r include/finclude/*
fi
if ! use mpi ; then
insinto /usr/include/${PN}/mpiuni
@@ -219,6 +219,7 @@ src_install() {
doenvd 99petsc
dolib.so ${PETSC_ARCH}/lib/*.so
+ dolib.so ${PETSC_ARCH}/lib/*.so.*
if use doc ; then
einfo "installing documentation (this could take a while)"