aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-09 16:23:51 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-09 16:25:16 +0200
commitb111bc689a1bbd5a7b9e82d350b9e600fc6d2190 (patch)
tree3fc1893a0f382ce259cd42f4ebf1ec804b47b324 /sci-mathematics
parentsci-mathematics/gappa: Add multiprocessing.eclass for makeopts_jobs (diff)
downloadsci-b111bc689a1bbd5a7b9e82d350b9e600fc6d2190.tar.gz
sci-b111bc689a1bbd5a7b9e82d350b9e600fc6d2190.tar.bz2
sci-b111bc689a1bbd5a7b9e82d350b9e600fc6d2190.zip
sci-mathematics/gappa: add version 1.4.0
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gappa/Manifest1
-rw-r--r--sci-mathematics/gappa/gappa-1.4.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-mathematics/gappa/Manifest b/sci-mathematics/gappa/Manifest
index c250c9090..132e4af1c 100644
--- a/sci-mathematics/gappa/Manifest
+++ b/sci-mathematics/gappa/Manifest
@@ -1 +1,2 @@
DIST gappa-1.3.5.tar.gz 412527 BLAKE2B cf3dc69e9ef538cda7eee42c81dfa5cdfb765967745f68dabd5937cb00ea075f6c6b1614afefe10e7dfe69377ec5ba7f5fed5e4d45b45efd4362090a0bb136cb SHA512 60b5719e3a321df43e33045fa8f4511fc02a4218d1ae7e476e7c6ebcf90ae208832881f6eea5b99a3296dfcc3a18c7e1f4ea9dbea446fc502e14306b6975f6e6
+DIST gappa-1.4.0.tar.gz 387988 BLAKE2B f1c4666b3e3048686753a2cee12b64e7d8c4b2007723c364541458e127b0575836d0b831e2a837cb833b0b7d9a609ab708595ac9498d166a8ae67a566347a0f1 SHA512 fe8ee10b74a257b3df8d7c3fdb9095a10a7d5ee5af41b031d5bb9b981db00832a025bc1d6fce92f97f294fc9f3ab846531a864548e57e9fe191c79b828eb6475
diff --git a/sci-mathematics/gappa/gappa-1.4.0.ebuild b/sci-mathematics/gappa/gappa-1.4.0.ebuild
new file mode 100644
index 000000000..7395c8ea3
--- /dev/null
+++ b/sci-mathematics/gappa/gappa-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOCS_BUILDER="doxygen"
+DOCS_DIR="doc/doxygen"
+
+inherit docs multiprocessing
+
+DESCRIPTION="Verifying and proving properties on floating-point or fixed-point arithmetic"
+HOMEPAGE="https://gappa.gitlabpages.inria.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/38436/${P}.tar.gz"
+
+LICENSE="|| ( CeCILL-2 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ dev-libs/boost
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i Remakefile.in \
+ -e "s:mkdir -p @bindir@:mkdir -p \${DESTDIR}@bindir@:g" \
+ -e "s:cp src/gappa @bindir@:cp src/gappa \${DESTDIR}@bindir@:g" || die
+}
+
+src_compile() {
+ # Only accept number of parrellel jobs because remake does not understand --load-average
+ ./remake -d -j$(makeopts_jobs) || die "emake failed"
+ docs_compile
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install
+ einstalldocs
+}