aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-28 17:32:50 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-28 17:32:50 +0100
commitd2c004d8d6e33c536f7e6ec23231470208512205 (patch)
tree9fbc57b0e7b078cbd5fa3b539377af25d0e4fce0 /sci-mathematics
parentsci-physics/atompaw: install pdf docs unconditionally (diff)
downloadsci-d2c004d8d6e33c536f7e6ec23231470208512205.tar.gz
sci-d2c004d8d6e33c536f7e6ec23231470208512205.tar.bz2
sci-d2c004d8d6e33c536f7e6ec23231470208512205.zip
sci-mathematics/Oid: EAPI bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Oid/Manifest2
-rw-r--r--sci-mathematics/Oid/Oid-4.0.ebuild24
2 files changed, 14 insertions, 12 deletions
diff --git a/sci-mathematics/Oid/Manifest b/sci-mathematics/Oid/Manifest
index 109bdc2b8..dbc9c4bab 100644
--- a/sci-mathematics/Oid/Manifest
+++ b/sci-mathematics/Oid/Manifest
@@ -1,2 +1,2 @@
-DIST Oid4-0.tar.gz 244760 BLAKE2B 6acf06087bffac9bca6ed14bdd2319201e14d126b3299049ee713ebe87c00dfdc783559df06f2e8c1e56af469cdce296a42cb1927bae0b878a4c8187b67b7b9d SHA512 82d4039c3d8d499f7ad4e2df3626782c6c92629f141c12dd78b3b9d9175cfd3aeb0a4ed3a211e3aa7a6b0fec3b0b9112deb6c28c866013e1cf62cb165e786ef5
+DIST Oid-4.0.tar.gz 244760 BLAKE2B 6acf06087bffac9bca6ed14bdd2319201e14d126b3299049ee713ebe87c00dfdc783559df06f2e8c1e56af469cdce296a42cb1927bae0b878a4c8187b67b7b9d SHA512 82d4039c3d8d499f7ad4e2df3626782c6c92629f141c12dd78b3b9d9175cfd3aeb0a4ed3a211e3aa7a6b0fec3b0b9112deb6c28c866013e1cf62cb165e786ef5
DIST OidUserManual4-0.pdf 191264 BLAKE2B bddb1aa328195adb02d9ce25670a2c5c6feea5104168d7a4f65e2d69c0c106ac193dc63bc661c1efebc4feedbaf1db10cdf1fc41eb4d16dd26d2698e3f0e0776 SHA512 bccefaf64a9765bb3bf3927091f2d467e773c12b4694dcf7fd42d761545ad324a3bc4398ae5d3fdffef466e3731fcbc322016af9148cd81705df52d4da756043
diff --git a/sci-mathematics/Oid/Oid-4.0.ebuild b/sci-mathematics/Oid/Oid-4.0.ebuild
index bbc267637..ce967fd46 100644
--- a/sci-mathematics/Oid/Oid-4.0.ebuild
+++ b/sci-mathematics/Oid/Oid-4.0.ebuild
@@ -1,35 +1,38 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils java-pkg-2 versionator
+inherit java-pkg-2
-MY_PV=$(replace_version_separator 1 '-')
+MY_PV="${PV//./-}"
MY_P="${PN}${MY_PV}"
DESCRIPTION="An interactive, extensible software system for experimenting with matroids"
-HOMEPAGE="http://sites.google.com/site/wwwmatroids/"
+HOMEPAGE="https://sites.google.com/site/wwwmatroids/"
SRC_URI="
- http://sites.google.com/site/wwwmatroids/${MY_P}.tar.gz
- doc? ( http://sites.google.com/site/wwwmatroids/${PN}UserManual${MY_PV}.pdf )"
+ https://sites.google.com/site/wwwmatroids/${MY_P}.tar.gz -> ${P}.tar.gz
+ https://sites.google.com/site/wwwmatroids/${PN}UserManual${MY_PV}.pdf
+"
KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="GPL-2"
-IUSE="doc"
DEPEND=">=virtual/jdk-1.4:*"
RDEPEND=">=virtual/jre-1.4:*"
# The source uses 'enum' as an identifier, therefore:
JAVA_PKG_WANT_SOURCE="1.4"
+S="${WORKDIR}"
src_prepare () {
mkdir classes || die
-# change path names
+ # change path names
sed -i -e 's:NAME = ":NAME = "/usr/share/Oid/:' MatroidToolkit.java || die
+
+ default
}
src_compile () {
@@ -42,8 +45,7 @@ src_install () {
java-pkg_dojar Oid.jar
java-pkg_dolauncher
-
- use doc && dodoc "${DISTDIR}"/OidUserManual4-0.pdf
+ dodoc "${DISTDIR}"/OidUserManual4-0.pdf
insinto /usr/share/Oid
doins matroid*.txt