aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens-Malte Gottfried <jmgottfried@web.de>2012-03-06 23:15:51 +0100
committerJens-Malte Gottfried <jmgottfried@web.de>2012-03-06 23:15:51 +0100
commitd7f3beeed83c0f03321b18d832ab51406b2e6643 (patch)
treee3726c9bb670ea1b479ecb7692f9ac611d851c9a /sci-mathematics
parentsci-mathematics/petsc: more cleaning (diff)
downloadsci-d7f3beeed83c0f03321b18d832ab51406b2e6643.tar.gz
sci-d7f3beeed83c0f03321b18d832ab51406b2e6643.tar.bz2
sci-d7f3beeed83c0f03321b18d832ab51406b2e6643.zip
moved comments out of the argument list
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/petsc/petsc-3.2_p6.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/sci-mathematics/petsc/petsc-3.2_p6.ebuild b/sci-mathematics/petsc/petsc-3.2_p6.ebuild
index 51a35597f..b1ea99f99 100644
--- a/sci-mathematics/petsc/petsc-3.2_p6.ebuild
+++ b/sci-mathematics/petsc/petsc-3.2_p6.ebuild
@@ -48,7 +48,10 @@ DEPEND="${RDEPEND}
virtual/fortran
dev-lang/python
dev-util/pkgconfig
+ dev-util/cmake
"
+# cmake is used for parralel building
+# in some configuration setups, legacy build is used (slow)
S="${WORKDIR}/${MY_P}"
@@ -120,7 +123,6 @@ src_configure() {
--with-gnu-compilers \
--with-blas-lapack-lib="$(pkg-config --libs lapack)" \
$(petsc_enable debug debugging) \
- $(petsc_with imagemagick imagemagick /usr/include/ImageMagick $(pkg-config --libs MagickCore)) \
$(petsc_enable mpi) \
$(petsc_select mpi cc mpicc $(tc-getCC)) \
$(petsc_select mpi cxx mpicxx $(tc-getCXX)) \
@@ -132,17 +134,19 @@ src_configure() {
$(petsc_select complex-scalars scalar-type complex real) \
--with-windows-graphics=0 \
--with-matlab=0 \
- --with-python=0 \ # why not?
- --with-cmake=cmake \ # what for?
+ --with-cmake=cmake \
$(petsc_with afterimage afterimage /usr/include/libAfterImage -lAfterImage) \
$(petsc_with hdf5) \
$(petsc_with hypre hypre /usr/include/hypre -lHYPRE) \
+ $(petsc_with imagemagick imagemagick /usr/include/ImageMagick $(pkg-config --libs MagickCore)) \
$(petsc_with metis parmetis) \
$(petsc_with sparse cholmod) \
$(petsc_with superlu superlu /usr/include/superlu -lsuperlu) \
$(petsc_with X x) \
$(petsc_with X x11) \
- --with-scotch=0 # why not?
+ --with-python=0 \
+ --with-scotch=0
+ # not yet tested: python bindings, sctotch support
# failed dependencies, perhaps fixed in upstream soon:
# $(petsc_with boost) \
@@ -177,7 +181,6 @@ src_install() {
-e "s:usr/lib:usr/$(get_libdir):g" \
"${ED}"/usr/include/${PN}/${PETSC_ARCH}/include/petscconf.h || die
-
# add information about installation directory and
# PETSC_ARCH to environmental variables
cat >> 99petsc <<- EOF