aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-03-14 21:59:05 -0600
committerChristoph Junghans <ottxor@gentoo.org>2012-03-14 21:59:05 -0600
commitde03054b75a255eed6cb4e6110ac3c4fb84a2d26 (patch)
tree88d8813b33801a5a9fd87cae21c92d0d3f677587 /sci-mathematics
parentadd *-macos prefix support to gotblas2 (diff)
parentMake sci-mathematics/polymake work with gentoo-prefix. (diff)
downloadsci-de03054b75a255eed6cb4e6110ac3c4fb84a2d26.tar.gz
sci-de03054b75a255eed6cb4e6110ac3c4fb84a2d26.tar.bz2
sci-de03054b75a255eed6cb4e6110ac3c4fb84a2d26.zip
Merge branch 'polymake' of https://github.com/burcin/sci
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/polymake/Manifest1
-rw-r--r--sci-mathematics/polymake/files/2.10-soname.patch11
-rw-r--r--sci-mathematics/polymake/files/polymake-2.11-drop-jreality.patch25
-rw-r--r--sci-mathematics/polymake/polymake-2.11-r1.ebuild82
4 files changed, 119 insertions, 0 deletions
diff --git a/sci-mathematics/polymake/Manifest b/sci-mathematics/polymake/Manifest
new file mode 100644
index 000000000..19f4c38fa
--- /dev/null
+++ b/sci-mathematics/polymake/Manifest
@@ -0,0 +1 @@
+DIST polymake-2.11.tar.bz2 13249691 SHA256 232dd41f39ad7f67508c513ced2642f84f9e116b3613a790b57900a3dfce286d SHA512 2af0baa07b130fabc194367774a09cbf8714ba08b73b094c5562eb5132101553b1e1ff6378bed004591cd67b73341691ae9ba11945ca4f2036324603661f4958 WHIRLPOOL fe66d72ce84a7ec5f491658988d257ecf106e55bb100f5935a5fe5f2d8a802294f68f68c7d9c4038906d5712929eb8355158ffa121e4c151ac8f14c5263767bb
diff --git a/sci-mathematics/polymake/files/2.10-soname.patch b/sci-mathematics/polymake/files/2.10-soname.patch
new file mode 100644
index 000000000..14e66eaeb
--- /dev/null
+++ b/sci-mathematics/polymake/files/2.10-soname.patch
@@ -0,0 +1,11 @@
+--- polymake-2.10.fixed/support/corelib.make 2011-06-20 08:30:06.000000000 +0100
++++ polymake-2.10/support/corelib.make 2011-08-20 23:42:29.000000000 +0100
+@@ -89,7 +89,7 @@
+ ifneq (${LDcallableFlags},none)
+ # no explicit dependence on XSObjects here because they are built in compile-xs using the Makefile generated by xsubpp
+ ${CallableLib} : ${SharedObjects} ${CallableSharedObjects} ${GlueObjects} ${CallableGlueObjects} ${XXSObjects} $(patsubst %,${SourceDir}/perl/%.xs,${XSModules})
+- ${CXX} ${LDcallableFlags} -o $@ ${SharedObjects} ${CallableSharedObjects} ${GlueObjects} ${CallableGlueObjects} ${XXSObjects} ${XSObjects} ${LDFLAGS} ${PERLccdlflags} -lmpfr -lgmp ${LIBS} -L${PERLarchlib}/CORE -lperl
++ ${CXX} ${LDcallableFlags} -Wl,-soname,libpolymake.so.0 -o $@ ${SharedObjects} ${CallableSharedObjects} ${GlueObjects} ${CallableGlueObjects} ${XXSObjects} ${XSObjects} ${LDFLAGS} ${PERLccdlflags} -lmpfr -lgmp ${LIBS} -L${PERLarchlib}/CORE -lperl
+ else
+ ${CallableLib} : ${XXSObjects} $(patsubst %,${SourceDir}/perl/%.xs,${XSModules})
+ endif
diff --git a/sci-mathematics/polymake/files/polymake-2.11-drop-jreality.patch b/sci-mathematics/polymake/files/polymake-2.11-drop-jreality.patch
new file mode 100644
index 000000000..0eefe58ac
--- /dev/null
+++ b/sci-mathematics/polymake/files/polymake-2.11-drop-jreality.patch
@@ -0,0 +1,25 @@
+diff -U 3 -dHrN polymake-2.11.orig/Makefile polymake-2.11/Makefile
+--- polymake-2.11.orig/Makefile 2011-12-23 15:51:41.762207359 +0100
++++ polymake-2.11/Makefile 2011-12-23 15:52:13.889973019 +0100
+@@ -134,11 +134,11 @@
+ @case "$$(uname -s)" in \
+ *linux*|*Linux*) \
+ for d in linux32 linux64; do \
+- ${PERL} ${INSTALL_PL} -m ${DirMask} -U external/jreality/jni/$$d ${InstallArch}/lib/jreality/jni/$$d; \
++ true; \
+ done; \
+ ;; \
+ Darwin*|darwin*) \
+- ${PERL} ${INSTALL_PL} -m ${DirMask} -U external/jreality/jni/macosx ${InstallArch}/lib/jreality/jni/macosx; \
++ true; \
+ ;; \
+ esac
+ [ -d ${InstallBin} ] || $(call _CreateDir,${InstallBin})
+@@ -166,7 +166,6 @@
+ @+$(call _MakeApps, install-src)
+ $(if ${.svn},${CallPolymake} --no-config --script filter_rules -m ${InstallTop} ${Apps})
+ [ ! -d java_build ] || $(call _InstallSubdir,java_build,-X de)
+- [ ! -d java_build ] || $(call _InstallSubdirRenamed,external/jreality/lib,java_build/jreality/lib)
+ $(call _InstallSubdir,povray)
+ $(call _InstallSubdir,scripts)
+ $(call _InstallSubdir,xml)
diff --git a/sci-mathematics/polymake/polymake-2.11-r1.ebuild b/sci-mathematics/polymake/polymake-2.11-r1.ebuild
new file mode 100644
index 000000000..1512501a5
--- /dev/null
+++ b/sci-mathematics/polymake/polymake-2.11-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils flag-o-matic
+
+MY_PV=${PV}
+
+DESCRIPTION="research tool for polyhedral geometry and combinatorics"
+SRC_URI="http://polymake.org/lib/exe/fetch.php/download/${PN}-${MY_PV}.tar.bz2"
+HOMEPAGE="http://polymake.org"
+
+IUSE="libpolymake"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-libs/gmp
+ dev-libs/boost
+ dev-libs/libxml2:2
+ dev-perl/XML-LibXML
+ dev-libs/libxslt
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-Writer
+ dev-perl/Term-ReadLine-Gnu"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # embedded jreality is a precompiled desaster (bug #346073)
+ epatch "${FILESDIR}/${P}"-drop-jreality.patch
+ # Assign a soname
+ epatch "${FILESDIR}/2.10"-soname.patch
+ rm -rf java_build/jreality
+
+ # Don't strip
+ sed -i '/system "strip $to"/d' support/install.pl || die
+
+ einfo "During compile this package uses up to"
+ einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
+ einfo "you run into trouble."
+}
+
+src_configure () {
+ export CXXOPT=$(get-flag -O)
+ local myconf
+ if use libpolymake ; then
+ # WTF: If we leave myconf as the empty string here
+ # then configure will fail.
+ myconf="--without-prereq"
+ else
+ # --with-callable is not supported :(
+ myconf="--without-callable"
+ fi
+ echo ${myconf}
+ # Configure does not accept --host, therefore econf cannot be used
+ ./configure --prefix="${EPREFIX}/usr" \
+ --without-java \
+ --without-prereq \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/polymake" \
+ "${myconf}" || die
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_postinst(){
+ elog "Polymake uses Perl Modules compiled during install."
+ elog "You have to reinstall polymake after an upgrade of Perl."
+ elog " "
+ elog "This version of polymake does not ship docs. Sorry."
+ elog "Help can be found on http://www.opt.tu-darmstadt.de/polymake_doku/ "
+ elog " "
+ elog "Visualization in polymake is via jreality which ships pre-compiled"
+ elog "binary libraries. Until this situation is resolved, support for"
+ elog "jreality has been dropped. Please contribute to Bug #346073 to "
+ elog "make jreality available in Gentoo."
+}