aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-07-12 05:53:40 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-07-12 05:55:24 -0500
commitfcbf3687c7f71449e326be09015c1e7f6fb6d655 (patch)
treeadb4bad8c8674b6e5094067e023135028a9f0a7c /sci-mathematics
parentsci-mathematics/petsc: fix blas configuration error (diff)
downloadsci-fcbf3687c7f71449e326be09015c1e7f6fb6d655.tar.gz
sci-fcbf3687c7f71449e326be09015c1e7f6fb6d655.tar.bz2
sci-fcbf3687c7f71449e326be09015c1e7f6fb6d655.zip
sci-mathematics/petsc: also apply patches to 3.10.4 and 3.11.1
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/petsc/petsc-3.10.4.ebuild14
-rw-r--r--sci-mathematics/petsc/petsc-3.11.1.ebuild14
2 files changed, 10 insertions, 18 deletions
diff --git a/sci-mathematics/petsc/petsc-3.10.4.ebuild b/sci-mathematics/petsc/petsc-3.10.4.ebuild
index bc9a4b110..418196a8d 100644
--- a/sci-mathematics/petsc/petsc-3.10.4.ebuild
+++ b/sci-mathematics/petsc/petsc-3.10.4.ebuild
@@ -5,13 +5,11 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic fortran-2 python-any-r1 toolchain-funcs versionator
-
-MY_P="${PN}-$(replace_version_separator _ -)"
+inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs
DESCRIPTION="Portable, Extensible Toolkit for Scientific Computation"
HOMEPAGE="http://www.mcs.anl.gov/petsc/"
-SRC_URI="http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${MY_P}.tar.gz"
+SRC_URI="http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
@@ -54,8 +52,6 @@ DEPEND="${RDEPEND}
dev-util/cmake
"
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}"/${PN}-3.7.0-disable-rpath.patch \
"${FILESDIR}"/${PN}-3.9.0-fix_sandbox_violation.patch
@@ -83,7 +79,7 @@ petsc_with() {
shift 3
myuse="${myuse} --with-${p}-lib=$@"
else
- myuse="${myuse}"
+ myuse="${myuse} --with-${p}-dir=${EPREFIX}${3:-/usr}"
fi
else
myuse="--with-${p}=0"
@@ -143,7 +139,7 @@ src_configure() {
--with-petsc-arch=${PETSC_ARCH} \
--with-precision=double \
--with-gnu-compilers \
- --with-blas-lapack-lib="$($(tc-getPKG_CONFIG) --libs lapack)" \
+ --with-blas-lapack-lib="$($(tc-getPKG_CONFIG) --libs blas lapack)" \
$(petsc_enable debug debugging) \
$(petsc_enable mpi) \
$(petsc_select mpi cc mpicc $(tc-getCC)) \
@@ -154,7 +150,7 @@ src_configure() {
$(petsc_select complex-scalars scalar-type complex real) \
--with-windows-graphics=0 \
--with-matlab=0 \
- --with-cmake=true \
+ --with-cmake:BOOL=1 \
$(petsc_enable threads pthread) \
$(petsc_with afterimage afterimage \
/usr/include/libAfterImage -lAfterImage) \
diff --git a/sci-mathematics/petsc/petsc-3.11.1.ebuild b/sci-mathematics/petsc/petsc-3.11.1.ebuild
index e6517c680..99676386d 100644
--- a/sci-mathematics/petsc/petsc-3.11.1.ebuild
+++ b/sci-mathematics/petsc/petsc-3.11.1.ebuild
@@ -5,13 +5,11 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic fortran-2 python-any-r1 toolchain-funcs versionator
-
-MY_P="${PN}-$(replace_version_separator _ -)"
+inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs
DESCRIPTION="Portable, Extensible Toolkit for Scientific Computation"
HOMEPAGE="http://www.mcs.anl.gov/petsc/"
-SRC_URI="http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${MY_P}.tar.gz"
+SRC_URI="http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
@@ -54,8 +52,6 @@ DEPEND="${RDEPEND}
dev-util/cmake
"
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}"/${PN}-3.7.0-disable-rpath.patch \
"${FILESDIR}"/${PN}-3.9.0-fix_sandbox_violation.patch
@@ -83,7 +79,7 @@ petsc_with() {
shift 3
myuse="${myuse} --with-${p}-lib=$@"
else
- myuse="${myuse}"
+ myuse="${myuse} --with-${p}-dir=${EPREFIX}${3:-/usr}"
fi
else
myuse="--with-${p}=0"
@@ -143,7 +139,7 @@ src_configure() {
--with-petsc-arch=${PETSC_ARCH} \
--with-precision=double \
--with-gnu-compilers \
- --with-blas-lapack-lib="$($(tc-getPKG_CONFIG) --libs lapack)" \
+ --with-blas-lapack-lib="$($(tc-getPKG_CONFIG) --libs blas lapack)" \
$(petsc_enable debug debugging) \
$(petsc_enable mpi) \
$(petsc_select mpi cc mpicc $(tc-getCC)) \
@@ -154,7 +150,7 @@ src_configure() {
$(petsc_select complex-scalars scalar-type complex real) \
--with-windows-graphics=0 \
--with-matlab=0 \
- --with-cmake=true \
+ --with-cmake:BOOL=1 \
$(petsc_enable threads pthread) \
$(petsc_with afterimage afterimage \
/usr/include/libAfterImage -lAfterImage) \