aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Paccolat <chr.paccolat@mycable.ch>2012-12-03 14:18:53 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-03 08:25:05 +0100
commit8933ae04575f3bc41a535502523c0c7d01cc87ac (patch)
tree08315f3937354b0adb92df286d6c3b993a29a451 /sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild
parentMerge branch 'master' into zhou13-master (diff)
downloadsci-8933ae04575f3bc41a535502523c0c7d01cc87ac.tar.gz
sci-8933ae04575f3bc41a535502523c0c7d01cc87ac.tar.bz2
sci-8933ae04575f3bc41a535502523c0c7d01cc87ac.zip
sci-misc/elmer-meta: New ebuilds for Elmer FEM packages
Diffstat (limited to 'sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild')
-rw-r--r--sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild b/sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild
new file mode 100644
index 000000000..fafab98be
--- /dev/null
+++ b/sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit autotools eutils subversion
+
+ELMER_ROOT="elmerfem"
+MY_PN=${PN/elmer-/}
+
+DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, meshgen2d"
+HOMEPAGE="http://www.csc.fi/english/pages/elmer"
+#SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
+SRC_URI=""
+RESTRICT="mirror"
+ESVN_REPO_URI="https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk/${MY_PN}"
+ESVN_PROJECT="${MY_PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+DEPEND="sys-libs/glibc"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PV}/meshgen2d"
+
+src_prepare() {
+ #unpack ${A}
+ cd "${S}"
+ # configure must be executable
+ #chmod +x configure
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"
+ local myconf
+ export FC="gfortran"
+ export F77="gfortran"
+ use debug &&
+ myconf="${myconf} --with-debug" ||
+ myconf="${myconf} --without-debug"
+ econf $myconf || die "econf failed"
+}