aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
commit76ffb781ed7a917f23b67454e9f950e5e3b83527 (patch)
tree94fa8e1ddc7cb9ef80b78ea7896a5845f074f95b /sci-misc/finomaton/finomaton-1.0.ebuild
parentmove stuff to root (diff)
downloadsci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.gz
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.bz2
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.zip
moved overlay to new directory
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@979 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-misc/finomaton/finomaton-1.0.ebuild')
-rw-r--r--sci-misc/finomaton/finomaton-1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-misc/finomaton/finomaton-1.0.ebuild b/sci-misc/finomaton/finomaton-1.0.ebuild
new file mode 100644
index 000000000..e51d488ba
--- /dev/null
+++ b/sci-misc/finomaton/finomaton-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# N.B. this is from CTAN
+
+DESCRIPTION="Simple tcl/tk script to draw finite state automata"
+HOMEPAGE="http://stud4.tuwien.ac.at/~e0225855/finomaton/finomaton.html"
+SRC_URI="http://stud4.tuwien.ac.at/~e0225855/finomaton/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="examples"
+
+# script only
+DEPEND=""
+# tetex for metapost
+RDEPEND="app-text/tetex
+ >=dev-lang/tcl-8.3
+ >=dev-lang/tk-8.3"
+
+src_install() {
+ dobin finomaton.tcl
+ dodoc ChangeLog TODO README
+ if use examples ; then
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ for f in examples ; do
+ doins ${f}
+ done
+ fi
+}